summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-07-18 22:08:31 +0000
committerMike Frysinger <vapier@gentoo.org>2010-07-18 22:08:31 +0000
commit438c908afde7405fd081d4ff4666c8cb1a435823 (patch)
tree404e033d5ec3682e719a989fca0be36ce70de781 /app-shells/dash
parentconvert to eshopts_{push,pop} (diff)
downloadgentoo-2-438c908afde7405fd081d4ff4666c8cb1a435823.tar.gz
gentoo-2-438c908afde7405fd081d4ff4666c8cb1a435823.tar.bz2
gentoo-2-438c908afde7405fd081d4ff4666c8cb1a435823.zip
Version bump #327723 by Davide Pesavento.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/ChangeLog5
-rw-r--r--app-shells/dash/dash-0.5.6.1.ebuild55
2 files changed, 60 insertions, 0 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index f302a9153f98..322f5a6e6b0e 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/dash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+*dash-0.5.6.1 (18 Jul 2010)
+
+ 18 Jul 2010; Mike Frysinger <vapier@gentoo.org> +dash-0.5.6.1.ebuild:
+ Version bump #327723 by Davide Pesavento.
+
10 Jul 2010; Jeroen Roovers <jer@gentoo.org> dash-0.5.5.1.2.ebuild:
Stable for HPPA (bug #324753).
diff --git a/app-shells/dash/dash-0.5.6.1.ebuild b/app-shells/dash/dash-0.5.6.1.ebuild
new file mode 100644
index 000000000000..0165742e9e6c
--- /dev/null
+++ b/app-shells/dash/dash-0.5.6.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.6.1.ebuild,v 1.1 2010/07/18 22:08:31 vapier Exp $
+
+EAPI="2"
+
+inherit autotools eutils flag-o-matic
+
+DEB_PV=${PV%.*}
+DEB_PATCH=${PV##*.}
+DEB_PF="${PN}_${DEB_PV}.${DEB_PATCH}-1~exp0"
+MY_P="${PN}-${DEB_PV}"
+
+DESCRIPTION="DASH is a direct descendant of the NetBSD version of ash (the Almquist SHell) and is POSIX compliant"
+HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
+SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${PN}-${DEB_PV}.tar.gz
+ mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libedit static"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${WORKDIR}"/${DEB_PF}.diff
+ epatch */debian/diff/*
+
+ # Fix the invalid sort
+ sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
+
+ # Always statically link libedit in to ensure we always boot if it changes
+ # which it has done in the past.
+ local s="s/-ledit/-Wl,-Bstatic -ledit -Wl,-Bdynamic -lcurses/g"
+ use static && s="s/-ledit/-ledit -lcurses/g"
+ sed -i -e "${s}" configure.ac || die "Failed to sed configure.ac"
+
+ # May as well, as the debian patches force this anyway
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --bindir=/bin \
+ $(use_with libedit)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog */debian/changelog
+}