summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2003-12-19 18:40:57 +0000
committerChristian Birchinger <joker@gentoo.org>2003-12-19 18:40:57 +0000
commit12b5529ebf99827d9da43e7422eec78235012f72 (patch)
tree3301683cf695f1dc43dc7ec4b08326339ee16b84 /app-shells/bash-completion/bash-completion-20031215.ebuild
parentARCH cleanup and ~alpha keywords (bugs #34771, #34773) (diff)
downloadgentoo-2-12b5529ebf99827d9da43e7422eec78235012f72.tar.gz
gentoo-2-12b5529ebf99827d9da43e7422eec78235012f72.tar.bz2
gentoo-2-12b5529ebf99827d9da43e7422eec78235012f72.zip
Version bump
Diffstat (limited to 'app-shells/bash-completion/bash-completion-20031215.ebuild')
-rw-r--r--app-shells/bash-completion/bash-completion-20031215.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-shells/bash-completion/bash-completion-20031215.ebuild b/app-shells/bash-completion/bash-completion-20031215.ebuild
new file mode 100644
index 000000000000..8403776cb7d9
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20031215.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20031215.ebuild,v 1.1 2003/12/19 18:40:47 joker Exp $
+
+S=${WORKDIR}/${PN/-/_}
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~amd64"
+
+DEPEND="app-arch/tar
+ app-arch/bzip2"
+
+RDEPEND=">=app-shells/bash-2.05a"
+
+src_install() {
+ insinto /etc
+ doins bash_completion
+
+ insinto /etc/bash_completion.d
+
+ doins contrib/unrar
+ doins contrib/harbour
+ doins contrib/isql
+ doins contrib/larch
+ doins contrib/lilypond
+ doins contrib/p4
+ doins contrib/ri
+
+ newins ${FILESDIR}/gentoo.completion-${PVR/-r0/} gentoo
+
+ insinto /etc/profile.d
+ doins ${FILESDIR}/bash-completion
+
+ dodoc COPYING Changelog README
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+ echo
+
+ if [ -f /etc/bash_completion.d/gentoo.completion ]
+ then
+ echo
+ ewarn "The file 'gentoo.completion' in '/etc/bash_completion.d/' has been"
+ ewarn "replaced with 'gentoo'. Remove gentoo.completion to avoid problems."
+ echo
+ fi
+}