summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-10-14 14:57:34 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-10-14 14:57:34 +0000
commite00bf98d6d96fabf44b263e1011031ab3cc430e0 (patch)
tree5b11b0b3f5bff97cacc66e74ace17d24cee84aba /app-sci
parentFix digests (Manifest recommit) (diff)
downloadgentoo-2-e00bf98d6d96fabf44b263e1011031ab3cc430e0.tar.gz
gentoo-2-e00bf98d6d96fabf44b263e1011031ab3cc430e0.tar.bz2
gentoo-2-e00bf98d6d96fabf44b263e1011031ab3cc430e0.zip
Use gcc-getCC/CXX rather than CC/CXX.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/staden/ChangeLog5
-rw-r--r--app-sci/staden/staden-1.4.1-r7.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/app-sci/staden/ChangeLog b/app-sci/staden/ChangeLog
index 5a6759be2730..31d77dc4b9a4 100644
--- a/app-sci/staden/ChangeLog
+++ b/app-sci/staden/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/staden
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/staden/ChangeLog,v 1.11 2004/09/23 02:52:32 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/staden/ChangeLog,v 1.12 2004/10/14 14:57:34 ribosome Exp $
+
+ 14 Oct 2004; Olivier Fisette <ribosome@gentoo.org> staden-1.4.1-r7.ebuild:
+ Use gcc-getCC/CXX from gcc.eclass rather than ${CC/CXX}.
*staden-1.4.1-r7 (22 Sep 2004)
diff --git a/app-sci/staden/staden-1.4.1-r7.ebuild b/app-sci/staden/staden-1.4.1-r7.ebuild
index f8218a8e0a03..f0b87076a164 100644
--- a/app-sci/staden/staden-1.4.1-r7.ebuild
+++ b/app-sci/staden/staden-1.4.1-r7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/staden/staden-1.4.1-r7.ebuild,v 1.1 2004/09/23 02:52:32 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/staden/staden-1.4.1-r7.ebuild,v 1.2 2004/10/14 14:57:34 ribosome Exp $
-inherit eutils
+inherit eutils gcc
DESCRIPTION="The Staden Package - Biological sequence handling and analysis"
HOMEPAGE="http://${PN}.sourceforge.net/"
@@ -159,8 +159,8 @@ src_compile() {
MACHINE="linux" \
JOB="all" \
O="linux-binaries" \
- CC=${CC:-gcc} \
- CXX=${CXX:-g++} \
+ CC=$(gcc-getCC) \
+ CXX=$(gcc-getCXX) \
F77=${F77:-g77} \
|| die "Package compilation failed."
@@ -172,8 +172,8 @@ src_compile() {
MACHINE="linux" \
JOB="all" \
O="linux-binaries" \
- CC=${CC:-gcc} \
- CXX=${CXX:-g++} \
+ CC=$(gcc-getCC) \
+ CXX=$(gcc-getCXX) \
F77=${F77:-g77} \
|| die "Package compilation failed."