summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-09-21 11:19:34 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-09-21 11:19:34 +0000
commitd7b6b9c35c2cd42c4d96237d36afa9ac456d3481 (patch)
tree2a185776d37c7128b9f312d37509660cc1040177 /app-sci/qcad
parentadded ~amd64 keyword (Manifest recommit) (diff)
downloadgentoo-2-d7b6b9c35c2cd42c4d96237d36afa9ac456d3481.tar.gz
gentoo-2-d7b6b9c35c2cd42c4d96237d36afa9ac456d3481.tar.bz2
gentoo-2-d7b6b9c35c2cd42c4d96237d36afa9ac456d3481.zip
~amd64, gcc34 patch
Diffstat (limited to 'app-sci/qcad')
-rw-r--r--app-sci/qcad/ChangeLog6
-rw-r--r--app-sci/qcad/files/qcad-2.0.3.1-gcc34.patch14
-rw-r--r--app-sci/qcad/qcad-2.0.3.1-r1.ebuild7
3 files changed, 25 insertions, 2 deletions
diff --git a/app-sci/qcad/ChangeLog b/app-sci/qcad/ChangeLog
index 67b8ddb72ed3..632c8b89b529 100644
--- a/app-sci/qcad/ChangeLog
+++ b/app-sci/qcad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/qcad
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/ChangeLog,v 1.24 2004/06/24 22:15:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/ChangeLog,v 1.25 2004/09/21 11:19:34 kugelfang Exp $
+
+ 21 Sep 2004; Danny van Dyk <kugelfang@gentoo.org>
+ +files/qcad-2.0.3.1-gcc34.patch, qcad-2.0.3.1-r1.ebuild:
+ Marked ~amd64. Added patch to compile with gcc-3.4.x.
26 May 2004; Patrick Kursawe <phosphan@gentoo.org> qcad-2.0.3.1-r1.ebuild:
Stable for x86
diff --git a/app-sci/qcad/files/qcad-2.0.3.1-gcc34.patch b/app-sci/qcad/files/qcad-2.0.3.1-gcc34.patch
new file mode 100644
index 000000000000..4cab00958ea2
--- /dev/null
+++ b/app-sci/qcad/files/qcad-2.0.3.1-gcc34.patch
@@ -0,0 +1,14 @@
+--- qcadlib/src/math/rs_math.h.orig Sat Aug 21 20:00:56 2004
++++ qcadlib/src/math/rs_math.h Sat Aug 21 20:07:09 2004
+@@ -45,8 +45,9 @@
+ #include "rs_vector.h"
+
+ #ifdef __GNUC__
+-#define min(x,y) (x<y ? x : y)
+-#define max(x,y) (x>y ? x : y)
++//#define min(x,y) (x<y ? x : y)
++//#define max(x,y) (x>y ? x : y)
++using namespace std;
+ #endif
+
+ #define ARAD 57.29577951308232
diff --git a/app-sci/qcad/qcad-2.0.3.1-r1.ebuild b/app-sci/qcad/qcad-2.0.3.1-r1.ebuild
index b50431c323c7..41d9d16664a3 100644
--- a/app-sci/qcad/qcad-2.0.3.1-r1.ebuild
+++ b/app-sci/qcad/qcad-2.0.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/qcad-2.0.3.1-r1.ebuild,v 1.3 2004/06/24 22:15:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/qcad-2.0.3.1-r1.ebuild,v 1.4 2004/09/21 11:19:34 kugelfang Exp $
inherit kde-functions eutils
@@ -39,6 +39,11 @@ src_unpack() {
|| die "sed failed on assistant path"
sed -i -e "s:QCADDOCPATH:/usr/share/doc/${PF}/html:" \
qc_applicationwindow.cpp || die "sed failed on manual path"
+
+ cd ${S}
+
+ # This patch allows compilation with gcc-3.4
+ epatch ${FILESDIR}/${P}-gcc34.patch
}