summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2003-12-15 03:54:16 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2003-12-15 03:54:16 +0000
commit12d789a61be22a7ffbbf2fbd84859adf1df4d18e (patch)
treed79f9ea953d49c3947b7a2ae309ead3acc85ddb2 /app-sci/mpqc
parentmark stable on amd64 (diff)
downloadgentoo-2-12d789a61be22a7ffbbf2fbd84859adf1df4d18e.tar.gz
gentoo-2-12d789a61be22a7ffbbf2fbd84859adf1df4d18e.tar.bz2
gentoo-2-12d789a61be22a7ffbbf2fbd84859adf1df4d18e.zip
Version bump.
Diffstat (limited to 'app-sci/mpqc')
-rw-r--r--app-sci/mpqc/ChangeLog7
-rw-r--r--app-sci/mpqc/Manifest6
-rw-r--r--app-sci/mpqc/files/digest-mpqc-2.2.01
-rw-r--r--app-sci/mpqc/mpqc-2.2.0.ebuild41
4 files changed, 52 insertions, 3 deletions
diff --git a/app-sci/mpqc/ChangeLog b/app-sci/mpqc/ChangeLog
index 0fd8f0ad6774..602fc3ef3354 100644
--- a/app-sci/mpqc/ChangeLog
+++ b/app-sci/mpqc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/mpqc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/ChangeLog,v 1.3 2003/02/12 05:17:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/ChangeLog,v 1.4 2003/12/15 03:54:07 spyderous Exp $
+
+*mpqc-2.2.0 (14 Dec 2003)
+
+ 14 Dec 2003; Donnie Berkholz <spyderous@gentoo.org>; mpqc-2.2.0.ebuild:
+ Version bump.
02 Nov 2002; Hannes Mehnert <hannes@gentoo.org> mpqc-2.1.2.ebuild:
marked stable for x86
diff --git a/app-sci/mpqc/Manifest b/app-sci/mpqc/Manifest
index 23c2ab810682..4f225ecf54c0 100644
--- a/app-sci/mpqc/Manifest
+++ b/app-sci/mpqc/Manifest
@@ -1,4 +1,6 @@
-MD5 dc5b3c76bf2bddcff81ac9b0ec817d86 files/digest-mpqc-2.1.2 129
+MD5 37eae83e830979d3545ee2cbdc2652a3 ChangeLog 546
MD5 4a91be5896aaa494a9fbb8ebf7e6b59e mpqc-2.1.2.ebuild 1347
-MD5 459f2c2576a872f4dbfb347e516dc1ff ChangeLog 425
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 190f129210b741d1c754f5fd41dc125b mpqc-2.2.0.ebuild 1351
+MD5 dc5b3c76bf2bddcff81ac9b0ec817d86 files/digest-mpqc-2.1.2 129
+MD5 2d921846894e05077abfbb0eada2d6a3 files/digest-mpqc-2.2.0 63
diff --git a/app-sci/mpqc/files/digest-mpqc-2.2.0 b/app-sci/mpqc/files/digest-mpqc-2.2.0
new file mode 100644
index 000000000000..ac788a7d87aa
--- /dev/null
+++ b/app-sci/mpqc/files/digest-mpqc-2.2.0
@@ -0,0 +1 @@
+MD5 7506b2d1fc4050d2587e5783086fc652 mpqc-2.2.0.tar.gz 2197481
diff --git a/app-sci/mpqc/mpqc-2.2.0.ebuild b/app-sci/mpqc/mpqc-2.2.0.ebuild
new file mode 100644
index 000000000000..5562ded8e51e
--- /dev/null
+++ b/app-sci/mpqc/mpqc-2.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.2.0.ebuild,v 1.1 2003/12/15 03:54:07 spyderous Exp $
+
+DESCRIPTION="The Massively Parallel Quantum Chemistry Program"
+HOMEPAGE="http://aros.ca.sandia.gov/~cljanss/mpqc/"
+SRC_URI="http://aros.ca.sandia.gov/~cljanss/mpqc/distrib/${P}.tar.gz
+ doc? ( http://aros.ca.sandia.gov/~cljanss/mpqc/distrib/${PN}-man-${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc X"
+
+DEPEND="sys-devel/flex
+ app-sci/blas
+ app-sci/lapack
+ dev-lang/perl
+ X? ( x11-base/xfree )"
+
+src_compile() {
+ CFLAGS_SAVE=${CFLAGS}; CXXFLAGS_SAVE=${CXXFLAGS}
+ myconf="${myconf} --prefix=/usr"
+ use X && myconf="${myconf} --x-includes=/usr/X11R6/include \
+ --x-libraries=/usr/X11R6/lib"
+ ./configure ${myconf}
+ sed -e "s:^CFLAGS =.*$:CFLAGS=${CFLAGS_SAVE}:" \
+ -e "s:^FFLAGS =.*$:FFLAGS=${CFLAGS_SAVE}:" \
+ -e "s:^CXXFLAGS =.*$:CXXFLAGS=${CXXFLAGS_SAVE}:" \
+ lib/LocalMakefile > lib/LocalMakefile.foo
+ mv lib/LocalMakefile.foo lib/LocalMakefile
+ emake
+}
+
+src_install() {
+ sed -e "s:^prefix=.*$:prefix=${D}/usr:" lib/LocalMakefile \
+ > lib/LocalMakefile.foo
+ mv lib/LocalMakefile.foo lib/LocalMakefile
+ use doc && doman ${WORKDIR}/${PN}-man-${PV}/man3/*
+ make install install_devel install_inc
+}