summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Bienstman <pbienst@gentoo.org>2004-03-03 17:31:32 +0000
committerPeter Bienstman <pbienst@gentoo.org>2004-03-03 17:31:32 +0000
commite9d5e31710086470da6b60024e73aaf8330703b3 (patch)
tree0acd90090ee56008610b855aec0bb0301ffdddd9 /app-sci/ginac/ginac-1.1.6.ebuild
parentheader fix (Manifest recommit) (diff)
downloadgentoo-2-e9d5e31710086470da6b60024e73aaf8330703b3.tar.gz
gentoo-2-e9d5e31710086470da6b60024e73aaf8330703b3.tar.bz2
gentoo-2-e9d5e31710086470da6b60024e73aaf8330703b3.zip
add version 1.1.6
Diffstat (limited to 'app-sci/ginac/ginac-1.1.6.ebuild')
-rw-r--r--app-sci/ginac/ginac-1.1.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-sci/ginac/ginac-1.1.6.ebuild b/app-sci/ginac/ginac-1.1.6.ebuild
new file mode 100644
index 000000000000..a8788b3b7c7a
--- /dev/null
+++ b/app-sci/ginac/ginac-1.1.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ginac/ginac-1.1.6.ebuild,v 1.1 2004/03/03 17:31:32 pbienst Exp $
+
+IUSE=""
+
+inherit flag-o-matic
+
+Name="GiNaC"
+S=${WORKDIR}/${Name}-${PV}
+
+DESCRIPTION="GiNaC : a free CAS (computer algebra system)"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/${Name}-${PV}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="dev-libs/cln"
+
+src_compile() {
+ filter-flags "-funroll-loops -frerun-loop-opt"
+ econf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}