summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Diener <sediener@gentoo.org>2003-08-02 05:27:40 +0000
committerStephen Diener <sediener@gentoo.org>2003-08-02 05:27:40 +0000
commit941c998d565d00d4ef1c50dc30f28f67d96d73cf (patch)
tree3ebdb9c43c77db021684fb496fb1b03468b8050b /app-sci/bioperl
parentNew Bioperl version 1.2.2 - (diff)
downloadgentoo-2-941c998d565d00d4ef1c50dc30f28f67d96d73cf.tar.gz
gentoo-2-941c998d565d00d4ef1c50dc30f28f67d96d73cf.tar.bz2
gentoo-2-941c998d565d00d4ef1c50dc30f28f67d96d73cf.zip
New Bioperl version 1.2.2 -
Diffstat (limited to 'app-sci/bioperl')
-rw-r--r--app-sci/bioperl/ChangeLog9
-rw-r--r--app-sci/bioperl/Manifest4
-rw-r--r--app-sci/bioperl/bioperl-1.2.2.ebuild81
-rw-r--r--app-sci/bioperl/files/biodbgff-enable-1.2.2.patch98
-rw-r--r--app-sci/bioperl/files/digest-bioperl-1.2.21
-rw-r--r--app-sci/bioperl/files/domanpages-1.2.2.patch19
6 files changed, 209 insertions, 3 deletions
diff --git a/app-sci/bioperl/ChangeLog b/app-sci/bioperl/ChangeLog
index 03a0017c9434..6dcb7d3fbd6f 100644
--- a/app-sci/bioperl/ChangeLog
+++ b/app-sci/bioperl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-sci/bioperl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/bioperl/ChangeLog,v 1.3 2003/04/25 23:27:45 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/bioperl/ChangeLog,v 1.4 2003/08/02 05:27:28 sediener Exp $
+
+*bioperl-1.2.2 (02 Aug 2003)
+
+ 02 Aug 2003; Stephen Diener <sediener@gentoo.org> bioperl-1.2.2.ebuild,
+ files/biodbgff-enable-1.2.2.patch, files/domanpages-1.2.2.patch:
+ New Version thanks to Gontran Zepeda <gontran@gontran.net> in bug# 24467 :
+ Also fixes bug# 25079
*bioperl-1.2 (24 Apr 2003)
diff --git a/app-sci/bioperl/Manifest b/app-sci/bioperl/Manifest
index 9f820e7db3ef..f3a853e70559 100644
--- a/app-sci/bioperl/Manifest
+++ b/app-sci/bioperl/Manifest
@@ -1,7 +1,7 @@
-MD5 20489a52a06a7d294835399cdba0b36b ChangeLog 867
+MD5 d83f077ff4deca282a614098204649d5 ChangeLog 870
MD5 8e47663b52056acabfe389fff6515abd bioperl-1.0.2.ebuild 1549
MD5 4b53e5b83a67807a46ba90f2260fddb0 bioperl-1.2.ebuild 1572
-MD5 3080cf994c822ff44016b90b379ab3c9 bioperl-1.2.2.ebuild 2174
+MD5 5bd49c63392ef31a2e57d49237a129ca bioperl-1.2.2.ebuild 2275
MD5 1828ff2ba6225e17a98d27bfbad5c7c9 files/bioperl-1.2-manpage.diff 712
MD5 dfdb9921cbef92f60e9746a9531d8de7 files/digest-bioperl-1.0.2 66
MD5 14b9e16331895fe40e231065f7dda942 files/digest-bioperl-1.2 64
diff --git a/app-sci/bioperl/bioperl-1.2.2.ebuild b/app-sci/bioperl/bioperl-1.2.2.ebuild
new file mode 100644
index 000000000000..9c9e44d15133
--- /dev/null
+++ b/app-sci/bioperl/bioperl-1.2.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/bioperl/bioperl-1.2.2.ebuild,v 1.1 2003/08/02 05:27:28 sediener Exp $
+
+IUSE="mysql gd"
+
+inherit perl-module
+
+S=${WORKDIR}/${P}
+CATEGORY="app-sci"
+
+DESCRIPTION="The Bioperl Project is a collection of tools for bioinformatics, genomics and life science research."
+#SRC_URI="http://www.cpan.org/modules/by-module/Bio/${P}.tar.gz"
+SRC_URI="http://www.bioperl.org/ftp/DIST/${P}.tar.gz"
+HOMEPAGE="http://www.bioperl.org/"
+
+SLOT="0"
+LICENSE="Artistic GPL-2"
+KEYWORDS="~x86"
+
+#DEPEND=${DEPEND}
+DEPEND="${DEPEND}
+ dev-perl/File-Temp
+ dev-perl/HTML-Parser
+ dev-perl/IO-String
+ dev-perl/IO-stringy
+ dev-perl/SOAP-Lite
+ dev-perl/Storable
+ dev-perl/XML-DOM
+ dev-perl/XML-Parser
+ dev-perl/XML-Writer
+ dev-perl/XML-Twig
+ dev-perl/libxml-perl
+ dev-perl/libwww-perl
+ dev-perl/Graph
+ dev-perl/Text-Shellwords
+ gd? ( >=dev-perl/GD-1.32-r1 )
+ mysql? ( >=dev-perl/DBD-mysql-2.1004-r3 )"
+RDEPEND=${RDEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # remove interactiveness
+ [ -n "`use mysql`" ] && epatch ${FILESDIR}/biodbgff-enable-${PV}.patch
+ # want man pages in addition to perldoc documentation??
+ #epatch ${FILESDIR}/domanpages-${PV}.patch
+}
+
+src_compile() {
+ # there's a test to run for BioGFFDB if using mysql
+ perl-module_src_compile || die "compile failed"
+ # make test
+## perl-module_src_test || die "src test failed"
+}
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+ # get the bptutorial installed and executeable
+ dodir /usr/bin
+ dosym /usr/lib/perl5/site_perl/5.8.0/bptutorial.pl /usr/bin/bptutorial.pl
+ fperms +x /usr/lib/perl5/site_perl/5.8.0/bptutorial.pl
+
+ # bioperl scripts and examples
+ einfo 'Adding bioperl examples and scripts to /usr/share/...'
+ dodir /usr/share/${PF}/scripts
+ #insinto /usr/share/${PF}/scripts
+ cd ${S}/scripts/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/scripts; tar xf -)
+ dodir /usr/share/${PF}/examples
+ cd ${S}/examples/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/examples; tar xf -)
+ cd ${S}
+
+ # some pods in maindir
+ eval `perl '-V:installsitelib'`
+ MY_SITE_LIB=${installsitelib}
+ insinto ${MY_SITE_LIB}
+ doins biodatabases.pod biodesign.pod bioperl.pod bioscripts.pod
+}
diff --git a/app-sci/bioperl/files/biodbgff-enable-1.2.2.patch b/app-sci/bioperl/files/biodbgff-enable-1.2.2.patch
new file mode 100644
index 000000000000..7bd66206a0b4
--- /dev/null
+++ b/app-sci/bioperl/files/biodbgff-enable-1.2.2.patch
@@ -0,0 +1,98 @@
+--- Makefile.PL.orig 2003-07-14 16:09:49.000000000 +0100
++++ Makefile.PL 2003-07-14 16:15:56.000000000 +0100
+@@ -83,9 +83,6 @@
+ # Prompt user for BioDBGFF stuff
+ #
+
+-if( eval { require DBI } && grep {/mysql/} DBI->available_drivers) {
+- my $proceed = prompt("Do you want to run the BioDBGFF tests (requires a mysql database) y/n",'n');
+- if( $proceed =~ /^[yY]/) {
+ my $cfg = {dbd_driver => 'mysql'};
+ GFFQueryDb($cfg,{'prompt'=>1,'verbose'=>1});
+ if (open T,">t/do_biodbgff.tests") {
+@@ -94,13 +91,6 @@
+ }
+ close T;
+ }
+- } else {
+- if( -e "t/do_biodbgff.tests" ) {
+- unlink "t/do_biodbgff.tests";
+- }
+- }
+-}
+-
+
+ ############################################################################
+ #
+@@ -124,55 +114,27 @@
+ my $d = lc $driver;
+ my $prompt = $options->{'prompt'};
+
+- my $test_db = exists($options->{"$d-test-db"}) ?
+- $options->{"$d-test-db"} : ($cfg->{'test_db'} || 'test');
+- $test_db = prompt
+- ("Which database should I use for testing the $db drivers?",
+- $test_db) if $prompt;
+-
+- my $test_host = exists($options->{"$d-test-host"}) ?
+- $options->{"$d-test-host"} : ($cfg->{'test_host'} || 'localhost');
+- $test_host = prompt
+- ("On which host is database $test_db running (hostname, ip address or host:port)", $test_host) if $prompt;
+-
+- my($test_user, $test_pass);
+-
+- $test_user = exists($options->{"$d-test-user"}) ?
+- $options->{"$d-test-user"} : ($cfg->{'test_user'} || "undef");
+- $test_user = prompt
+- ("User name for connecting to database $test_db?", $test_user)
+- if $prompt;
+- $test_user = undef if $test_user eq 'undef';
+-
+- $test_pass = exists($options->{"$d-test-pass"}) ?
+- $options->{"$d-test-pass"} : ($cfg->{'test_pass'} || "undef");
+- $test_pass = prompt
+- ("Password for connecting to database $test_db?", $test_pass)
+- if $prompt;
+- $test_pass = undef if $test_pass eq 'undef';
+-
+- $cfg->{'test_db'} = $test_db;
+- $cfg->{'test_host'} = $test_host;
+- $cfg->{'test_user'} = $test_user;
+- $cfg->{'test_pass'} = $test_pass;
+- if ($test_host eq 'undef' || $test_host eq 'localhost') {
+- $test_host = '';
+- }
+- my $test_dsn = "DBI:$driver:database=$test_db";
+- $cfg->{test_dsn} = $test_dsn;
+- if ($test_host) {
+- $cfg->{'test_dsn'} .= ";host=$test_host";
+- }
++ $options->{"$d-test-db"} = 'test';
++ $options->{"$d-test-host"} = 'localhost';
++ $options->{"$d-test-user"} = n0b0dy;
++ $options->{"$d-test-pass"} = undef;
++
++ $cfg->{'test_db'} = $options->{"$d-test-db"};
++ $cfg->{'test_host'} = $options->{"$d-test-host"};
++ $cfg->{'test_user'} = $options->{"$d-test-user"};
++ $cfg->{'test_pass'} = $options->{"$d-test-pass"};
+
++ my $test_dsn = "DBI:$driver:database=" . $cfg->{test_db};
++ $cfg->{'test_dsn'} = $test_dsn;
+
+ if ($options->{'verbose'}) {
+ local $^W=0; # some uninitialized variable warning coming through
+ print("Driver $driver is using the following settings for tests:\n",
+- " Database $test_db\n",
+- " Host $test_host\n",
+- " DSN $test_dsn\n",
+- " User $test_user\n",
+- " Password $test_pass\n");
++ " Database ".$cfg->{test_db}. "\n",
++ " Host ".$cfg->{test_host}."\n",
++ " DSN ".$cfg->{test_dsn}. "\n",
++ " User ".$cfg->{test_user}."\n",
++ " Password ".$cfg->{test_pass}."\n");
+ }
+ }
+
diff --git a/app-sci/bioperl/files/digest-bioperl-1.2.2 b/app-sci/bioperl/files/digest-bioperl-1.2.2
new file mode 100644
index 000000000000..f9d1b2b95180
--- /dev/null
+++ b/app-sci/bioperl/files/digest-bioperl-1.2.2
@@ -0,0 +1 @@
+MD5 c630a5f13a452a65cfa1cbbed1d10378 bioperl-1.2.2.tar.gz 3585206
diff --git a/app-sci/bioperl/files/domanpages-1.2.2.patch b/app-sci/bioperl/files/domanpages-1.2.2.patch
new file mode 100644
index 000000000000..14cbe35de59a
--- /dev/null
+++ b/app-sci/bioperl/files/domanpages-1.2.2.patch
@@ -0,0 +1,19 @@
+--- Makefile.PL.orig 2003-07-14 17:31:03.000000000 +0100
++++ Makefile.PL 2003-07-14 17:31:15.000000000 +0100
+@@ -270,16 +270,3 @@
+ },
+ );
+
+-
+-sub MY::manifypods {
+- my $self = shift;
+- #print STDERR "In manifypods moment\n";
+- if( 1 ) {
+- return "\nmanifypods : pure_all\n\t$self->{NOECHO}\$(NOOP)\n"
+- }
+- else {
+- return $self->SUPER::manifypods(@_);
+- }
+- }
+-
+-