summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2006-06-02 07:35:26 +0000
committerHarald van Dijk <truedfx@gentoo.org>2006-06-02 07:35:26 +0000
commiteca931cdb605ad820bca5349a3f66283113c96b6 (patch)
tree67d4bf7afde3d23d213a43f04a2f39e8dbc860de /app-portage
parentPatched Makefiles so they don't strip binaries, bug #135208. (diff)
downloadgentoo-2-eca931cdb605ad820bca5349a3f66283113c96b6.tar.gz
gentoo-2-eca931cdb605ad820bca5349a3f66283113c96b6.tar.bz2
gentoo-2-eca931cdb605ad820bca5349a3f66283113c96b6.zip
Fix 'source' support
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/ufed/ChangeLog8
-rw-r--r--app-portage/ufed/files/digest-ufed-0.40-r31
-rw-r--r--app-portage/ufed/files/ufed-0.40-source.patch27
-rw-r--r--app-portage/ufed/ufed-0.40-r3.ebuild39
4 files changed, 67 insertions, 8 deletions
diff --git a/app-portage/ufed/ChangeLog b/app-portage/ufed/ChangeLog
index 9cd83b1cd35c..97e458d41597 100644
--- a/app-portage/ufed/ChangeLog
+++ b/app-portage/ufed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/ufed
# Copyright 2003-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.43 2006/05/23 05:12:13 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.44 2006/06/02 07:35:26 truedfx Exp $
+
+*ufed-0.40-r3 (02 Jun 2006)
+
+ 02 Jun 2006; Harald van Dijk <truedfx@gentoo.org>
+ files/ufed-0.40-source.patch, -ufed-0.40-r2.ebuild, +ufed-0.40-r3.ebuild:
+ Fix 'source' support
*ufed-0.40-r2 (23 May 2006)
diff --git a/app-portage/ufed/files/digest-ufed-0.40-r3 b/app-portage/ufed/files/digest-ufed-0.40-r3
new file mode 100644
index 000000000000..2345f518f492
--- /dev/null
+++ b/app-portage/ufed/files/digest-ufed-0.40-r3
@@ -0,0 +1 @@
+MD5 81c6dc3af93d6ab2f592ba2cd7b1ee7f ufed-0.40.tar.bz2 20288
diff --git a/app-portage/ufed/files/ufed-0.40-source.patch b/app-portage/ufed/files/ufed-0.40-source.patch
index d1e04f3dfd31..236928334bb7 100644
--- a/app-portage/ufed/files/ufed-0.40-source.patch
+++ b/app-portage/ufed/files/ufed-0.40-source.patch
@@ -1,6 +1,6 @@
--- ufed-0.40/ufed.pl
+++ ufed-0.40/ufed.pl
-@@ -179,6 +179,7 @@
+@@ -161,6 +161,7 @@
close $makeconf;
}
@@ -8,7 +8,7 @@
eval {
# USE comment start/end (start/end of newline character at the end, specifically)
# default to end of make.conf, to handle make.confs without #USE=
-@@ -200,8 +200,12 @@
+@@ -180,8 +181,12 @@
/\G$IDENT/gc or die;
my $name = $1;
/\G$BLANK/gc;
@@ -19,9 +19,22 @@
+ $sourcing = 1;
+ }
die if pos == length;
- my $valstart = pos;
- /\G(?:$BNUQV|$SQVAL|$BNDQV)+/gc or die;
-@@ -295,6 +300,10 @@
+ if($name ne 'USE') {
+ /\G(?:$UQVAL|$SQVAL|$DQVAL)+/gc or die;
+@@ -265,8 +270,12 @@
+ /\G$IDENT/gc or die;
+ my $name = $1;
+ /\G$BLANK/gc;
++ if($name ne 'source') {
+ /\G$ASSIG/gc or die;
+ /\G$BLANK/gc;
++ } else {
++ $sourcing = 1;
++ }
+ /\G(?:$UQVAL|$SQVAL|$DQVAL)+/gc or die;
+ my $end = pos;
+ if($name eq 'USE') {
+@@ -278,6 +287,10 @@
};
die "Parse error when writing make.conf - did you modify it while ufed was running?\n" if $@;
@@ -34,7 +47,7 @@
print $makeconf $_;
--- ufed-0.40/Portage.pm
+++ ufed-0.40/Portage.pm
-@@ -250,8 +250,10 @@
+@@ -237,8 +237,10 @@
/\G$IDENT/gc or die;
my $name = $1;
/\G$BLANK/gc;
@@ -45,7 +58,7 @@
die if pos == length;
my $value = '';
for(;;) {
-@@ -275,7 +277,20 @@
+@@ -262,7 +264,20 @@
last
}
}
diff --git a/app-portage/ufed/ufed-0.40-r3.ebuild b/app-portage/ufed/ufed-0.40-r3.ebuild
new file mode 100644
index 000000000000..7f6f99ec49f5
--- /dev/null
+++ b/app-portage/ufed/ufed-0.40-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ufed-0.40-r3.ebuild,v 1.1 2006/06/02 07:35:26 truedfx Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux USE flags editor"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~truedfx/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-useorder.patch
+ epatch "${FILESDIR}"/${P}-source.patch
+}
+
+src_compile() {
+ ./configure || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ newsbin ufed.pl ufed
+ doman ufed.8
+ insinto /usr/lib/ufed
+ doins *.pm
+ exeinto /usr/lib/ufed
+ doexe ufed-curses
+}