summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-01-08 10:22:02 +0000
committerMichał Górny <mgorny@gentoo.org>2011-01-08 10:22:02 +0000
commitdbc2fea111ccd9acfe824ec851f99f4cae214173 (patch)
treec558e41e599c20f5a55a1ab72e8156c4d2236bb7 /app-portage
parentVersion bump: add -q option for reduced output. (diff)
downloadgentoo-2-dbc2fea111ccd9acfe824ec851f99f4cae214173.tar.gz
gentoo-2-dbc2fea111ccd9acfe824ec851f99f4cae214173.tar.bz2
gentoo-2-dbc2fea111ccd9acfe824ec851f99f4cae214173.zip
Use bash-completion.eclass.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/flaggie/ChangeLog5
-rw-r--r--app-portage/flaggie/flaggie-0.0.4.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/app-portage/flaggie/ChangeLog b/app-portage/flaggie/ChangeLog
index 98693e269226..13e36e33913c 100644
--- a/app-portage/flaggie/ChangeLog
+++ b/app-portage/flaggie/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-portage/flaggie
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/ChangeLog,v 1.13 2011/01/07 12:21:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/ChangeLog,v 1.14 2011/01/08 10:22:02 mgorny Exp $
+
+ 08 Jan 2011; Michał Górny <mgorny@gentoo.org> flaggie-0.0.4.ebuild:
+ Use bash-completion.eclass.
*flaggie-0.0.4 (07 Jan 2011)
diff --git a/app-portage/flaggie/flaggie-0.0.4.ebuild b/app-portage/flaggie/flaggie-0.0.4.ebuild
index a2a51293c3c6..0540b7c73a51 100644
--- a/app-portage/flaggie/flaggie-0.0.4.ebuild
+++ b/app-portage/flaggie/flaggie-0.0.4.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/flaggie-0.0.4.ebuild,v 1.1 2011/01/07 12:21:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/flaggie-0.0.4.ebuild,v 1.2 2011/01/08 10:22:02 mgorny Exp $
EAPI=3
PYTHON_DEPEND="*:2.6"
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="2.4 2.5"
-inherit base distutils
+inherit base bash-completion distutils
DESCRIPTION="A smart CLI mangler for package.* files"
HOMEPAGE="https://github.com/mgorny/flaggie/"
@@ -28,8 +28,7 @@ src_prepare() {
src_install() {
distutils_src_install
- insinto /usr/share/bash-completion
- newins contrib/bash-completion/${PN}.bash-completion ${PN} || die
+ dobashcompletion contrib/bash-completion/${PN}.bash-completion || die
}
pkg_postinst() {
@@ -39,4 +38,6 @@ pkg_postinst() {
ewarn "before performing each change through appending a single '~'."
ewarn "If you'd like to keep your own backup of them, please use another"
ewarn "naming scheme (or even better some VCS)."
+
+ bash-completion_pkg_postinst
}