summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-09 07:23:52 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-09 07:23:52 +0000
commit0d7e3e90daf4d9c27fc85751a00eb21b81ebae35 (patch)
treebefd64604e4a367845066ba309d32fd1d5952d24 /app-officeext/languagetool/languagetool-1.7.ebuild
parentmarked x86 per bug 414329 (diff)
downloadgentoo-2-0d7e3e90daf4d9c27fc85751a00eb21b81ebae35.tar.gz
gentoo-2-0d7e3e90daf4d9c27fc85751a00eb21b81ebae35.tar.bz2
gentoo-2-0d7e3e90daf4d9c27fc85751a00eb21b81ebae35.zip
Add language tool to the new app-officeext category.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-officeext/languagetool/languagetool-1.7.ebuild')
-rw-r--r--app-officeext/languagetool/languagetool-1.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-officeext/languagetool/languagetool-1.7.ebuild b/app-officeext/languagetool/languagetool-1.7.ebuild
new file mode 100644
index 000000000000..1f684e8725de
--- /dev/null
+++ b/app-officeext/languagetool/languagetool-1.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-officeext/languagetool/languagetool-1.7.ebuild,v 1.1 2012/05/09 07:23:52 scarabeus Exp $
+
+EAPI=4
+
+MY_P="LanguageTool-${PV}"
+
+OO_EXTENSIONS=(
+ "${MY_P}.oxt"
+)
+
+inherit office-ext
+
+DESCRIPTION="Style and Grammar Checker for libreoffice"
+HOMEPAGE="http://www.languagetool.org/"
+SRC_URI="http://www.languagetool.org/download/${MY_P}.oxt"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ virtual/ooo[java]
+"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp -v "${DISTDIR}/${MY_P}.oxt" "${S}"
+}
+
+pkg_postinst() {
+ office-ext_pkg_postinst
+ einfo "Be warned that this extension is serious resource hog and thus"
+ einfo "it might result in slower operations."
+}