summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2008-10-24 19:07:21 +0000
committerAndreas Proschofsky <suka@gentoo.org>2008-10-24 19:07:21 +0000
commitfd110d6dcd8023014a8bcc11b8bef781121c7a74 (patch)
tree0904ad6d323edfac5cde2ee969d53900b58a05b9 /app-office
parentFix dependencies. (diff)
downloadgentoo-2-fd110d6dcd8023014a8bcc11b8bef781121c7a74.tar.gz
gentoo-2-fd110d6dcd8023014a8bcc11b8bef781121c7a74.tar.bz2
gentoo-2-fd110d6dcd8023014a8bcc11b8bef781121c7a74.zip
Trying to fix freeze related to spell checking, see bug #242020
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo-r1 i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice/ChangeLog7
-rw-r--r--app-office/openoffice/files/gentoo-3.0.0.diff6
-rw-r--r--app-office/openoffice/files/hunspell-one-dir-nocrash.diff26
-rw-r--r--app-office/openoffice/openoffice-3.0.0.ebuild3
4 files changed, 38 insertions, 4 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index 6cf5b5d1a84c..ae58ec0b3d51 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/openoffice
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.435 2008/10/24 10:15:51 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.436 2008/10/24 19:07:13 suka Exp $
+
+ 24 Oct 2008; Andreas Proschofsky <suka@gentoo.org>
+ files/gentoo-3.0.0.diff, +files/hunspell-one-dir-nocrash.diff,
+ openoffice-3.0.0.ebuild:
+ Trying to fix freeze related to spell checking, see bug #242020
24 Oct 2008; Andreas Proschofsky <suka@gentoo.org>
openoffice-3.0.0.ebuild:
diff --git a/app-office/openoffice/files/gentoo-3.0.0.diff b/app-office/openoffice/files/gentoo-3.0.0.diff
index ff047aff8113..c11b021514d1 100644
--- a/app-office/openoffice/files/gentoo-3.0.0.diff
+++ b/app-office/openoffice/files/gentoo-3.0.0.diff
@@ -40,14 +40,16 @@
--with-vendor=\"Gentoo Foundation\"
--- patches/dev300/apply
+++ patches/dev300/apply
-@@ -1425,7 +1425,9 @@
+@@ -1425,7 +1425,11 @@
SectionOwner => aprosky
# system lucene classpath
-gentoo-system-lucene.diff
+#gentoo-system-lucene.diff
-+#No java build
++# No java build
+nojavanostax.diff
++# Fix freezes with dict|hyph-stuff in one dir
++hunspell-one-dir-nocrash.diff
# Allow build to proceed with PaX enabled
gentoo-pax-fix.diff, aprosky
# support server-only versions of 64bit JDKs
diff --git a/app-office/openoffice/files/hunspell-one-dir-nocrash.diff b/app-office/openoffice/files/hunspell-one-dir-nocrash.diff
new file mode 100644
index 000000000000..85fa3e8fc304
--- /dev/null
+++ b/app-office/openoffice/files/hunspell-one-dir-nocrash.diff
@@ -0,0 +1,26 @@
+? unxlngx6.pro
+Index: source/lingutil/lingutil.cxx
+===================================================================
+RCS file: /cvs/whiteboard/lingucomponent/source/lingutil/lingutil.cxx,v
+retrieving revision 1.4
+diff -u -r1.4 lingutil.cxx
+--- lingucomponent/source/lingutil/lingutil.cxx 13 Jun 2008 14:02:52 -0000 1.4
++++ lingucomponent/source/lingutil/lingutil.cxx 24 Oct 2008 15:01:43 -0000
+@@ -322,11 +322,15 @@
+ {
+ LanguageType nLang = MsLangId::convertIsoStringToLanguage( aIt2->aLocaleNames[0] );
+
++ if (nLang == LANGUAGE_DONTKNOW || nLang == LANGUAGE_NONE)
++ {
++ DBG_ERROR( "old style dictionary with invalid language found!" );
++ continue;
++ }
++
+ // language not yet added?
+ if (aNewStyleLanguages.count( nLang ) == 0)
+- {
+ rNewStyleDics.push_back( *aIt2 );
+- }
+ }
+ else
+ {
diff --git a/app-office/openoffice/openoffice-3.0.0.ebuild b/app-office/openoffice/openoffice-3.0.0.ebuild
index b040785e2c78..e7bd465a1110 100644
--- a/app-office/openoffice/openoffice-3.0.0.ebuild
+++ b/app-office/openoffice/openoffice-3.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.0.0.ebuild,v 1.14 2008/10/24 10:15:51 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.0.0.ebuild,v 1.15 2008/10/24 19:07:13 suka Exp $
WANT_AUTOCONF="2.5"
WANT_AUTOMAKE="1.9"
@@ -265,6 +265,7 @@ src_unpack() {
epatch "${FILESDIR}/gentoo-${PV}.diff"
epatch "${FILESDIR}/ooo-env_log.diff"
cp -f "${FILESDIR}/nojavanostax.diff" "${S}/patches/dev300" || die
+ cp -f "${FILESDIR}/hunspell-one-dir-nocrash.diff" "${S}/patches/dev300" || die
#Use flag checks
if use java ; then