summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-02-27 21:56:30 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-02-27 21:56:30 +0000
commit8d314fa9032cddd0044a39d900d4cc147966add8 (patch)
treeb6c658a543998ac2ca8d84cb23e1553a1f5125b7 /app-office
parentReduce if condition to oneliner. Less code++ (diff)
downloadgentoo-2-8d314fa9032cddd0044a39d900d4cc147966add8.tar.gz
gentoo-2-8d314fa9032cddd0044a39d900d4cc147966add8.tar.bz2
gentoo-2-8d314fa9032cddd0044a39d900d4cc147966add8.zip
Revert last commit on old versions to avoid unnecessary rebuilds
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog6
-rw-r--r--app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild11
-rw-r--r--app-office/libreoffice/libreoffice-3.4.5.2.ebuild11
3 files changed, 11 insertions, 17 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 73dc6aab1e92..a8cc0f4c8c10 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.243 2012/02/27 21:44:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.244 2012/02/27 21:56:30 dilfridge Exp $
+
+ 27 Feb 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ libreoffice-3.4.3.2-r1.ebuild, libreoffice-3.4.5.2.ebuild:
+ Revert last commit on old versions to avoid unnecessary rebuilds
27 Feb 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-9999-r2.ebuild:
Reduce if condition to oneliner. Less code++
diff --git a/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild b/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
index 018946bff96b..ec74c1c9fcc9 100644
--- a/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild,v 1.20 2012/02/27 21:29:20 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild,v 1.21 2012/02/27 21:56:30 dilfridge Exp $
EAPI=3
@@ -100,7 +100,7 @@ unset ADDONS_URI
unset EXT_URI
unset ADDONS_SRC
-IUSE="binfilter +branding +cups custom-cflags dbus debug eds gnome graphite
+IUSE="binfilter +branding custom-cflags dbus debug eds gnome graphite
gstreamer gtk kde ldap mysql nsplugin odk opengl python templates test +vba
webdav pdfimport"
LICENSE="LGPL-3"
@@ -134,6 +134,7 @@ COMMON_DEPEND="
>=media-libs/fontconfig-2.8.0
>=media-libs/vigra-1.7
>=media-libs/libpng-1.4
+ net-print/cups
sci-mathematics/lpsolve
>=sys-libs/db-4.8
virtual/jpeg
@@ -176,7 +177,6 @@ RDEPEND="${COMMON_DEPEND}
!app-office/libreoffice-bin
!app-office/openoffice-bin
!app-office/openoffice
- cups? ( net-print/cups )
java? ( >=virtual/jre-1.6 )
"
@@ -194,7 +194,6 @@ DEPEND="${COMMON_DEPEND}
dev-util/mdds
>=dev-util/pkgconfig-0.26
>=net-misc/curl-7.21.4
- net-print/cups
>=sys-apps/findutils-4.4.2
sys-devel/bison
sys-apps/coreutils
@@ -558,10 +557,6 @@ pkg_postinst() {
kde4-base_pkg_postinst
pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
-
- if ! use cups ; then
- ewarn 'You will need net-print/cups to be able to print with libreoffice.'
- fi
}
pkg_postrm() {
diff --git a/app-office/libreoffice/libreoffice-3.4.5.2.ebuild b/app-office/libreoffice/libreoffice-3.4.5.2.ebuild
index 9ada4054b3b8..445a9f1474b9 100644
--- a/app-office/libreoffice/libreoffice-3.4.5.2.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.5.2.ebuild,v 1.6 2012/02/27 21:29:20 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.5.2.ebuild,v 1.7 2012/02/27 21:56:30 dilfridge Exp $
EAPI=4
@@ -67,7 +67,7 @@ unset ADDONS_URI
unset EXT_URI
unset ADDONS_SRC
-IUSE="binfilter +branding +cups custom-cflags dbus debug eds gnome graphite
+IUSE="binfilter +branding custom-cflags dbus debug eds gnome graphite
gstreamer gtk jemalloc kde mysql nsplugin odk opengl pdfimport python
test +vba webdav"
LICENSE="LGPL-3"
@@ -94,6 +94,7 @@ COMMON_DEPEND="
>=media-libs/fontconfig-2.8.0
>=media-libs/vigra-1.7
>=media-libs/libpng-1.4
+ net-print/cups
sci-mathematics/lpsolve
>=sys-libs/db-4.8
virtual/jpeg
@@ -136,7 +137,6 @@ RDEPEND="${COMMON_DEPEND}
!app-office/libreoffice-bin
!app-office/openoffice-bin
!app-office/openoffice
- cups? ( net-print/cups )
java? ( >=virtual/jre-1.6 )
"
@@ -154,7 +154,6 @@ DEPEND="${COMMON_DEPEND}
dev-util/mdds
>=dev-util/pkgconfig-0.26
>=net-misc/curl-7.21.4
- net-print/cups
>=sys-apps/findutils-4.4.2
sys-devel/bison
sys-apps/coreutils
@@ -508,10 +507,6 @@ pkg_postinst() {
kde4-base_pkg_postinst
pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
-
- if ! use cups ; then
- ewarn 'You will need net-print/cups to be able to print with libreoffice.'
- fi
}
pkg_postrm() {