summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-07-22 23:33:35 +0000
committerAlex Alexander <wired@gentoo.org>2009-07-22 23:33:35 +0000
commit840845fa91ca3291fb356397323cae45078f3f69 (patch)
treead6b8ccf2e3c814819d4bb6adcd6f9021d3ca06d /app-office
parentold (diff)
downloadgentoo-2-840845fa91ca3291fb356397323cae45078f3f69.tar.gz
gentoo-2-840845fa91ca3291fb356397323cae45078f3f69.tar.bz2
gentoo-2-840845fa91ca3291fb356397323cae45078f3f69.zip
updated ebuild with fixes from kde-testing overlay
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/akonadi-server/ChangeLog7
-rw-r--r--app-office/akonadi-server/akonadi-server-1.1.2.ebuild33
2 files changed, 28 insertions, 12 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index 3067acc31016..07c5e536c917 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.14 2009/04/30 20:30:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.15 2009/07/22 23:33:35 wired Exp $
+
+ 22 Jul 2009; Alex Alexander <wired@gentoo.org>
+ akonadi-server-1.1.2.ebuild:
+ updated ebuild with fixes from kde-testing overlay (fixed RDEPEND, removed
+ inherit qt4)
*akonadi-server-1.1.2 (30 Apr 2009)
diff --git a/app-office/akonadi-server/akonadi-server-1.1.2.ebuild b/app-office/akonadi-server/akonadi-server-1.1.2.ebuild
index c6ed2e1511c2..075b5a6a05de 100644
--- a/app-office/akonadi-server/akonadi-server-1.1.2.ebuild
+++ b/app-office/akonadi-server/akonadi-server-1.1.2.ebuild
@@ -1,30 +1,31 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.1.2.ebuild,v 1.1 2009/04/30 20:30:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.1.2.ebuild,v 1.2 2009/07/22 23:33:35 wired Exp $
EAPI="2"
-inherit qt4 cmake-utils
+inherit cmake-utils
DESCRIPTION="The server part of Akonadi"
HOMEPAGE="http://pim.kde.org/akonadi"
SRC_URI="http://download.akonadi-project.org/${P/-server/}.tar.bz2"
LICENSE="LGPL-2.1"
-SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+SLOT="0"
IUSE="+mysql"
-RDEPEND="x11-libs/qt-core:4
- x11-libs/qt-dbus:4
- x11-libs/qt-sql:4[mysql?]
- x11-libs/qt-test:4
- x11-misc/shared-mime-info"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.6.0
+RDEPEND="
dev-libs/boost
+ >=x11-libs/qt-core-4.5.0:4
+ >=x11-libs/qt-dbus-4.5.0:4
+ >=x11-libs/qt-sql-4.5.0:4[mysql?]
+ x11-misc/shared-mime-info
+"
+DEPEND="${RDEPEND}
dev-libs/libxslt
- >=kde-base/automoc-0.9.88"
+ >=kde-base/automoc-0.9.88
+"
S="${WORKDIR}/${P/-server/}"
@@ -35,3 +36,13 @@ src_prepare() {
-i "${S}"/server/CMakeLists.txt || die 'Sed failed.'
fi
}
+
+pkg_postinst() {
+ if ! use mysql; then
+ echo
+ ewarn "You have decided to build akonadi-server with mysql USE"
+ ewarn "flag disabled. Note, that this is the only supported"
+ ewarn "database backend, hence akonadi-server will not work."
+ echo
+ fi
+}