summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-29 12:54:54 +0000
committerJustin Lecher <jlec@gentoo.org>2013-07-29 12:54:54 +0000
commit33cbf403513d3a8403f53f105d3dbdef9b1c5cfa (patch)
treef651b733d793bc10ebe5187bc605e4e3bc6fd645 /app-office
parentVersion bump (diff)
downloadgentoo-2-33cbf403513d3a8403f53f105d3dbdef9b1c5cfa.tar.gz
gentoo-2-33cbf403513d3a8403f53f105d3dbdef9b1c5cfa.tar.bz2
gentoo-2-33cbf403513d3a8403f53f105d3dbdef9b1c5cfa.zip
app-office/texmaker: Version Bump
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-4.0.3-hunspell.patch165
-rw-r--r--app-office/texmaker/texmaker-4.0.3.ebuild67
3 files changed, 239 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 2921ea5f9c81..17316411b73f 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.133 2013/05/11 12:27:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.134 2013/07/29 12:54:54 jlec Exp $
+
+*texmaker-4.0.3 (29 Jul 2013)
+
+ 29 Jul 2013; Justin Lecher <jlec@gentoo.org> +texmaker-4.0.3.ebuild,
+ +files/texmaker-4.0.3-hunspell.patch:
+ Version Bump
*texmaker-4.0.2 (11 May 2013)
diff --git a/app-office/texmaker/files/texmaker-4.0.3-hunspell.patch b/app-office/texmaker/files/texmaker-4.0.3-hunspell.patch
new file mode 100644
index 000000000000..9cabfb2e6f51
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-4.0.3-hunspell.patch
@@ -0,0 +1,165 @@
+ configdialog.cpp | 2 +-
+ latexeditor.h | 2 +-
+ latexeditorview.h | 2 +-
+ latexhighlighter.h | 2 +-
+ spellerdialog.h | 2 +-
+ texmaker.cpp | 4 ++--
+ texmaker.h | 2 +-
+ texmaker.pro | 37 +++----------------------------------
+ 8 files changed, 11 insertions(+), 42 deletions(-)
+
+diff --git a/configdialog.cpp b/configdialog.cpp
+index e596a2c..3660429 100644
+--- a/configdialog.cpp
++++ b/configdialog.cpp
+@@ -220,7 +220,7 @@ void ConfigDialog::browseAspell()
+ QDir spelldir(QCoreApplication::applicationDirPath());
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QDir spelldir(PREFIX"/share/myspell/dicts");
++QDir spelldir(PREFIX"/share/myspell");
+ #else
+ QDir spelldir(PREFIX"/share/texmaker");
+ #endif
+diff --git a/latexeditor.h b/latexeditor.h
+index 29b01f8..1db88ad 100644
+--- a/latexeditor.h
++++ b/latexeditor.h
+@@ -33,7 +33,7 @@
+
+ #include "latexhighlighter.h"
+ #include "textblockselection.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ typedef int UserBookmarkList[3];
+
+diff --git a/latexeditorview.h b/latexeditorview.h
+index 9809d86..adca0b2 100644
+--- a/latexeditorview.h
++++ b/latexeditorview.h
+@@ -23,7 +23,7 @@
+ #include "gotolinewidget.h"
+ #include "replacewidget.h"
+ #include "minisplitter.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class LatexEditorView : public QWidget {
+ Q_OBJECT
+diff --git a/latexhighlighter.h b/latexhighlighter.h
+index e0b91b1..74ec42a 100644
+--- a/latexhighlighter.h
++++ b/latexhighlighter.h
+@@ -20,7 +20,7 @@
+ #include <QColor>
+ #include <QTextBlockUserData>
+ //#include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class QTextDocument;
+ class LatexEditor;
+diff --git a/spellerdialog.h b/spellerdialog.h
+index 83248ae..cd16dad 100644
+--- a/spellerdialog.h
++++ b/spellerdialog.h
+@@ -13,7 +13,7 @@
+
+ #include "ui_spellerdialog.h"
+ #include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ #include <QTextCursor>
+
+diff --git a/texmaker.cpp b/texmaker.cpp
+index 51d2082..607f66e 100644
+--- a/texmaker.cpp
++++ b/texmaker.cpp
+@@ -4363,7 +4363,7 @@ geometry_options=config->value("Quick/GeometryOptions","left=2cm,right=2cm,top=2
+ QString dicDir=QCoreApplication::applicationDirPath() + "/";
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QString dicDir=PREFIX"/share/myspell/dicts/";
++QString dicDir=PREFIX"/share/myspell/";
+ #else
+ QString dicDir=PREFIX"/share/texmaker/";
+ #endif
+@@ -10835,4 +10835,4 @@ if (singlemode && currentEditorView())
+ UpdateBibliography();
+ }
+ }
+-}
+\ No newline at end of file
++}
+diff --git a/texmaker.h b/texmaker.h
+index f7e278c..e80d9e5 100644
+--- a/texmaker.h
++++ b/texmaker.h
+@@ -48,7 +48,7 @@
+ #include "usertagslistwidget.h"
+ #include "xmltagslistwidget.h"
+ #include "logeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+ #include "browser.h"
+ #include "pdfviewerwidget.h"
+ #include "pdfviewer.h"
+diff --git a/texmaker.pro b/texmaker.pro
+index d2312d1..0009663 100644
+--- a/texmaker.pro
++++ b/texmaker.pro
+@@ -87,25 +87,6 @@ HEADERS += texmaker.h \
+ versiondialog.h \
+ unicodedialog.h \
+ unicodeview.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/replist.hxx \
+- hunspell/w_char.hxx \
+ singleapp/qtlocalpeer.h \
+ singleapp/qtlockedfile.h \
+ singleapp/qtsingleapplication.h \
+@@ -196,18 +174,6 @@ SOURCES += main.cpp \
+ versiondialog.cpp \
+ unicodedialog.cpp \
+ unicodeview.cpp \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/replist.cxx \
+- hunspell/hunzip.cxx \
+ singleapp/qtlocalpeer.cpp \
+ singleapp/qtlockedfile.cpp \
+ singleapp/qtsingleapplication.cpp \
+@@ -454,3 +420,6 @@ INSTALLS += desktop
+ icon.files = utilities/texmaker.png
+ INSTALLS += icon
+ }
++
++CONFIG += link_pkgconfig
++PKGCONFIG += hunspell
+\ No newline at end of file
diff --git a/app-office/texmaker/texmaker-4.0.3.ebuild b/app-office/texmaker/texmaker-4.0.3.ebuild
new file mode 100644
index 000000000000..0a1ce868a63f
--- /dev/null
+++ b/app-office/texmaker/texmaker-4.0.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-4.0.3.ebuild,v 1.1 2013/07/29 12:54:54 jlec Exp $
+
+EAPI=5
+
+inherit qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ dev-qt/qtwebkit:4
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-hunspell.patch )
+
+DOCS=( utilities/AUTHORS utilities/CHANGELOG.txt )
+HTML_DOCS=( doc/. )
+
+src_configure() {
+ eqmake4 \
+ ${PN}.pro \
+ PREFIX="${EPREFIX}/usr" \
+ DESKTOPDIR="${EPREFIX}/usr/share/applications" \
+ ICONDIR="${EPREFIX}/usr/share/pixmaps"
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}