summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2011-02-21 20:19:34 +0000
committerRémi Cardona <remi@gentoo.org>2011-02-21 20:19:34 +0000
commit0940bf596e8f709b8df6c17b1efb321dc1f915d4 (patch)
treeaa474fe0b25c224adedb0150dac3883df1ff3c35 /app-office
parentAdded to net-im herd (diff)
downloadgentoo-2-0940bf596e8f709b8df6c17b1efb321dc1f915d4.tar.gz
gentoo-2-0940bf596e8f709b8df6c17b1efb321dc1f915d4.tar.bz2
gentoo-2-0940bf596e8f709b8df6c17b1efb321dc1f915d4.zip
app-office/grisbi: Bump to 0.8.0, clean up ebuild
(Portage version: 2.2.0_alpha23/cvs/Linux i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/grisbi/ChangeLog9
-rw-r--r--app-office/grisbi/grisbi-0.8.0.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/app-office/grisbi/ChangeLog b/app-office/grisbi/ChangeLog
index 70bee2281050..14918a1e9164 100644
--- a/app-office/grisbi/ChangeLog
+++ b/app-office/grisbi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/grisbi
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/ChangeLog,v 1.41 2010/05/25 20:38:47 remi Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/ChangeLog,v 1.42 2011/02/21 20:19:34 remi Exp $
+
+*grisbi-0.8.0 (21 Feb 2011)
+
+ 21 Feb 2011; Rémi Cardona <remi@gentoo.org> +grisbi-0.8.0.ebuild:
+ Bump to 0.8.0, clean up ebuild
25 May 2010; Rémi Cardona <remi@gentoo.org> grisbi-0.6.0.ebuild:
simplify bash syntax
diff --git a/app-office/grisbi/grisbi-0.8.0.ebuild b/app-office/grisbi/grisbi-0.8.0.ebuild
new file mode 100644
index 000000000000..787a3babd69e
--- /dev/null
+++ b/app-office/grisbi/grisbi-0.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/grisbi-0.8.0.ebuild,v 1.1 2011/02/21 20:19:34 remi Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+IUSE="nls ofx ssl"
+
+DESCRIPTION="Grisbi is a personal accounting application for Linux"
+HOMEPAGE="http://www.grisbi.org"
+SRC_URI="mirror://sourceforge/grisbi/grisbi%20stable/0.8.x/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="dev-libs/libxml2
+ >=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.12.0
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ ofx? ( >=dev-libs/libofx-0.7.0 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.20"
+
+pkg_setup() {
+ G2CONF="
+ --with-plugins
+ --with-libxml2
+ $(use_with ssl openssl)
+ $(use_with ofx)
+ $(use_enable nls)"
+ DOCS="AUTHORS NEWS README"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "The first thing you should do is set up the browser command in"
+ elog "preferences after you start up grisbi. Otherwise you will not"
+ elog "be able to see the help and manuals."
+}