summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-23 13:24:55 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-23 13:24:55 +0000
commitbacf5ab10bc596aac66e98f6273377096924013b (patch)
tree8a14d70d3421490a69cfe5c52e3e3c6bd0cacfc7 /app-office/unoconv
parentUse Arch patch to fix compilation with gcc-4.6 (bug #367865). (diff)
downloadgentoo-2-bacf5ab10bc596aac66e98f6273377096924013b.tar.gz
gentoo-2-bacf5ab10bc596aac66e98f6273377096924013b.tar.bz2
gentoo-2-bacf5ab10bc596aac66e98f6273377096924013b.zip
Initial commit. Fixes bug #262083.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'app-office/unoconv')
-rw-r--r--app-office/unoconv/ChangeLog12
-rw-r--r--app-office/unoconv/files/timeout.patch11
-rw-r--r--app-office/unoconv/metadata.xml5
-rw-r--r--app-office/unoconv/unoconv-20110923.ebuild39
-rw-r--r--app-office/unoconv/unoconv-99999999.ebuild39
5 files changed, 106 insertions, 0 deletions
diff --git a/app-office/unoconv/ChangeLog b/app-office/unoconv/ChangeLog
new file mode 100644
index 000000000000..957e6825c349
--- /dev/null
+++ b/app-office/unoconv/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-office/unoconv
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/unoconv/ChangeLog,v 1.1 2011/09/23 13:24:55 scarabeus Exp $
+
+*unoconv-99999999 (23 Sep 2011)
+*unoconv-20110923 (23 Sep 2011)
+
+ 23 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +unoconv-20110923.ebuild, +unoconv-99999999.ebuild, +files/timeout.patch,
+ +metadata.xml:
+ Initial commit. Fixes bug #262083.
+
diff --git a/app-office/unoconv/files/timeout.patch b/app-office/unoconv/files/timeout.patch
new file mode 100644
index 000000000000..f41b101faf78
--- /dev/null
+++ b/app-office/unoconv/files/timeout.patch
@@ -0,0 +1,11 @@
+--- unoconv.old 2011-08-01 14:20:45.000000000 +0200
++++ unoconv 2011-08-01 14:21:01.000000000 +0200
+@@ -534,7 +534,7 @@
+ unocontext = resolver.resolve("uno:%s" % op.connection)
+ break
+ except NoConnectException:
+- time.sleep(0.5)
++ time.sleep(5)
+ timeout += 0.5
+ except:
+ raise
diff --git a/app-office/unoconv/metadata.xml b/app-office/unoconv/metadata.xml
new file mode 100644
index 000000000000..5d46203011d6
--- /dev/null
+++ b/app-office/unoconv/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+</pkgmetadata>
diff --git a/app-office/unoconv/unoconv-20110923.ebuild b/app-office/unoconv/unoconv-20110923.ebuild
new file mode 100644
index 000000000000..bc7ea096599c
--- /dev/null
+++ b/app-office/unoconv/unoconv-20110923.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/unoconv/unoconv-20110923.ebuild,v 1.1 2011/09/23 13:24:55 scarabeus Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+EGIT_REPO_URI="https://github.com/dagwieers/unoconv.git"
+[[ ${PV} == 9999* ]] && SCM_ECLASS="git-2"
+inherit eutils python ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
+[[ ${PV} == 9999* ]] || SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ ${PV} == 9999* ]] || KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${DEPEND}
+ virtual/ooo
+"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/timeout.patch"
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake docs-install install install-links DESTDIR="${D}" || die
+}
diff --git a/app-office/unoconv/unoconv-99999999.ebuild b/app-office/unoconv/unoconv-99999999.ebuild
new file mode 100644
index 000000000000..a85d914a9cfd
--- /dev/null
+++ b/app-office/unoconv/unoconv-99999999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/unoconv/unoconv-99999999.ebuild,v 1.1 2011/09/23 13:24:55 scarabeus Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+EGIT_REPO_URI="https://github.com/dagwieers/unoconv.git"
+[[ ${PV} == 9999* ]] && SCM_ECLASS="git-2"
+inherit eutils python ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
+[[ ${PV} == 9999* ]] || SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ ${PV} == 9999* ]] || KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${DEPEND}
+ virtual/ooo
+"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/timeout.patch"
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake docs-install install install-links DESTDIR="${D}" || die
+}