summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-31 08:55:29 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-31 08:55:29 +0000
commit3585aea48b298f0820beffcbf4aa7887d3a05dd4 (patch)
tree31a0f786d03b34c4273e264351572e25e6ee3d3a /app-office/unoconv/unoconv-0.6.ebuild
parentUse virtual for argparse. (diff)
downloadgentoo-2-3585aea48b298f0820beffcbf4aa7887d3a05dd4.tar.gz
gentoo-2-3585aea48b298f0820beffcbf4aa7887d3a05dd4.tar.bz2
gentoo-2-3585aea48b298f0820beffcbf4aa7887d3a05dd4.zip
Add latest released version. Currenty overshadowed, after testing the older versions will be removed, forcing a downgrade.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-office/unoconv/unoconv-0.6.ebuild')
-rw-r--r--app-office/unoconv/unoconv-0.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-office/unoconv/unoconv-0.6.ebuild b/app-office/unoconv/unoconv-0.6.ebuild
new file mode 100644
index 000000000000..b4f71aa80cb7
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/unoconv/unoconv-0.6.ebuild,v 1.1 2012/10/31 08:55:29 graaff Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+EGIT_REPO_URI="https://github.com/dagwieers/unoconv.git"
+[[ ${PV} == 9999* ]] && SCM_ECLASS="git-2"
+inherit eutils python ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
+[[ ${PV} == 9999* ]] || SRC_URI="https://github.com/dagwieers/${PN}/tarball/${PV} -> ${P}-git.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ ${PV} == 9999* ]] || KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ mv "${WORKDIR}"/dagwieers-${PN}-* "${WORKDIR}"/${P}
+ cd "${S}"
+
+ epatch "${FILESDIR}/timeout.patch"
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake doc-install install install-links DESTDIR="${D}" || die
+
+ dodoc ChangeLog README.asciidoc || die
+}