summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-07-13 08:50:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-07-13 08:50:31 +0000
commitb3e04961ec7b2132e98ed063e89f243f8a069542 (patch)
tree6ababd180faf47a702578475f241c03a3da14a65 /app-office/texmaker
parentCommitted too soon. Fixes to allow 0.4.0 to build and install (diff)
downloadgentoo-2-b3e04961ec7b2132e98ed063e89f243f8a069542.tar.gz
gentoo-2-b3e04961ec7b2132e98ed063e89f243f8a069542.tar.bz2
gentoo-2-b3e04961ec7b2132e98ed063e89f243f8a069542.zip
version bump, by Dustin Polke <gentoobugsie.20.dsurawicz@spamgourmet.com>, bug #276732
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/texmaker-1.92.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index b09e69295a25..3884d9a1f53e 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.59 2009/06/08 07:46:21 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.60 2009/07/13 08:50:31 aballier Exp $
+
+*texmaker-1.92 (13 Jul 2009)
+
+ 13 Jul 2009; Alexis Ballier <aballier@gentoo.org> +texmaker-1.92.ebuild:
+ version bump, by Dustin Polke <gentoobugsie.20.dsurawicz@spamgourmet.com>,
+ bug #276732
*texmaker-1.91 (08 Jun 2009)
diff --git a/app-office/texmaker/texmaker-1.92.ebuild b/app-office/texmaker/texmaker-1.92.ebuild
new file mode 100644
index 000000000000..e52e4603a8ac
--- /dev/null
+++ b/app-office/texmaker/texmaker-1.92.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-1.92.ebuild,v 1.1 2009/07/13 08:50:31 aballier Exp $
+
+EAPI=1
+
+inherit eutils versionator qt4
+
+DESCRIPTION="A nice LaTeX-IDE"
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+S="${WORKDIR}/${MY_P}"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+COMMON_DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/qt-gui-4.5.1:4
+ >=x11-libs/qt-core-4.5.1:4
+ >=app-text/hunspell-1.2.4"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ virtual/ghostscript
+ media-libs/netpbm"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.91-hunspell.patch"
+}
+
+src_compile() {
+ eqmake4 texmaker.pro || die "qmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png || die "doins failed."
+ doins utilities/texmaker.svg || die "doins failed."
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "/usr/share/${PN}/usermanual_en.html"
+ elog
+}