summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-26 22:59:02 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-26 22:59:02 +0000
commit7782fa2f2eb7f577fe62165740587298c6dfc21d (patch)
tree61d27d46446cc71ede805d3a4bf5e4da47efd5f2 /app-office/libreoffice
parentConvert to distutils-r1. (diff)
downloadgentoo-2-7782fa2f2eb7f577fe62165740587298c6dfc21d.tar.gz
gentoo-2-7782fa2f2eb7f577fe62165740587298c6dfc21d.tar.bz2
gentoo-2-7782fa2f2eb7f577fe62165740587298c6dfc21d.zip
Fix build with Boost 1.56, bug 522178
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/ChangeLog7
-rw-r--r--app-office/libreoffice/files/libreoffice-4.3.4.1-boost-1.56.0.patch187
-rw-r--r--app-office/libreoffice/libreoffice-4.3.4.1.ebuild3
-rw-r--r--app-office/libreoffice/libreoffice-4.3.9999.ebuild3
4 files changed, 197 insertions, 3 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 3f705343df64..973ae89b7bba 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.594 2014/12/21 21:57:07 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.595 2014/12/26 22:59:02 dilfridge Exp $
+
+ 26 Dec 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ libreoffice-4.3.4.1.ebuild, libreoffice-4.3.9999.ebuild,
+ +files/libreoffice-4.3.4.1-boost-1.56.0.patch:
+ Fix build with Boost 1.56, bug 522178
21 Dec 2014; Andreas K. Huettel <dilfridge@gentoo.org>
libreoffice-4.2.6.3.ebuild, libreoffice-4.2.9999.ebuild:
diff --git a/app-office/libreoffice/files/libreoffice-4.3.4.1-boost-1.56.0.patch b/app-office/libreoffice/files/libreoffice-4.3.4.1-boost-1.56.0.patch
new file mode 100644
index 000000000000..1926a3417c70
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-4.3.4.1-boost-1.56.0.patch
@@ -0,0 +1,187 @@
+Backport of 45dfbdca6a9afba1a6aef21623ec025ded635a4d from LO master
+by Mark Wright, gienah@gentoo.org
+
+
+--- libreoffice-4.3.1.2-orig/canvas/source/cairo/cairo_spritecanvashelper.cxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/canvas/source/cairo/cairo_spritecanvashelper.cxx 2014-09-20 15:09:49.269841950 +1000
+@@ -402,11 +402,12 @@
+ ::basegfx::computeSetDifference( aUncoveredAreas,
+ rUpdateArea.maTotalBounds,
+ ::basegfx::B2DRange( rDestRect ) );
++ SurfaceSharedPtr surface(mpOwningSpriteCanvas->getBufferSurface());
+ ::std::for_each( aUncoveredAreas.begin(),
+ aUncoveredAreas.end(),
+ ::boost::bind( &repaintBackground,
+ boost::cref(pCompositingCairo),
+- boost::cref(mpOwningSpriteCanvas->getBufferSurface()),
++ boost::cref(surface),
+ _1 ) );
+
+ cairo_rectangle( pWindowCairo.get(), 0, 0, rSize.getX(), rSize.getY() );
+--- libreoffice-4.3.1.2-orig/canvas/source/vcl/spritecanvashelper.cxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/canvas/source/vcl/spritecanvashelper.cxx 2014-09-20 15:09:49.270404983 +1000
+@@ -573,12 +573,12 @@
+
+ // repaint all affected sprites on top of background into
+ // VDev.
++ ::basegfx::B2DPoint outPos( ::vcl::unotools::b2DPointFromPoint(aOutputPosition) );
+ ::std::for_each( rSortedUpdateSprites.begin(),
+ rSortedUpdateSprites.end(),
+ ::boost::bind( &spriteRedrawStub2,
+ ::boost::ref( maVDev.get() ),
+- ::boost::cref(
+- ::vcl::unotools::b2DPointFromPoint(aOutputPosition)),
++ ::boost::cref( outPos ),
+ _1 ) );
+
+ // flush to screen
+--- libreoffice-4.3.1.2-orig/dbaccess/source/ui/tabledesign/TableController.cxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/dbaccess/source/ui/tabledesign/TableController.cxx 2014-09-20 15:12:36.829360633 +1000
+@@ -1392,7 +1392,8 @@
+ setEditable( xMeta.is() && !xMeta->isReadOnly() && (isAlterAllowed() || isDropAllowed() || isAddAllowed()) );
+ if(!isEditable())
+ {
+- ::std::for_each(m_vRowList.begin(),m_vRowList.end(),boost::bind( &OTableRow::SetReadOnly, _1, boost::cref( sal_True )));
++ sal_Bool t( sal_True );
++ ::std::for_each(m_vRowList.begin(),m_vRowList.end(),boost::bind( &OTableRow::SetReadOnly, _1, boost::cref( t )));
+ }
+ m_bNew = false;
+ // be notified when the table is in disposing
+--- libreoffice-4.3.1.2-orig/oox/source/drawingml/table/tablecell.cxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/oox/source/drawingml/table/tablecell.cxx 2014-09-20 15:09:49.272005355 +1000
+@@ -117,9 +117,9 @@
+ if (rTableStylePart.getTextColor().isUsed())
+ aTextCharProps.maCharColor = rTableStylePart.getTextColor();
+ if( rTableStylePart.getTextBoldStyle().is_initialized() )
+- aTextCharProps.moBold = rTableStylePart.getTextBoldStyle();
++ aTextCharProps.moBold = *rTableStylePart.getTextBoldStyle();
+ if( rTableStylePart.getTextItalicStyle().is_initialized() )
+- aTextCharProps.moItalic = rTableStylePart.getTextItalicStyle();
++ aTextCharProps.moItalic = *rTableStylePart.getTextItalicStyle();
+ }
+
+ void applyTableCellProperties( const Reference < ::com::sun::star::table::XCell >& rxCell, const TableCell& rTableCell )
+--- libreoffice-4.3.1.2-orig/reportdesign/source/core/api/ReportDefinition.cxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/reportdesign/source/core/api/ReportDefinition.cxx 2014-09-20 15:09:49.273376564 +1000
+@@ -1612,8 +1612,9 @@
+ m_pImpl->m_pObjectContainer->SwitchPersistence(m_pImpl->m_xStorage);
+ }
+ // notify our container listeners
++ OWeakObject *weakObjectThis = static_cast<OWeakObject*>(this);
+ m_pImpl->m_aStorageChangeListeners.forEach<document::XStorageChangeListener>(
+- ::boost::bind(&document::XStorageChangeListener::notifyStorageChange,_1,boost::cref(static_cast<OWeakObject*>(this)),boost::cref(_xStorage)));
++ ::boost::bind(&document::XStorageChangeListener::notifyStorageChange,_1,boost::cref(weakObjectThis),boost::cref(_xStorage)));
+ }
+
+ uno::Reference< embed::XStorage > SAL_CALL OReportDefinition::getDocumentStorage( ) throw (io::IOException, uno::Exception, uno::RuntimeException, std::exception)
+--- libreoffice-4.3.1.2-orig/slideshow/source/engine/activities/activitybase.hxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/slideshow/source/engine/activities/activitybase.hxx 2014-09-20 15:09:49.273965661 +1000
+@@ -111,7 +111,7 @@
+ ShapeAttributeLayerSharedPtr getShapeAttributeLayer() const
+ { return mpAttributeLayer; }
+
+- bool isRepeatCountValid() const { return maRepeats; }
++ bool isRepeatCountValid() const { return bool(maRepeats); }
+ double getRepeatCount() const { return *maRepeats; }
+ bool isAutoReverse() const { return mbAutoReverse; }
+
+--- libreoffice-4.3.1.2-orig/slideshow/source/engine/rehearsetimingsactivity.cxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/slideshow/source/engine/rehearsetimingsactivity.cxx 2014-09-20 15:09:49.274529920 +1000
+@@ -400,11 +400,12 @@
+ {
+ // new sprite pos, transformation might have changed:
+ maSpriteRectangle = calcSpriteRectangle( maViews.front().first );
++ ::basegfx::B2DPoint rectMin( maSpriteRectangle.getMinimum() );
+
+ // reposition sprites
+ for_each_sprite( boost::bind( &cppcanvas::Sprite::move,
+ _1,
+- boost::cref(maSpriteRectangle.getMinimum())) );
++ boost::cref( rectMin )) );
+
+ // sprites changed, need screen update
+ mrScreenUpdater.notifyUpdate();
+--- libreoffice-4.3.1.2-orig/slideshow/source/engine/shapes/appletshape.cxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/slideshow/source/engine/shapes/appletshape.cxx 2014-09-20 15:09:49.275052955 +1000
+@@ -148,12 +148,13 @@
+ void AppletShape::implViewsChanged()
+ {
+ // resize all ViewShapes
++ ::basegfx::B2DRectangle bounds( AppletShape::getBounds() );
+ ::std::for_each( maViewAppletShapes.begin(),
+ maViewAppletShapes.end(),
+ ::boost::bind(
+ &ViewAppletShape::resize,
+ _1,
+- ::boost::cref( AppletShape::getBounds())) );
++ ::boost::cref( bounds )) );
+ }
+
+
+@@ -252,11 +253,12 @@
+
+ bool AppletShape::implStartIntrinsicAnimation()
+ {
++ ::basegfx::B2DRectangle bounds( getBounds() );
+ ::std::for_each( maViewAppletShapes.begin(),
+ maViewAppletShapes.end(),
+ ::boost::bind( &ViewAppletShape::startApplet,
+ _1,
+- ::boost::cref( getBounds() )));
++ ::boost::cref( bounds )));
+ mbIsPlaying = true;
+
+ return true;
+--- libreoffice-4.3.1.2-orig/slideshow/source/engine/shapes/drawshape.cxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/slideshow/source/engine/shapes/drawshape.cxx 2014-09-20 15:09:49.275701062 +1000
+@@ -168,6 +168,7 @@
+ }
+
+ // redraw all view shapes, by calling their update() method
++ ViewShape::RenderArgs renderArgs( getViewRenderArgs() );
+ if( ::std::count_if( maViewShapes.begin(),
+ maViewShapes.end(),
+ ::boost::bind<bool>(
+@@ -178,8 +179,7 @@
+ // the extra mem_fn. WTF.
+ _1,
+ ::boost::cref( mpCurrMtf ),
+- ::boost::cref(
+- getViewRenderArgs() ),
++ ::boost::cref( renderArgs ),
+ nUpdateFlags,
+ isVisible() ) )
+ != static_cast<ViewShapeVector::difference_type>(maViewShapes.size()) )
+--- libreoffice-4.3.1.2-orig/slideshow/source/engine/shapes/mediashape.cxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/slideshow/source/engine/shapes/mediashape.cxx 2014-09-20 15:09:49.276133048 +1000
+@@ -125,12 +125,13 @@
+ void MediaShape::implViewsChanged()
+ {
+ // resize all ViewShapes
++ ::basegfx::B2DRectangle bounds( getBounds() );
+ ::std::for_each( maViewMediaShapes.begin(),
+ maViewMediaShapes.end(),
+ ::boost::bind(
+ &ViewMediaShape::resize,
+ _1,
+- ::boost::cref( getBounds())) );
++ ::boost::cref( bounds )) );
+ }
+
+
+--- libreoffice-4.3.1.2-orig/slideshow/source/engine/unoviewcontainer.cxx 2014-08-26 14:07:49.000000000 +1000
++++ libreoffice-4.3.1.2/slideshow/source/engine/unoviewcontainer.cxx 2014-09-20 15:09:49.276489737 +1000
+@@ -45,11 +45,12 @@
+ const UnoViewVector::iterator aEnd( maViews.end() );
+
+ // already added?
++ uno::Reference<presentation::XSlideShowView> xView (rView->getUnoView());
+ if( ::std::find_if( maViews.begin(),
+ aEnd,
+ ::boost::bind(
+ ::std::equal_to< uno::Reference< presentation::XSlideShowView > >(),
+- ::boost::cref( rView->getUnoView() ),
++ ::boost::cref( xView ),
+ ::boost::bind(
+ &UnoView::getUnoView,
+ _1 ) ) ) != aEnd )
diff --git a/app-office/libreoffice/libreoffice-4.3.4.1.ebuild b/app-office/libreoffice/libreoffice-4.3.4.1.ebuild
index ea0a24bf4ed5..951b48b8d098 100644
--- a/app-office/libreoffice/libreoffice-4.3.4.1.ebuild
+++ b/app-office/libreoffice/libreoffice-4.3.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.3.4.1.ebuild,v 1.3 2014/11/18 10:02:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.3.4.1.ebuild,v 1.4 2014/12/26 22:59:02 dilfridge Exp $
EAPI=5
@@ -246,6 +246,7 @@ PATCHES=(
# from master branch
"${FILESDIR}/${PN}-4.3.1.2-implement--with-system-coinmp.patch"
+ "${FILESDIR}/${PN}-4.3.4.1-boost-1.56.0.patch" # bug 522178
)
REQUIRED_USE="
diff --git a/app-office/libreoffice/libreoffice-4.3.9999.ebuild b/app-office/libreoffice/libreoffice-4.3.9999.ebuild
index c6319d34f838..7b935d84ac8e 100644
--- a/app-office/libreoffice/libreoffice-4.3.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-4.3.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.3.9999.ebuild,v 1.6 2014/11/18 10:02:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.3.9999.ebuild,v 1.7 2014/12/26 22:59:02 dilfridge Exp $
EAPI=5
@@ -246,6 +246,7 @@ PATCHES=(
# from master branch
"${FILESDIR}/${PN}-4.3.1.2-implement--with-system-coinmp.patch"
+ "${FILESDIR}/${PN}-4.3.4.1-boost-1.56.0.patch" # bug 522178
)
REQUIRED_USE="