summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2013-01-27 00:27:13 +0000
committerDenis Dupeyron <calchan@gentoo.org>2013-01-27 00:27:13 +0000
commit47bd922a2cf9bcbe82a262ba500eab02b67a31b4 (patch)
treecad4d5402d87f38cdaaf0d4f4ff7513e6dea8888 /app-office/homebank
parentFix missing dep, #428518 (diff)
downloadgentoo-2-47bd922a2cf9bcbe82a262ba500eab02b67a31b4.tar.gz
gentoo-2-47bd922a2cf9bcbe82a262ba500eab02b67a31b4.tar.bz2
gentoo-2-47bd922a2cf9bcbe82a262ba500eab02b67a31b4.zip
Version bump.
(Portage version: 2.1.11.48/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-office/homebank')
-rw-r--r--app-office/homebank/ChangeLog9
-rw-r--r--app-office/homebank/homebank-4.5.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-office/homebank/ChangeLog b/app-office/homebank/ChangeLog
index 38c82d396fdf..ea8d4cc6795c 100644
--- a/app-office/homebank/ChangeLog
+++ b/app-office/homebank/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/homebank
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/ChangeLog,v 1.27 2012/12/15 15:53:48 calchan Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/ChangeLog,v 1.28 2013/01/27 00:27:13 calchan Exp $
+
+*homebank-4.5 (27 Jan 2013)
+
+ 27 Jan 2013; Denis Dupeyron <calchan@gentoo.org> +homebank-4.5.ebuild:
+ Version bump.
15 Dec 2012; Denis Dupeyron <calchan@gentoo.org> homebank-4.4.ebuild,
+files/homebank-4.4-fix_tests.patch:
diff --git a/app-office/homebank/homebank-4.5.ebuild b/app-office/homebank/homebank-4.5.ebuild
new file mode 100644
index 000000000000..f78b73b035db
--- /dev/null
+++ b/app-office/homebank/homebank-4.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/homebank-4.5.ebuild,v 1.1 2013/01/27 00:27:13 calchan Exp $
+
+EAPI="4"
+
+inherit fdo-mime eutils
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=x11-libs/gtk+-2.20
+ >=dev-libs/glib-2.17
+ ofx? ( >=dev-libs/libofx-0.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40.5"
+
+src_configure() {
+ econf $(use_with ofx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}