summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2013-07-24 11:39:27 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2013-07-24 11:39:27 +0000
commit702ad152cc19121592821f543d2b06ca69d58112 (patch)
treefb19169658f03f60a4df594a7e71395086876c56 /app-office/akonadi-server
parentVersion bump (diff)
downloadgentoo-2-702ad152cc19121592821f543d2b06ca69d58112.tar.gz
gentoo-2-702ad152cc19121592821f543d2b06ca69d58112.tar.bz2
gentoo-2-702ad152cc19121592821f543d2b06ca69d58112.zip
Add PostgreSQL fix. Drop old ebuild.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
Diffstat (limited to 'app-office/akonadi-server')
-rw-r--r--app-office/akonadi-server/ChangeLog9
-rw-r--r--app-office/akonadi-server/akonadi-server-1.10.1-r1.ebuild (renamed from app-office/akonadi-server/akonadi-server-1.10.1.ebuild)3
-rw-r--r--app-office/akonadi-server/files/akonadi-server-1.10.1-fix_psql.patch19
3 files changed, 29 insertions, 2 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index 8412e72f8140..db4c23614c9c 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.120 2013/07/23 17:39:21 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.121 2013/07/24 11:39:27 mschiff Exp $
+
+*akonadi-server-1.10.1-r1 (24 Jul 2013)
+
+ 24 Jul 2013; Marc Schiffbauer <mschiff@gentoo.org>
+ +akonadi-server-1.10.1-r1.ebuild, +files/akonadi-server-1.10.1-fix_psql.patch,
+ -akonadi-server-1.10.1.ebuild:
+ Add PostgreSQL fix. Drop old ebuild.
*akonadi-server-1.10.1 (23 Jul 2013)
diff --git a/app-office/akonadi-server/akonadi-server-1.10.1.ebuild b/app-office/akonadi-server/akonadi-server-1.10.1-r1.ebuild
index 4a41f066b7e0..296e00b14841 100644
--- a/app-office/akonadi-server/akonadi-server-1.10.1.ebuild
+++ b/app-office/akonadi-server/akonadi-server-1.10.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.10.1.ebuild,v 1.1 2013/07/23 17:39:21 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.10.1-r1.ebuild,v 1.1 2013/07/24 11:39:27 mschiff Exp $
EAPI=5
@@ -91,6 +91,7 @@ pkg_setup() {
}
src_configure() {
+ epatch "${FILESDIR}"/${P}-fix_psql.patch
local mycmakeargs=(
-DAKONADI_USE_STRIGI_SEARCH=OFF
-DINSTALL_QSQLITE_IN_QT_PREFIX=ON
diff --git a/app-office/akonadi-server/files/akonadi-server-1.10.1-fix_psql.patch b/app-office/akonadi-server/files/akonadi-server-1.10.1-fix_psql.patch
new file mode 100644
index 000000000000..8cade4427f91
--- /dev/null
+++ b/app-office/akonadi-server/files/akonadi-server-1.10.1-fix_psql.patch
@@ -0,0 +1,19 @@
+commit f7bf081598dd58667751df0c1a3b601e095e6dfb
+Author: Andras Mantia <amantia@kde.org>
+Date: Wed Jul 24 12:48:05 2013 +0300
+
+ Fix (again) Akonadi for PostgreSql.
+ (cherry picked from commit 5b606c460834d63cf2953137748b66834c9ddb55)
+
+diff --git a/server/src/storage/datastore.cpp b/server/src/storage/datastore.cpp
+index 553d963..41a0927 100644
+--- a/server/src/storage/datastore.cpp
++++ b/server/src/storage/datastore.cpp
+@@ -238,6 +238,7 @@ bool DataStore::doAppendItemsFlag( const PimItem::List &items, const Flag &flag,
+ QueryBuilder qb2( PimItemFlagRelation::tableName(), QueryBuilder::Insert );
+ qb2.setColumnValue( PimItemFlagRelation::leftColumn(), appendIds );
+ qb2.setColumnValue( PimItemFlagRelation::rightColumn(), flagIds );
++ qb2.setIdentificationColumn( QString() );
+ if ( !qb2.exec() ) {
+ akDebug() << "Failed to execute query:" << qb2.query().lastError();
+ return false;