summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-06-07 12:51:18 +0000
committerAlin Năstac <mrness@gentoo.org>2008-06-07 12:51:18 +0000
commit4e69dc51bd06310c510f6857f93212c2cc525103 (patch)
tree78a802f9c8aea227a65a886c2219099a9b6c5808 /app-mobilephone
parentAdded p.masked Live SVN ebuild (diff)
downloadgentoo-2-4e69dc51bd06310c510f6857f93212c2cc525103.tar.gz
gentoo-2-4e69dc51bd06310c510f6857f93212c2cc525103.tar.bz2
gentoo-2-4e69dc51bd06310c510f6857f93212c2cc525103.zip
Install support for all languages if all selected LINGUAS are not supported.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gammu/ChangeLog8
-rw-r--r--app-mobilephone/gammu/gammu-1.20.0-r1.ebuild (renamed from app-mobilephone/gammu/gammu-1.20.0.ebuild)21
2 files changed, 22 insertions, 7 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index be6734a55ff7..38008cfad986 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/gammu
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.54 2008/06/07 09:42:54 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.55 2008/06/07 12:51:18 mrness Exp $
+
+*gammu-1.20.0-r1 (07 Jun 2008)
+
+ 07 Jun 2008; Alin Năstac <mrness@gentoo.org> -gammu-1.20.0.ebuild,
+ +gammu-1.20.0-r1.ebuild:
+ Install support for all languages if all selected LINGUAS are not supported.
*gammu-1.20.0 (07 Jun 2008)
diff --git a/app-mobilephone/gammu/gammu-1.20.0.ebuild b/app-mobilephone/gammu/gammu-1.20.0-r1.ebuild
index 4545ab7caf71..8e93e5fbee1b 100644
--- a/app-mobilephone/gammu/gammu-1.20.0.ebuild
+++ b/app-mobilephone/gammu/gammu-1.20.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.20.0.ebuild,v 1.1 2008/06/07 09:42:54 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.20.0-r1.ebuild,v 1.1 2008/06/07 12:51:18 mrness Exp $
inherit cmake-utils
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
dev-util/cmake"
+# sys-devel/gettext is needed for creating .mo files
# Supported languages and translated documentation
# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" cs de es it pl ru"
@@ -30,14 +31,22 @@ IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
src_unpack() {
unpack ${A}
- # sys-devel/gettext is needed for creating .mo files
- pushd "${S}/locale"
- local lang
+ pushd "${S}"/locale || die "locale directory not found"
+ local lang support_linguas=no
for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if ! use linguas_${lang} ; then
- sed -i -e "/^[[:space:]]*${lang}[[:space:]]*$/d" CMakeLists.txt
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
fi
done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ sed -i -e "/^[[:space:]]*${lang}[[:space:]]*$/d" CMakeLists.txt
+ fi
+ done
+ fi
popd
}