summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-02-01 12:58:08 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-02-01 12:58:08 +0000
commitdddfc6fbc1f2be20c5f514687af5378f2afd85dc (patch)
tree33e28704952a6cb2125909a21536e5fb84094e6d /app-misc
parentDrop old. Fixes CPU_FLAGS_X86 incompat, bug #538266. (diff)
downloadgentoo-2-dddfc6fbc1f2be20c5f514687af5378f2afd85dc.tar.gz
gentoo-2-dddfc6fbc1f2be20c5f514687af5378f2afd85dc.tar.bz2
gentoo-2-dddfc6fbc1f2be20c5f514687af5378f2afd85dc.zip
Version bump. Bug 538376
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/screenfetch/ChangeLog9
-rw-r--r--app-misc/screenfetch/screenfetch-3.6.5.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/app-misc/screenfetch/ChangeLog b/app-misc/screenfetch/ChangeLog
index 7a0192f9564e..cca2a0cd6d61 100644
--- a/app-misc/screenfetch/ChangeLog
+++ b/app-misc/screenfetch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/screenfetch
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screenfetch/ChangeLog,v 1.12 2014/07/14 16:43:15 hwoarang Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screenfetch/ChangeLog,v 1.13 2015/02/01 12:58:08 hwoarang Exp $
+
+*screenfetch-3.6.5 (01 Feb 2015)
+
+ 01 Feb 2015; Markos Chandras <hwoarang@gentoo.org> +screenfetch-3.6.5.ebuild:
+ Version bump. Bug 538376
14 Jul 2014; Markos Chandras <hwoarang@gentoo.org> screenfetch-2.7.7.ebuild,
screenfetch-3.2.2.ebuild, screenfetch-9999.ebuild:
diff --git a/app-misc/screenfetch/screenfetch-3.6.5.ebuild b/app-misc/screenfetch/screenfetch-3.6.5.ebuild
new file mode 100644
index 000000000000..64d40f0672d5
--- /dev/null
+++ b/app-misc/screenfetch/screenfetch-3.6.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screenfetch/screenfetch-3.6.5.ebuild,v 1.1 2015/02/01 12:58:08 hwoarang Exp $
+
+EAPI=4
+
+MY_PN="${PN/f/F}"
+DESCRIPTION="A Bash Screenshot Information Tool"
+HOMEPAGE="https://github.com/KittyKatt/screenFetch"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> \
+ ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="X"
+
+DEPEND=""
+RDEPEND="X? ( media-gfx/scrot x11-apps/xdpyinfo )"
+
+src_install() {
+ newbin ${PN}-dev ${PN}
+ dodoc CHANGELOG README.mkdn TODO
+}