summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2014-02-09 17:28:26 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2014-02-09 17:28:26 +0000
commitc01f21541ba97a16cf4d4b824fbab0743680edd8 (patch)
tree073ec135192a762650d6ea2fe547fe56b4932171 /app-misc
parentStable for amd64 wrt bug #499148 (diff)
downloadgentoo-2-c01f21541ba97a16cf4d4b824fbab0743680edd8.tar.gz
gentoo-2-c01f21541ba97a16cf4d4b824fbab0743680edd8.tar.bz2
gentoo-2-c01f21541ba97a16cf4d4b824fbab0743680edd8.zip
Add patch to fix adding pictures in "oddball WMs" per bug #489974
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 341D8825)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gourmet/ChangeLog11
-rw-r--r--app-misc/gourmet/files/gourmet-0.16.1-pictures-dir.patch13
-rw-r--r--app-misc/gourmet/gourmet-0.16.1-r3.ebuild64
3 files changed, 86 insertions, 2 deletions
diff --git a/app-misc/gourmet/ChangeLog b/app-misc/gourmet/ChangeLog
index 0213e11caae5..a68ab7f2a5a9 100644
--- a/app-misc/gourmet/ChangeLog
+++ b/app-misc/gourmet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/gourmet
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gourmet/ChangeLog,v 1.38 2013/11/19 02:45:49 nixphoeni Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gourmet/ChangeLog,v 1.39 2014/02/09 17:28:26 nixphoeni Exp $
+
+*gourmet-0.16.1-r3 (09 Feb 2014)
+
+ 09 Feb 2014; Joe Sapp <nixphoeni@gentoo.org> +gourmet-0.16.1-r3.ebuild,
+ +files/gourmet-0.16.1-pictures-dir.patch:
+ Add patch to fix adding pictures in "oddball WMs" per bug #489974 (thanks
+ m0par)
*gourmet-0.16.1-r2 (19 Nov 2013)
diff --git a/app-misc/gourmet/files/gourmet-0.16.1-pictures-dir.patch b/app-misc/gourmet/files/gourmet-0.16.1-pictures-dir.patch
new file mode 100644
index 000000000000..5c2bc3161baa
--- /dev/null
+++ b/app-misc/gourmet/files/gourmet-0.16.1-pictures-dir.patch
@@ -0,0 +1,13 @@
+--- gourmet/gtk_extras/dialog_extras.py 2013-10-31 09:03:08.456469166 -0500
++++ gourmet/gtk_extras/dialog_extras.py 2013-10-31 09:04:18.175067008 -0500
+@@ -1096,7 +1096,9 @@
+ buttons=None
+ ):
+ FileSelectorDialog.__init__(self, title, filename, filters, action, set_filter, buttons)
+- self.fsd.set_current_folder(get_user_special_dir(USER_DIRECTORY_PICTURES))
++ pictures_dir = get_user_special_dir(USER_DIRECTORY_PICTURES)
++ if not pictures_dir == None:
++ self.fsd.set_current_folder(pictures_dir)
+
+ def post_dialog (self):
+ self.preview = gtk.Image()
diff --git a/app-misc/gourmet/gourmet-0.16.1-r3.ebuild b/app-misc/gourmet/gourmet-0.16.1-r3.ebuild
new file mode 100644
index 000000000000..63893169c2dd
--- /dev/null
+++ b/app-misc/gourmet/gourmet-0.16.1-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gourmet/gourmet-0.16.1-r3.ebuild,v 1.1 2014/02/09 17:28:26 nixphoeni Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="sqlite"
+# Parallel builds fail when building translations
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="Recipe Organizer and Shopping List Generator for Gnome"
+HOMEPAGE="http://thinkle.github.com/gourmet/"
+SRC_URI="https://github.com/thinkle/gourmet/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="-i18n -ipython pdf print spell sound web"
+
+RDEPEND=">=dev-python/pygtk-2.22.0:2[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.7.9-r1[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ i18n? ( dev-python/elib-intl[${PYTHON_USEDEP}] )
+ ipython? ( >=dev-python/ipython-0.13.2[${PYTHON_USEDEP}] )
+ pdf? ( >=dev-python/reportlab-2.6[${PYTHON_USEDEP}]
+ >=dev-python/python-poppler-0.12.1-r4[${PYTHON_USEDEP}] )
+ print? ( >=dev-python/reportlab-2.6[${PYTHON_USEDEP}]
+ >=dev-python/python-poppler-0.12.1-r4[${PYTHON_USEDEP}] )
+ spell? ( dev-python/gtkspell-python )
+ sound? ( >=dev-python/gst-python-0.10.22-r1:0.10[${PYTHON_USEDEP}] )
+ web? ( >=dev-python/beautifulsoup-3.2.1-r1:python-2[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ >=dev-python/python-distutils-extra-2.37-r1[${PYTHON_USEDEP}]"
+
+PATCHES=( ${FILESDIR}/no-docs.patch \
+ ${FILESDIR}/nutritional-db-fix.patch \
+ ${FILESDIR}/desktop-entry.patch \
+ ${FILESDIR}/${P}-PIL-png.patch \
+ ${FILESDIR}/${P}-pictures-dir.patch )
+# distutils gets a bunch of default docs
+DOCS=( ChangeLog CODING FAQ TESTS TODO )
+
+python_prepare_all() {
+ # Modify these lines before copying them out
+ sed -i "s:base_dir = '..':base_dir = '/usr/share':" gourmet/settings.py || die
+ sed -i 's:data_dir = os.path.join(base_dir, "gourmet", "data"):data_dir = os.path.join(base_dir, "gourmet"):' gourmet/settings.py || die
+ sed -i 's:\(icon_base = os.path.join(data_dir,\) "icons",:\1 "gourmet",:' gourmet/settings.py || die
+ sed -i 's:\(locale_base = os.path.join(base_dir, "gourmet",\) "build",:\1:' gourmet/settings.py || die
+ sed -i 's:\(plugin_base = os.path.join(base_dir,\) "gourmet", "build", "share",:\1:' gourmet/settings.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_prepare() {
+ distutils-r1_python_prepare
+ sed -i "s:\(lib_dir = \)'../gourmet':\1'$(python_get_sitedir)':" gourmet/settings.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman gourmet.1
+}