summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2007-05-05 08:56:38 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2007-05-05 08:56:38 +0000
commit91fc4be7eb422aa8da8b96c721d35a2fbdc7b0d7 (patch)
tree885de3867d42082c642ad97c73a57092dc943039 /app-misc
parentAdded: NEED_PYTHON, doc/examples use-flags, ~amd64 keyword. Dropped old versi... (diff)
downloadgentoo-2-91fc4be7eb422aa8da8b96c721d35a2fbdc7b0d7.tar.gz
gentoo-2-91fc4be7eb422aa8da8b96c721d35a2fbdc7b0d7.tar.bz2
gentoo-2-91fc4be7eb422aa8da8b96c721d35a2fbdc7b0d7.zip
Use gsize instead of guint, patch by Radoslaw Szkodzinski, added ~amd64; bug 176604
(Portage version: 2.1.2.6)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/discomatic/ChangeLog9
-rw-r--r--app-misc/discomatic/discomatic-0.3.ebuild21
-rw-r--r--app-misc/discomatic/files/discomatic-0.3-glib.patch11
3 files changed, 32 insertions, 9 deletions
diff --git a/app-misc/discomatic/ChangeLog b/app-misc/discomatic/ChangeLog
index 0bb5955162ea..9d33e025e590 100644
--- a/app-misc/discomatic/ChangeLog
+++ b/app-misc/discomatic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/discomatic
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/discomatic/ChangeLog,v 1.9 2006/10/21 09:05:31 dertobi123 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/discomatic/ChangeLog,v 1.10 2007/05/05 08:56:38 dertobi123 Exp $
+
+ 05 May 2007; Tobias Scherbaum <dertobi123@gentoo.org>
+ +files/discomatic-0.3-glib.patch, discomatic-0.3.ebuild:
+ Use gsize instead of guint, patch by Radoslaw Szkodzinski, added ~amd64; bug
+ 176604
21 Oct 2006; Tobias Scherbaum <dertobi123@gentoo.org>
discomatic-0.3.ebuild:
diff --git a/app-misc/discomatic/discomatic-0.3.ebuild b/app-misc/discomatic/discomatic-0.3.ebuild
index 914b445116ae..4b0700c53821 100644
--- a/app-misc/discomatic/discomatic-0.3.ebuild
+++ b/app-misc/discomatic/discomatic-0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/discomatic/discomatic-0.3.ebuild,v 1.9 2006/10/21 09:05:31 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/discomatic/discomatic-0.3.ebuild,v 1.10 2007/05/05 08:56:38 dertobi123 Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="GTK+ CD-ROM archiving tool for mastering and burning multiple CD-ROM"
HOMEPAGE="http://discomatic.sourceforge.net"
@@ -10,12 +10,19 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="ppc x86"
+KEYWORDS="~amd64 ppc x86"
IUSE=""
-RDEPEND=">=dev-libs/glib-2.2
- >=x11-libs/gtk+-2.2"
-DEPEND="${RDEPEND}
+RDEPEND="${DEPEND}
+ virtual/cdrtools"
+DEPEND=">=dev-libs/glib-2.2
+ >=x11-libs/gtk+-2.2
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-glib.patch
+}
+
DOCS="AUTHORS ChangeLog INSTALL NEWS README* TODO"
diff --git a/app-misc/discomatic/files/discomatic-0.3-glib.patch b/app-misc/discomatic/files/discomatic-0.3-glib.patch
new file mode 100644
index 000000000000..0b155b909100
--- /dev/null
+++ b/app-misc/discomatic/files/discomatic-0.3-glib.patch
@@ -0,0 +1,11 @@
+--- discomatic-0.3/src/process.cpp.orig 2003-10-17 22:54:37.000000000 +0200
++++ discomatic-0.3/src/process.cpp 2007-04-30 18:34:43.000000000 +0200
+@@ -134,7 +134,7 @@
+ int Process::processInput(GIOChannel *source){
+ gchar buf;
+ gchar *buf2;
+- guint count;
++ gsize count;
+ g_io_channel_read(source, &buf, 1, &count);
+ if(count){
+ if(buf == '\b'){