summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-28 07:02:52 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-28 07:02:52 +0000
commit36b5c3635cbdb06355d3f7e31d4b0d97de999ea1 (patch)
tree111940ae2e05344b40b5bca33761fb0dc0fa8239 /app-misc/pax-utils
parentPropogate sse changes to the rest. (diff)
downloadgentoo-2-36b5c3635cbdb06355d3f7e31d4b0d97de999ea1.tar.gz
gentoo-2-36b5c3635cbdb06355d3f7e31d4b0d97de999ea1.tar.bz2
gentoo-2-36b5c3635cbdb06355d3f7e31d4b0d97de999ea1.zip
Add support for FreeBSD and fix cross-endian bugs.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-misc/pax-utils')
-rw-r--r--app-misc/pax-utils/ChangeLog7
-rw-r--r--app-misc/pax-utils/files/digest-pax-utils-0.0.91
-rw-r--r--app-misc/pax-utils/pax-utils-0.0.9.ebuild30
3 files changed, 37 insertions, 1 deletions
diff --git a/app-misc/pax-utils/ChangeLog b/app-misc/pax-utils/ChangeLog
index 1efdb8008891..35577ac22080 100644
--- a/app-misc/pax-utils/ChangeLog
+++ b/app-misc/pax-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/pax-utils
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.21 2005/05/21 19:01:40 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.22 2005/05/28 07:02:52 vapier Exp $
+
+*pax-utils-0.0.9 (28 May 2005)
+
+ 28 May 2005; Mike Frysinger <vapier@gentoo.org> +pax-utils-0.0.9.ebuild:
+ Add support for FreeBSD and fix cross-endian bugs.
21 May 2005; <solar@gentoo.org> :
Makefile: include/depend fix. dumpelf: display improvements, 32/64bit phdr
diff --git a/app-misc/pax-utils/files/digest-pax-utils-0.0.9 b/app-misc/pax-utils/files/digest-pax-utils-0.0.9
new file mode 100644
index 000000000000..ae0d584e8039
--- /dev/null
+++ b/app-misc/pax-utils/files/digest-pax-utils-0.0.9
@@ -0,0 +1 @@
+MD5 91278396fd87849759466a23647b231f pax-utils-0.0.9.tar.bz2 40028
diff --git a/app-misc/pax-utils/pax-utils-0.0.9.ebuild b/app-misc/pax-utils/pax-utils-0.0.9.ebuild
new file mode 100644
index 000000000000..6fbb185fa171
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.0.9.ebuild,v 1.1 2005/05/28 07:02:52 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Various ELF related utils for ELF32, ELF64 binaries useful for displaying PaX and security info on a large groups of bins"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="caps"
+
+DEPEND="caps? ( sys-libs/libcap )"
+
+src_compile() {
+ if use caps ; then
+ append-flags -DWANT_SYSCAP
+ append-ldflags -lcap
+ fi
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" all || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README
+}