summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-09-17 12:54:42 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-09-17 12:54:42 +0000
commitacc1f33f7960067edbe637b7b2ceb987a3f93b41 (patch)
treedae79066b4c7dee37a7349560c7b9b597884309e /app-misc/hivex
parentStable for x86, wrt bug #433227 (diff)
downloadgentoo-2-acc1f33f7960067edbe637b7b2ceb987a3f93b41.tar.gz
gentoo-2-acc1f33f7960067edbe637b7b2ceb987a3f93b41.tar.bz2
gentoo-2-acc1f33f7960067edbe637b7b2ceb987a3f93b41.zip
Add support for multiple python ABIs
(Portage version: 2.1.11.16/cvs/Linux i686)
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/ChangeLog9
-rw-r--r--app-misc/hivex/files/1.3.6-r1/fix_python_linking.patch11
-rw-r--r--app-misc/hivex/hivex-1.3.6-r2.ebuild114
3 files changed, 132 insertions, 2 deletions
diff --git a/app-misc/hivex/ChangeLog b/app-misc/hivex/ChangeLog
index 09719d239ca9..22a1132a7e89 100644
--- a/app-misc/hivex/ChangeLog
+++ b/app-misc/hivex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/hivex
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.19 2012/09/16 09:03:31 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.20 2012/09/17 12:54:42 maksbotan Exp $
+
+*hivex-1.3.6-r2 (17 Sep 2012)
+
+ 17 Sep 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/1.3.6-r1/fix_python_linking.patch, +hivex-1.3.6-r2.ebuild:
+ Add support for multiple python ABIs
16 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> metadata.xml:
Add name field to first maintainer in metadata
@@ -107,4 +113,3 @@
+files/autoconf_fix-1.3.0.patch, +hivex-1.3.1.ebuild,
+files/incorrect_format.patch, +metadata.xml:
Copy app-misc/hivex from rion-overlay, thanks to slepnoga. Bug #342217
-
diff --git a/app-misc/hivex/files/1.3.6-r1/fix_python_linking.patch b/app-misc/hivex/files/1.3.6-r1/fix_python_linking.patch
new file mode 100644
index 000000000000..283d68897de5
--- /dev/null
+++ b/app-misc/hivex/files/1.3.6-r1/fix_python_linking.patch
@@ -0,0 +1,11 @@
+--- python/Makefile.am 2012-06-12 14:12:50.000000000 +0400
++++ python/Makefile.am 2012-09-17 16:21:55.230278577 +0400
+@@ -35,7 +35,7 @@
+ libhivexmod_la_SOURCES = hivex-py.c
+ libhivexmod_la_CFLAGS = -Wall -I$(PYTHON_INCLUDEDIR) \
+ -I$(top_srcdir)/lib -I$(top_builddir)/lib
+-libhivexmod_la_LIBADD = $(top_builddir)/lib/libhivex.la
++libhivexmod_la_LIBADD = $(top_builddir)/lib/libhivex.la -lpython$(PYTHON_VERSION)
+ libhivexmod_la_LDFLAGS = -avoid-version -shared
+
+ TESTS_ENVIRONMENT = \
diff --git a/app-misc/hivex/hivex-1.3.6-r2.ebuild b/app-misc/hivex/hivex-1.3.6-r2.ebuild
new file mode 100644
index 000000000000..85bccd73db8c
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.6-r2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.6-r2.ebuild,v 1.1 2012/09/17 12:54:42 maksbotan Exp $
+
+EAPI=4
+
+WANT_AUTOMAKE="1.11"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+USE_RUBY="ruby18"
+RUBY_OPTIONAL=yes
+PYTHON_DEPEND="python? 2:2.6"
+SUPPORT_PYTHON_ABIS=1
+
+inherit autotools-utils eutils perl-app python
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline perl python test static-libs ruby"
+
+RDEPEND="virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline )
+ perl? ( dev-perl/IO-stringy )
+ "
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage )
+ )
+ ruby? ( dev-ruby/rake )
+ "
+PATCHES=( "${FILESDIR}"/${PV}-r1/disable_automagic_cumulative_patch.patch
+ "${FILESDIR}"/${PV}-r1/fix_python_linking.patch )
+
+DOCS=(README)
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+ if use perl; then
+ perl-module_pkg_setup
+ fi
+}
+
+src_prepare() {
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ $(use_enable python)
+ $(use_enable ruby)
+ --disable-rpath )
+
+ autotools-utils_src_configure
+
+ if use perl; then
+ pushd perl
+ perl-app_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+src_test() {
+ if use perl;then
+ pushd perl
+ perl-app_src_install
+ popd
+ fi
+
+ autotools-utils_src_compile check
+}
+
+src_install() {
+ strip-linguas -i po
+
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ if use perl; then
+ fixlocalpod
+ fi
+ if use python; then
+ compile_and_install() {
+ emake -C python clean
+ emake -C python PYTHON_VERSION="${PYTHON_ABI}" \
+ PYTHON_INCLUDEDIR="$(python_get_includedir)" \
+ PYTHON_INSTALLDIR="$(python_get_sitedir)" \
+ DESTDIR="${ED}" install
+ }
+ python_execute_function compile_and_install
+ fi
+}