summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-01-19 02:25:18 +0000
committerMichael Weber <xmw@gentoo.org>2012-01-19 02:25:18 +0000
commit8902a10fac3a18fcf02eef933abfadc0b8f6c78e (patch)
treecbc91b801338d07fffd3670f80767e0502db5e1f /app-misc/golly/golly-2.3.ebuild
parentVersion bump for beta channel release. (diff)
downloadgentoo-2-8902a10fac3a18fcf02eef933abfadc0b8f6c78e.tar.gz
gentoo-2-8902a10fac3a18fcf02eef933abfadc0b8f6c78e.tar.bz2
gentoo-2-8902a10fac3a18fcf02eef933abfadc0b8f6c78e.zip
Version bump (thanks Maks Verver, bug 395757)
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/golly/golly-2.3.ebuild')
-rw-r--r--app-misc/golly/golly-2.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/golly/golly-2.3.ebuild b/app-misc/golly/golly-2.3.ebuild
new file mode 100644
index 000000000000..73eca31f36e8
--- /dev/null
+++ b/app-misc/golly/golly-2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/golly-2.3.ebuild,v 1.1 2012/01/19 02:25:18 xmw Exp $
+
+EAPI=2
+PYTHON_DEPEND=2
+WX_GTK_VER=2.8
+
+inherit eutils python wxwidgets
+
+MY_P=${P}-src
+DESCRIPTION="A simulator for Conway's Game of Life and other cellular automata"
+HOMEPAGE="http://golly.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf \
+ --with-perl-shlib="libperl.so" \
+ --with-python-shlib="$(python_get_library)"
+}
+
+src_install() {
+ emake docdir= DESTDIR="${D}" install || die
+ dodoc README
+}