summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-26 17:24:55 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-26 17:24:55 +0000
commitbbdea0664fc04cb98c9feaf1df4e964aaefbaddc (patch)
tree64a5659cd562ec243416ca2025c1b5898d7641b1 /app-misc/glimpse
parentamd64 stable wrt bug #214913 (diff)
downloadgentoo-2-bbdea0664fc04cb98c9feaf1df4e964aaefbaddc.tar.gz
gentoo-2-bbdea0664fc04cb98c9feaf1df4e964aaefbaddc.tar.bz2
gentoo-2-bbdea0664fc04cb98c9feaf1df4e964aaefbaddc.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-misc/glimpse')
-rw-r--r--app-misc/glimpse/files/4.17.4-gcc3.patch58
-rw-r--r--app-misc/glimpse/glimpse-4.17.4.ebuild44
2 files changed, 0 insertions, 102 deletions
diff --git a/app-misc/glimpse/files/4.17.4-gcc3.patch b/app-misc/glimpse/files/4.17.4-gcc3.patch
deleted file mode 100644
index 6ed6c292eba6..000000000000
--- a/app-misc/glimpse/files/4.17.4-gcc3.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-diff -Naur glimpse-4.17.4-old/libtemplate/include/util.h glimpse-4.17.4/libtemplate/include/util.h
---- glimpse-4.17.4-old/libtemplate/include/util.h 1999-11-03 16:40:57.000000000 -0500
-+++ glimpse-4.17.4/libtemplate/include/util.h 2004-03-01 19:07:06.438665221 -0500
-@@ -93,9 +93,14 @@
- void init_log3 _PARAMS((char *,FILE *,FILE *)); /* Initialize log routines */
- void log_errno _PARAMS((char *)); /* Same as perror(3) */
- void fatal_errno _PARAMS((char *)); /* Same as perror(3) & exit */
--#ifdef __STRICT_ANSI__
-+#if defined(__STRICT_ANSI__) || (defined(__GNUC__) && __GNUC__ >= 3)
- #include <stdarg.h>
-+# if defined(__GNUC__)
-+#define log xlog
-+void xlog _PARAMS((char *, ...)); /* Log a message */
-+# else
- void log _PARAMS((char *, ...)); /* Log a message */
-+# endif
- void errorlog _PARAMS((char *, ...)); /* Log an error message */
- void fatal _PARAMS((char *, ...)); /* Log error msg and exit */
- #else
-diff -Naur glimpse-4.17.4-old/libtemplate/util/log.c glimpse-4.17.4/libtemplate/util/log.c
---- glimpse-4.17.4-old/libtemplate/util/log.c 1999-11-03 15:42:14.000000000 -0500
-+++ glimpse-4.17.4/libtemplate/util/log.c 2004-03-01 19:07:13.934576926 -0500
-@@ -55,7 +55,7 @@
- #include <errno.h>
- #include <time.h>
- #include <sys/file.h>
--#if defined(__STRICT_ANSI__)
-+#if defined(__STRICT_ANSI__) || (defined(__GNUC__) && __GNUC__ >= 3)
- #include <stdarg.h>
- #else
- #include <varargs.h>
-@@ -119,7 +119,7 @@
- /*
- * log() - used like printf(3). Prints message to stdout.
- */
--#if defined(__STRICT_ANSI__)
-+#if defined(__STRICT_ANSI__) || (defined(__GNUC__) && __GNUC__ >= 3)
- void log(char *fmt,...)
- {
- va_list ap;
-@@ -155,7 +155,7 @@
- /*
- * errorlog() - used like printf(3). Prints error message to stderr.
- */
--#if defined(__STRICT_ANSI__)
-+#if defined(__STRICT_ANSI__) || (defined(__GNUC__) && __GNUC__ >= 3)
- void errorlog(char *fmt,...)
- {
- va_list ap;
-@@ -193,7 +193,7 @@
- /*
- * fatal() - used like printf(3). Prints error message to stderr and exits
- */
--#if defined(__STRICT_ANSI__)
-+#if defined(__STRICT_ANSI__) || (defined(__GNUC__) && __GNUC__ >= 3)
- void fatal(char *fmt,...)
- {
- va_list ap;
diff --git a/app-misc/glimpse/glimpse-4.17.4.ebuild b/app-misc/glimpse/glimpse-4.17.4.ebuild
deleted file mode 100644
index b495e2998663..000000000000
--- a/app-misc/glimpse/glimpse-4.17.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/glimpse/glimpse-4.17.4.ebuild,v 1.12 2007/04/15 16:40:21 drac Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="A index/query system to search a large set of files quickly"
-HOMEPAGE="http://webglimpse.net/"
-SRC_URI="http://webglimpse.net/trial/${P}.tar.gz"
-
-LICENSE="glimpse"
-SLOT="0"
-KEYWORDS="mips"
-IUSE="static"
-
-RDEPEND="!dev-libs/tre
- !app-text/agrep"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-gcc3.patch
- sed -i -e 's:-O3 -fomit-frame-pointer:$(OPTIMIZEFLAGS):' \
- dynfilters/Makefile.in \
- || die "removing -O3 failed"
- sed -i -e '/^CFLAGS/s:$: $(OPTIMIZEFLAGS):' \
- {agrep,compress,index}/Makefile.in \
- Makefile.in \
- libtemplate/{template,util}/Makefile.in \
- || die "inserting OPTIMIZEFLAGS failed"
-}
-
-src_compile() {
- use static && append-ldflags -static
-
- econf || die
- emake -j1 OPTIMIZEFLAGS="${CFLAGS}" || die
-}
-
-src_install() {
- einstall || die
- dodir /usr/share/man/man1
- mv "${D}"/usr/share/man/*.1 "${D}"/usr/share/man/man1/
-}