summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-12-20 23:25:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-12-20 23:25:39 +0000
commitfeeac89f764e4a6a8afb63b680131a993b91bf83 (patch)
treec7a715e1e79e02eade9f84a25233290ed84791b2 /app-misc/figlet/figlet-222.ebuild
parentMade the ebuild call java-pkg_getjars with the proper argument format so emer... (diff)
downloadgentoo-2-feeac89f764e4a6a8afb63b680131a993b91bf83.tar.gz
gentoo-2-feeac89f764e4a6a8afb63b680131a993b91bf83.tar.bz2
gentoo-2-feeac89f764e4a6a8afb63b680131a993b91bf83.zip
version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-misc/figlet/figlet-222.ebuild')
-rw-r--r--app-misc/figlet/figlet-222.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/figlet/figlet-222.ebuild b/app-misc/figlet/figlet-222.ebuild
new file mode 100644
index 000000000000..ab75085cd40c
--- /dev/null
+++ b/app-misc/figlet/figlet-222.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-222.ebuild,v 1.1 2006/12/20 23:25:39 mr_bones_ Exp $
+
+inherit eutils bash-completion
+
+MY_P=${P/-/}
+DESCRIPTION="program for making large letters out of ordinary text"
+HOMEPAGE="http://www.figlet.org/"
+# Bug 35339 - add more fonts to figlet ebuild
+# The fonts are available from the figlet site, but they don't
+# have versions so we mirror them ourselves.
+SRC_URI="ftp://ftp.figlet.org/pub/figlet/program/unix/${MY_P}.tar.gz
+ mirror://gentoo/contributed-${PN}-221.tar.gz
+ mirror://gentoo/ms-dos-${PN}-221.tar.gz"
+
+LICENSE="AFL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ cp "${WORKDIR}"/contributed/C64-fonts/*.flf fonts/ || die
+ cp "${WORKDIR}"/contributed/bdffonts/*.flf fonts/ || die
+ cp "${WORKDIR}"/ms-dos/*.flf fonts/ || die
+ cp "${WORKDIR}"/contributed/*.flf fonts/ || die
+
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+ sed -i \
+ -e "s/CFLAGS = -g/CFLAGS = ${CFLAGS}/g" Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ make clean || die "make clean failed"
+ emake figlet || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man6 || die "dodir failed"
+ chmod +x figlist showfigfonts
+ emake \
+ DESTDIR="${D}"/usr/bin \
+ MANDIR="${D}"/usr/share/man/man6 \
+ DEFAULTFONTDIR="${D}"/usr/share/figlet \
+ install || die "make install failed"
+
+ dodoc README figfont.txt
+ dobashcompletion "${FILESDIR}"/figlet.bashcomp
+}