summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 19:27:36 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 19:27:36 +0000
commit50de2e27c44b48283a36b3ed46de051ede532d69 (patch)
treeec4b8e6b73b71d5fea998f77046d69c85010ce2e /app-misc/btail
parentold (diff)
downloadgentoo-2-50de2e27c44b48283a36b3ed46de051ede532d69.tar.gz
gentoo-2-50de2e27c44b48283a36b3ed46de051ede532d69.tar.bz2
gentoo-2-50de2e27c44b48283a36b3ed46de051ede532d69.zip
QA: Respect CC/CXX (bug 243612) and CFLAGS/LDFLAGS (bug 243616)
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-misc/btail')
-rw-r--r--app-misc/btail/ChangeLog7
-rw-r--r--app-misc/btail/btail-0.2.ebuild22
2 files changed, 17 insertions, 12 deletions
diff --git a/app-misc/btail/ChangeLog b/app-misc/btail/ChangeLog
index d201d46dffba..331c195082cb 100644
--- a/app-misc/btail/ChangeLog
+++ b/app-misc/btail/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/btail
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/btail/ChangeLog,v 1.3 2007/07/02 14:14:51 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/btail/ChangeLog,v 1.4 2008/12/30 19:27:36 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> btail-0.2.ebuild:
+ QA: Respect CC/CXX (bug 243612) and CFLAGS/LDFLAGS (bug 243616)
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> btail-0.2.ebuild:
(QA) RESTRICT clean up.
diff --git a/app-misc/btail/btail-0.2.ebuild b/app-misc/btail/btail-0.2.ebuild
index 3e1fe8858896..5ae7ee83f2d3 100644
--- a/app-misc/btail/btail-0.2.ebuild
+++ b/app-misc/btail/btail-0.2.ebuild
@@ -1,29 +1,31 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/btail/btail-0.2.ebuild,v 1.3 2007/07/02 14:14:51 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/btail/btail-0.2.ebuild,v 1.4 2008/12/30 19:27:36 angelos Exp $
inherit eutils
DESCRIPTION="Bayesian logfile filter"
HOMEPAGE="http://www.vanheusden.com/btail/"
SRC_URI="${HOMEPAGE}/${P}.tgz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
-#RESTRICT="strip"
DEPEND="sys-libs/gdbm"
-#RDEPEND=""
src_unpack() {
- unpack ${A}; cd ${S}
+ unpack ${A}
+ sed -i -e "/^LDFLAGS/s/$/ ${LDFLAGS}/" "${S}"/Makefile
+}
- sed -i -e 1iCXX=$(tc-getCXX) \
- -e "s,^\(CXXFLAGS=\).*$,\1${CXXFLAGS}," \
- -e "s,^\(LDFLAGS=\),&${LDFLAGS} ," \
- -e "s,\$(CC) -Wall -W,$(tc-getCXX)," \
- Makefile
+src_compile() {
+ emake CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ || die "emake failed"
}
src_install() {