summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-24 09:11:15 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-24 09:11:15 +0000
commit68acacc9b50868a557ab253e6d68f656ae1c0bde (patch)
treeb3b9efb5fccef4a3dce2a59eb4c1443ed7dfeff8 /app-misc/boxes
parentStable for alpha, wrt bug #535364 (diff)
downloadgentoo-2-68acacc9b50868a557ab253e6d68f656ae1c0bde.tar.gz
gentoo-2-68acacc9b50868a557ab253e6d68f656ae1c0bde.tar.bz2
gentoo-2-68acacc9b50868a557ab253e6d68f656ae1c0bde.zip
Version bump; fixes format-security problems, #521076
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-misc/boxes')
-rw-r--r--app-misc/boxes/ChangeLog9
-rw-r--r--app-misc/boxes/boxes-1.1.2.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/app-misc/boxes/ChangeLog b/app-misc/boxes/ChangeLog
index dfc8d86e4b85..bffe641e5e25 100644
--- a/app-misc/boxes/ChangeLog
+++ b/app-misc/boxes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/boxes
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/ChangeLog,v 1.31 2014/12/22 12:02:23 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/ChangeLog,v 1.32 2015/02/24 09:11:15 jlec Exp $
+
+*boxes-1.1.2 (24 Feb 2015)
+
+ 24 Feb 2015; Justin Lecher <jlec@gentoo.org> +boxes-1.1.2.ebuild:
+ Version bump; fixes format-security problems, #521076
22 Dec 2014; Justin Lecher <jlec@gentoo.org> boxes-1.1.1.ebuild:
add github to HOMEPAGE, #533212
diff --git a/app-misc/boxes/boxes-1.1.2.ebuild b/app-misc/boxes/boxes-1.1.2.ebuild
new file mode 100644
index 000000000000..dcc6b393527b
--- /dev/null
+++ b/app-misc/boxes/boxes-1.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/boxes-1.1.2.ebuild,v 1.1 2015/02/24 09:11:15 jlec Exp $
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Draw any kind of boxes around your text"
+HOMEPAGE="http://boxes.thomasjensen.com/ https://github.com/ascii-boxes/boxes"
+SRC_URI="https://github.com/ascii-boxes/boxes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ "
+
+src_prepare() {
+ append-cflags -Iregexp -I. -ansi
+ append-ldflags -Lregexp
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin src/boxes
+ doman doc/boxes.1
+ dodoc README
+ insinto /usr/share/boxes
+ doins boxes-config
+}