summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-06-28 13:42:52 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-06-28 13:42:52 +0000
commit9a52f40efb3b360bb0febe42d6ab4f084cc3d0e0 (patch)
tree90360eba5f72d961b0f70f7dcc10f1804862e3fd /app-leechcraft
parentAdd missing dependency on dev-qt/qtxmlpatterns, bug #515298. Clean old. (diff)
downloadgentoo-2-9a52f40efb3b360bb0febe42d6ab4f084cc3d0e0.tar.gz
gentoo-2-9a52f40efb3b360bb0febe42d6ab4f084cc3d0e0.tar.bz2
gentoo-2-9a52f40efb3b360bb0febe42d6ab4f084cc3d0e0.zip
Add upstream patches for making dbus optional (and disabling it by default) and fixes for gcc-4.9, bug #513904 and bug #513404. Thanks to patrick for the report and to 0xd34df00d for the fixes.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-core/ChangeLog9
-rw-r--r--app-leechcraft/lc-core/files/lc-core-0.6.65-dbus-optional.patch87
-rw-r--r--app-leechcraft/lc-core/files/lc-core-0.6.65-gcc-4.9.patch48
-rw-r--r--app-leechcraft/lc-core/lc-core-0.6.65.ebuild8
4 files changed, 149 insertions, 3 deletions
diff --git a/app-leechcraft/lc-core/ChangeLog b/app-leechcraft/lc-core/ChangeLog
index 672ab0f2954c..d6a372fa79ca 100644
--- a/app-leechcraft/lc-core/ChangeLog
+++ b/app-leechcraft/lc-core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-leechcraft/lc-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/ChangeLog,v 1.18 2014/06/25 06:36:31 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/ChangeLog,v 1.19 2014/06/28 13:42:52 maksbotan Exp $
+
+ 28 Jun 2014; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/lc-core-0.6.65-dbus-optional.patch,
+ +files/lc-core-0.6.65-gcc-4.9.patch, lc-core-0.6.65.ebuild:
+ Add upstream patches for making dbus optional (and disabling it by default)
+ and fixes for gcc-4.9, bug #513904 and bug #513404. Thanks to patrick for the
+ report and to 0xd34df00d for the fixes.
25 Jun 2014; Patrick Lauer <patrick@gentoo.org> lc-core-0.6.65.ebuild,
lc-core-9999.ebuild:
diff --git a/app-leechcraft/lc-core/files/lc-core-0.6.65-dbus-optional.patch b/app-leechcraft/lc-core/files/lc-core-0.6.65-dbus-optional.patch
new file mode 100644
index 000000000000..6d784608b3bc
--- /dev/null
+++ b/app-leechcraft/lc-core/files/lc-core-0.6.65-dbus-optional.patch
@@ -0,0 +1,87 @@
+commit 2e221a116dacf7541af8bfe6110856a70b8a8f70
+Author: 0xd34df00d <0xd34df00d@gmail.com>
+Date: Mon Jun 16 14:54:15 2014 +0400
+
+ [Core] DBus loaders made optional.
+
+diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
+index c138fd5..dc2b8d6 100644
+--- a/src/core/CMakeLists.txt
++++ b/src/core/CMakeLists.txt
+@@ -5,8 +5,10 @@ include_directories (${CMAKE_CURRENT_BINARY_DIR}
+ ${Boost_INCLUDE_DIR}
+ )
+
++option (WITH_DBUS_LOADERS "Build D-Bus loaders on UNIX" OFF)
++
+ if (NOT USE_QT5)
+- if (NOT WIN32)
++ if (WITH_DBUS_LOADERS)
+ set (QT_USE_QTDBUS TRUE)
+ endif ()
+ set (QT_USE_QTNETWORK TRUE)
+@@ -101,7 +103,7 @@ set (SRCS
+ loaders/sopluginloader.cpp
+ )
+
+-if (UNIX AND NOT APPLE)
++if (WITH_DBUS_LOADERS)
+ set (SRCS
+ ${SRCS}
+ loaders/dbuspluginloader.cpp
+@@ -179,6 +181,6 @@ if (USE_QT5)
+ QT5_USE_MODULES (leechcraft Gui Network Widgets Xml Sql Script Concurrent DBus Svg)
+ endif ()
+
+-if (UNIX AND NOT APPLE)
++if (WITH_DBUS_LOADERS)
+ add_subdirectory (loaders/dbus)
+ endif ()
+commit 4017753193a769a8bf7de6a54ec2c66954401e2f
+Author: 0xd34df00d <0xd34df00d@gmail.com>
+Date: Mon Jun 16 17:15:57 2014 +0400
+
+ [Core] Fixed linking without WITH_DBUS_LOADERS.
+
+diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
+index dc2b8d6..5f593ea 100644
+--- a/src/core/CMakeLists.txt
++++ b/src/core/CMakeLists.txt
+@@ -7,6 +7,10 @@ include_directories (${CMAKE_CURRENT_BINARY_DIR}
+
+ option (WITH_DBUS_LOADERS "Build D-Bus loaders on UNIX" OFF)
+
++if (WITH_DBUS_LOADERS)
++ add_definitions (-DWITH_DBUS_LOADERS)
++endif ()
++
+ if (NOT USE_QT5)
+ if (WITH_DBUS_LOADERS)
+ set (QT_USE_QTDBUS TRUE)
+diff --git a/src/core/pluginmanager.cpp b/src/core/pluginmanager.cpp
+index e769715..4cb479a 100644
+--- a/src/core/pluginmanager.cpp
++++ b/src/core/pluginmanager.cpp
+@@ -56,9 +56,11 @@
+ #include "shortcutmanager.h"
+ #include "application.h"
+ #include "loaders/sopluginloader.h"
+-#ifdef Q_OS_LINUX
+- #include "loaders/dbuspluginloader.h"
++
++#ifdef WITH_DBUS_LOADERS
++#include "loaders/dbuspluginloader.h"
+ #endif
++
+ #include "settingstab.h"
+
+ namespace LeechCraft
+@@ -985,7 +987,7 @@ namespace LeechCraft
+
+ Loaders::IPluginLoader_ptr PluginManager::MakeLoader (const QString& filename)
+ {
+-#ifndef Q_OS_LINUX
++#ifndef WITH_DBUS_LOADERS
+ return Loaders::IPluginLoader_ptr (new Loaders::SOPluginLoader (filename));
+ #else
+ if (DBusMode_)
diff --git a/app-leechcraft/lc-core/files/lc-core-0.6.65-gcc-4.9.patch b/app-leechcraft/lc-core/files/lc-core-0.6.65-gcc-4.9.patch
new file mode 100644
index 000000000000..1ea3cc410c67
--- /dev/null
+++ b/app-leechcraft/lc-core/files/lc-core-0.6.65-gcc-4.9.patch
@@ -0,0 +1,48 @@
+From 2db7cf510491e3ef2f25341b35b3705acf824bc3 Mon Sep 17 00:00:00 2001
+From: 0xd34df00d <0xd34df00d@gmail.com>
+Date: Thu, 12 Jun 2014 23:38:39 +0400
+Subject: [PATCH] [Interfaces] Added missing include.
+
+---
+ src/interfaces/itexteditor.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/interfaces/itexteditor.h b/src/interfaces/itexteditor.h
+index 059b936..0004bc5 100644
+--- a/src/interfaces/itexteditor.h
++++ b/src/interfaces/itexteditor.h
+@@ -29,6 +29,7 @@
+
+ #pragma once
+
++#include <functional>
+ #include <QPair>
+ #include <QList>
+ #include <QRegExp>
+--
+1.9.3
+
+From 317cbe27a95cc6536f163c0c833eeb1b4fb3f53b Mon Sep 17 00:00:00 2001
+From: 0xd34df00d <0xd34df00d@gmail.com>
+Date: Thu, 12 Jun 2014 23:32:15 +0400
+Subject: [PATCH] [Util] Added a missing include.
+
+---
+ src/util/qml/plotitem.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/util/qml/plotitem.h b/src/util/qml/plotitem.h
+index 194c69c..8185851 100644
+--- a/src/util/qml/plotitem.h
++++ b/src/util/qml/plotitem.h
+@@ -29,6 +29,7 @@
+
+ #pragma once
+
++#include <functional>
+ #include <QDeclarativeItem>
+ #include "qmlconfig.h"
+
+--
+1.9.3
+
diff --git a/app-leechcraft/lc-core/lc-core-0.6.65.ebuild b/app-leechcraft/lc-core/lc-core-0.6.65.ebuild
index 29876db767dc..f96cfbe95cf1 100644
--- a/app-leechcraft/lc-core/lc-core-0.6.65.ebuild
+++ b/app-leechcraft/lc-core/lc-core-0.6.65.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/lc-core-0.6.65.ebuild,v 1.2 2014/06/25 06:36:31 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/lc-core-0.6.65.ebuild,v 1.3 2014/06/28 13:42:52 maksbotan Exp $
EAPI="5"
@@ -22,7 +22,6 @@ COMMON_DEPEND=">=dev-libs/boost-1.46
dev-qt/qtscript:4
dev-qt/qtsql:4[postgres?,sqlite?]
dev-qt/qtwebkit:4
- dev-qt/qtdbus:4
qwt? ( x11-libs/qwt:6 )"
DEPEND="${COMMON_DEPEND}
doc? ( app-doc/doxygen )"
@@ -35,6 +34,11 @@ RDEPEND="${COMMON_DEPEND}
REQUIRED_USE="|| ( postgres sqlite )"
+PATCHES=(
+ "${FILESDIR}"/${P}-dbus-optional.patch
+ "${FILESDIR}"/${P}-gcc-4.9.patch
+)
+
src_configure() {
local mycmakeargs=(
-DWITH_PLUGINS=False