summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-05-02 15:40:38 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-05-02 15:40:38 +0000
commit997102651ec126891dbc5fd1a727d23bf3badad5 (patch)
treed196f85aebb4a7328c5aef8bded8dc2546efb6fb /app-leechcraft
parentBump LeechCraft to 0.5.95, thanks to 0xd34df00d (diff)
downloadgentoo-2-997102651ec126891dbc5fd1a727d23bf3badad5.tar.gz
gentoo-2-997102651ec126891dbc5fd1a727d23bf3badad5.tar.bz2
gentoo-2-997102651ec126891dbc5fd1a727d23bf3badad5.zip
Bump app-leechcraft/lc-azoth to 0.5.95, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-azoth/ChangeLog7
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-0.5.95.ebuild95
2 files changed, 101 insertions, 1 deletions
diff --git a/app-leechcraft/lc-azoth/ChangeLog b/app-leechcraft/lc-azoth/ChangeLog
index b9da0588eed8..b5714add8920 100644
--- a/app-leechcraft/lc-azoth/ChangeLog
+++ b/app-leechcraft/lc-azoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-azoth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-azoth/ChangeLog,v 1.3 2013/04/14 16:17:36 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-azoth/ChangeLog,v 1.4 2013/05/02 15:40:38 pinkbyte Exp $
+
+*lc-azoth-0.5.95 (02 May 2013)
+
+ 02 May 2013; Sergey Popov <pinkbyte@gentoo.org> +lc-azoth-0.5.95.ebuild:
+ Bump app-leechcraft/lc-azoth to 0.5.95, thanks to 0xd34df00d
14 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> lc-azoth-9999.ebuild:
Correct doxygen dependency - add USE 'dot'
diff --git a/app-leechcraft/lc-azoth/lc-azoth-0.5.95.ebuild b/app-leechcraft/lc-azoth/lc-azoth-0.5.95.ebuild
new file mode 100644
index 000000000000..ff763e92f263
--- /dev/null
+++ b/app-leechcraft/lc-azoth/lc-azoth-0.5.95.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-azoth/lc-azoth-0.5.95.ebuild,v 1.1 2013/05/02 15:40:38 pinkbyte Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc astrality +acetamide +adiumstyles +autoidler +autopaste +birthdaynotifier
+ +chathistory +crypt +depester +embedmedia +herbicide +hili +isterique
+ +juick +keeso +lastseen +metacontacts media +msn +latex +nativeemoticons
+ +otroid +p100q +spell shx +standardstyles +xmpp +xtazy"
+
+COMMON_DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-qt/qtwebkit:4
+ dev-qt/qtmultimedia:4
+ autoidler? ( x11-libs/libXScrnSaver )
+ astrality? ( net-libs/telepathy-qt )
+ otroid? ( net-libs/libotr )
+ media? ( dev-qt/qtmultimedia:4 )
+ msn? ( net-libs/libmsn )
+ spell? ( app-text/hunspell )
+ xmpp? ( >=net-libs/qxmpp-0.7.6 media-libs/speex )
+ xtazy? ( dev-qt/qtdbus:4 )
+ crypt? ( app-crypt/qca app-crypt/qca-gnupg )"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+RDEPEND="${COMMON_DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )"
+
+REQUIRED_USE="|| ( standardstyles adiumstyles )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable astrality AZOTH_ASTRALITY)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable birthdaynotifier AZOTH_BIRTHDAYNOTIFIER)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable isterique AZOTH_ISTERIQUE)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable keeso AZOTH_KEESO)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable media MEDIACALLS)
+ $(cmake-utils_use_enable latex AZOTH_MODNOK)
+ $(cmake-utils_use_enable msn AZOTH_ZHEET)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable otroid AZOTH_OTROID)
+ $(cmake-utils_use_enable p100q AZOTH_P100Q)
+ $(cmake-utils_use_enable spell AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable shx AZOTH_SHX)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable xmpp AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
+
+pkg_postinst() {
+ if use spell; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}