summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-12-20 02:56:49 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-12-20 02:56:49 +0000
commit8b6a74d09ba06c9b3a565b569bee37af2add9b66 (patch)
tree39f6cee6eddea1cec30248b691f40f991f6e5faa /app-laptop
parentversion bump (bug #390065) (diff)
downloadgentoo-2-8b6a74d09ba06c9b3a565b569bee37af2add9b66.tar.gz
gentoo-2-8b6a74d09ba06c9b3a565b569bee37af2add9b66.tar.bz2
gentoo-2-8b6a74d09ba06c9b3a565b569bee37af2add9b66.zip
Version bump: fixes bug #375697 and bug #384735
(Portage version: 2.2.0_alpha81/cvs/Linux i686)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tp_smapi/ChangeLog7
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.41.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/app-laptop/tp_smapi/ChangeLog b/app-laptop/tp_smapi/ChangeLog
index eeddf6f027b2..d134e8602298 100644
--- a/app-laptop/tp_smapi/ChangeLog
+++ b/app-laptop/tp_smapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/tp_smapi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.42 2011/12/19 23:53:58 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.43 2011/12/20 02:56:49 ottxor Exp $
+
+*tp_smapi-0.41 (20 Dec 2011)
+
+ 20 Dec 2011; Christoph Junghans <ottxor@gentoo.org> +tp_smapi-0.41.ebuild:
+ Version bump: fixes bug #375697 and bug #384735
19 Dec 2011; Christoph Junghans <ottxor@gentoo.org>
files/tp_smapi-0.40-initd:
diff --git a/app-laptop/tp_smapi/tp_smapi-0.41.ebuild b/app-laptop/tp_smapi/tp_smapi-0.41.ebuild
new file mode 100644
index 000000000000..43afb114fe8d
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.41.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.41.ebuild,v 1.1 2011/12/20 02:56:49 ottxor Exp $
+
+EAPI=4
+
+inherit linux-mod
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="https://github.com/evgeni/tp_smapi/ http://tpctl.sourceforge.net/"
+SRC_URI="mirror://github/evgeni/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="hdaps"
+
+RESTRICT="userpriv"
+
+# We need dmideode if the kernel does not support DMI_DEV_TYPE_OEM_STRING
+# in dmi.h
+DEPEND="sys-apps/dmidecode"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 19; then
+ eerror
+ eerror "${P} requires Linux kernel 2.6.19 or above."
+ eerror
+ die "Unsupported kernel version"
+ fi
+
+ MODULE_NAMES="thinkpad_ec(extra:) tp_smapi(extra:)"
+ BUILD_PARAMS="KSRC=${KV_DIR} KBUILD=${KV_OUT_DIR}"
+ BUILD_TARGETS="default"
+
+ if use hdaps; then
+ CONFIG_CHECK="~INPUT_UINPUT"
+ WARNING_INPUT_UINPUT="Your kernel needs uinput for the hdaps module to perform better"
+ linux-info_pkg_setup
+
+ MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
+ BUILD_PARAMS="${BUILD_PARAMS} HDAPS=1"
+
+ CONFIG_CHECK="!SENSORS_HDAPS"
+ ERROR_SENSORS_HDAPS="${P} with USE=hdaps conflicts with in-kernel HDAPS (CONFIG_SENSORS_HDAPS)"
+ linux-info_pkg_setup
+ fi
+}
+
+pkg_setup() {
+ # run again as pkg_pretend is not var safe
+ pkg_pretend
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CHANGES README
+ newinitd "${FILESDIR}"/${PN}-0.40-initd smapi
+ newconfd "${FILESDIR}"/${PN}-0.40-confd smapi
+}