summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-05-27 19:04:29 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-05-27 19:04:29 +0000
commit3a5ecd67a94d899816705fb2a97640ad64eae833 (patch)
tree4160be88c5053b20dd45c388e83c2f2da70cc8cd /app-laptop
parentStable on alpha. (diff)
downloadgentoo-2-3a5ecd67a94d899816705fb2a97640ad64eae833.tar.gz
gentoo-2-3a5ecd67a94d899816705fb2a97640ad64eae833.tar.bz2
gentoo-2-3a5ecd67a94d899816705fb2a97640ad64eae833.zip
Version bump, thanks to Anton in bug #132519.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tp_smapi/ChangeLog7
-rw-r--r--app-laptop/tp_smapi/Manifest4
-rw-r--r--app-laptop/tp_smapi/files/digest-tp_smapi-0.201
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.20.ebuild42
4 files changed, 52 insertions, 2 deletions
diff --git a/app-laptop/tp_smapi/ChangeLog b/app-laptop/tp_smapi/ChangeLog
index 1019726eb0de..af3d37e687a9 100644
--- a/app-laptop/tp_smapi/ChangeLog
+++ b/app-laptop/tp_smapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/tp_smapi
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.9 2006/04/14 11:48:03 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.10 2006/05/27 19:04:29 brix Exp $
+
+*tp_smapi-0.20 (27 May 2006)
+
+ 27 May 2006; Henrik Brix Andersen <brix@gentoo.org> +tp_smapi-0.20.ebuild:
+ Version bump, thanks to Anton in bug #132519.
*tp_smapi-0.19 (14 Apr 2006)
diff --git a/app-laptop/tp_smapi/Manifest b/app-laptop/tp_smapi/Manifest
index dba15a67edd1..7c359fff8166 100644
--- a/app-laptop/tp_smapi/Manifest
+++ b/app-laptop/tp_smapi/Manifest
@@ -1,6 +1,8 @@
-MD5 700ecde17881130c599fb875bec815fb ChangeLog 1438
+MD5 dc6e97ba1f2e548b3df337c316827d6d ChangeLog 1594
MD5 2ae3b65a64a5f6052af081851efc5418 files/digest-tp_smapi-0.17 61
MD5 c6d54a83820a9d78c5256b265e3c104a files/digest-tp_smapi-0.19 61
+MD5 fa5f73ec580c8a3468c32d80ed64c134 files/digest-tp_smapi-0.20 61
MD5 b280eebc74d70d85e664debf1adce2c3 metadata.xml 255
MD5 f6933bb050bdb7903aa51daa2956f12e tp_smapi-0.17.ebuild 892
MD5 e0a8a500c5277fe19763e407e765c272 tp_smapi-0.19.ebuild 893
+MD5 e16ecf78d66f3f2ee98040b6290d7d95 tp_smapi-0.20.ebuild 793
diff --git a/app-laptop/tp_smapi/files/digest-tp_smapi-0.20 b/app-laptop/tp_smapi/files/digest-tp_smapi-0.20
new file mode 100644
index 000000000000..a593dbfa8eb5
--- /dev/null
+++ b/app-laptop/tp_smapi/files/digest-tp_smapi-0.20
@@ -0,0 +1 @@
+MD5 da5026c09e477514908e54387c3965da tp_smapi-0.20.tgz 34365
diff --git a/app-laptop/tp_smapi/tp_smapi-0.20.ebuild b/app-laptop/tp_smapi/tp_smapi-0.20.ebuild
new file mode 100644
index 000000000000..23b809ab93a2
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.20.ebuild,v 1.1 2006/05/27 19:04:29 brix Exp $
+
+inherit linux-mod
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="http://tpctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tpctl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="hdaps"
+
+BUILD_TARGETS="default"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 15; then
+ eerror
+ eerror "${P} requires Linux kernel 2.6.15 or above."
+ eerror
+ die "Unsupported kernel version"
+ fi
+
+ MODULE_NAMES="tp_base(extra:) tp_smapi(extra:)"
+ BUILD_PARAMS="KSRC=${KV_DIR}"
+
+ if use hdaps; then
+ MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
+ BUILD_PARAMS="${BUILD_PARAMS} HDAPS=1"
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc CHANGES README
+}