summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-26 09:35:34 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-26 09:35:34 +0000
commit13e74607bbfb5ea7e44527c4459dfe2e96645bfa (patch)
tree5032d9efecec37de422dd503b291b8d629674d26 /app-laptop
parentRemove patch that's applied upstream (diff)
downloadgentoo-2-13e74607bbfb5ea7e44527c4459dfe2e96645bfa.tar.gz
gentoo-2-13e74607bbfb5ea7e44527c4459dfe2e96645bfa.tar.bz2
gentoo-2-13e74607bbfb5ea7e44527c4459dfe2e96645bfa.zip
Apply patch from Mateusz Dziadko <matidz.gentoo@gmail.com> to compile against new kernels. Bug #342161
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkpad/ChangeLog9
-rw-r--r--app-laptop/thinkpad/files/thinkpad-5.9-ioctl.patch27
-rw-r--r--app-laptop/thinkpad/thinkpad-5.9-r1.ebuild7
3 files changed, 38 insertions, 5 deletions
diff --git a/app-laptop/thinkpad/ChangeLog b/app-laptop/thinkpad/ChangeLog
index 9f4ce098aa18..70c208117942 100644
--- a/app-laptop/thinkpad/ChangeLog
+++ b/app-laptop/thinkpad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/thinkpad
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/ChangeLog,v 1.21 2007/05/25 07:00:31 opfer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/ChangeLog,v 1.22 2011/06/26 09:35:33 hwoarang Exp $
+
+ 26 Jun 2011; Markos Chandras <hwoarang@gentoo.org> thinkpad-5.9-r1.ebuild,
+ +files/thinkpad-5.9-ioctl.patch:
+ Apply patch from Mateusz Dziadko <matidz.gentoo@gmail.com> to compile against
+ new kernels. Bug #342161
25 May 2007; Christian Faulhammer <opfer@gentoo.org> ChangeLog:
corrected ChangeLog, so it conforms to our standards
diff --git a/app-laptop/thinkpad/files/thinkpad-5.9-ioctl.patch b/app-laptop/thinkpad/files/thinkpad-5.9-ioctl.patch
new file mode 100644
index 000000000000..3f20744265b8
--- /dev/null
+++ b/app-laptop/thinkpad/files/thinkpad-5.9-ioctl.patch
@@ -0,0 +1,27 @@
+--- thinkpad-5.9.orig/2.6/drivers/thinkpad.c 2010-11-19 01:35:10.610000017 +0100
++++ thinkpad-5.9/2.6/drivers/thinkpad.c 2010-11-19 01:35:37.215000017 +0100
+@@ -66,7 +66,6 @@
+ struct file * pfileThe
+ );
+ static int thinkpad_ioctl(
+- struct inode * pinodeThe,
+ struct file * pfileThe,
+ unsigned int uintIoctlNum,
+ unsigned long ulongIoctlArg
+@@ -111,7 +110,7 @@
+ static flag_t _fInUse = 1;
+
+ static struct file_operations _fileopsThinkpad = {
+- .ioctl = thinkpad_ioctl,
++ .unlocked_ioctl = thinkpad_ioctl,
+ .open = thinkpad_open,
+ .release = thinkpad_release,
+ .owner = THIS_MODULE
+@@ -169,7 +168,6 @@
+
+
+ static int thinkpad_ioctl(
+- struct inode * pinodeThe,
+ struct file * pfileThe,
+ unsigned int uintIoctlNum,
+ unsigned long ulongIoctlArg
diff --git a/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild b/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild
index 6d84f6c9649c..108e26062cf7 100644
--- a/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild
+++ b/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild,v 1.6 2007/03/21 01:05:02 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild,v 1.7 2011/06/26 09:35:33 hwoarang Exp $
inherit eutils linux-mod
@@ -47,7 +47,8 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-5.9-remove-thinkpadapm-argument.patch
epatch "${FILESDIR}"/${PN}-5.9-remove-inter_module.patch
-
+ # bug 342161
+ epatch "${FILESDIR}"/${P}-ioctl.patch
kernel_is ge 2 6 0 && epatch "${FILESDIR}"/${P}-module-param.patch
}