summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-11-20 08:45:41 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-11-20 08:45:41 +0000
commit9a11cdf9b8840509f32279755d19aabaf04d1c22 (patch)
tree200cf426b31c5071e4ac689e0d0557252f8dd496 /app-laptop/spicctrl
parentVersion bump. (diff)
downloadgentoo-2-9a11cdf9b8840509f32279755d19aabaf04d1c22.tar.gz
gentoo-2-9a11cdf9b8840509f32279755d19aabaf04d1c22.tar.bz2
gentoo-2-9a11cdf9b8840509f32279755d19aabaf04d1c22.zip
Revision bump: EAPI 4, base eclass, respect LDFLAGS and compiler wrt bug #337317, keyword ~amd64
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-laptop/spicctrl')
-rw-r--r--app-laptop/spicctrl/ChangeLog9
-rw-r--r--app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch11
-rw-r--r--app-laptop/spicctrl/spicctrl-1.9-r1.ebuild29
3 files changed, 48 insertions, 1 deletions
diff --git a/app-laptop/spicctrl/ChangeLog b/app-laptop/spicctrl/ChangeLog
index 36d8cfcda560..2eddf83c3e1c 100644
--- a/app-laptop/spicctrl/ChangeLog
+++ b/app-laptop/spicctrl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-laptop/spicctrl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/spicctrl/ChangeLog,v 1.12 2012/11/18 10:52:24 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/spicctrl/ChangeLog,v 1.13 2012/11/20 08:45:41 pinkbyte Exp $
+
+*spicctrl-1.9-r1 (20 Nov 2012)
+
+ 20 Nov 2012; Sergey Popov <pinkbyte@gentoo.org> +spicctrl-1.9-r1.ebuild,
+ +files/spicctrl-1.9-makefile.patch:
+ Revision bump: EAPI 4, base eclass, respect LDFLAGS and compiler wrt bug
+ #337317, keyword ~amd64
18 Nov 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop mobile herd as talked in gentoo-dev ML
diff --git a/app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch b/app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch
new file mode 100644
index 000000000000..a49a29c30fb5
--- /dev/null
+++ b/app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2012-11-20 12:38:41.528871594 +0400
++++ Makefile 2012-11-20 12:39:42.630871103 +0400
+@@ -14,7 +14,7 @@
+ all: spicctrl
+
+ spicctrl: $(OBJ)
+- $(CC) -o spicctrl $(OBJ) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o spicctrl $(OBJ) $(LIBS)
+
+ clean:
+ rm -f $(OBJ) spicctrl *~
diff --git a/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild b/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild
new file mode 100644
index 000000000000..aa9ecd1e86ce
--- /dev/null
+++ b/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild,v 1.1 2012/11/20 08:45:41 pinkbyte Exp $
+
+EAPI=4
+
+inherit base toolchain-funcs
+
+DESCRIPTION="tool for the sonypi-Device (found in Sony Vaio Notebooks)"
+HOMEPAGE="http://www.popies.net/sonypi/"
+SRC_URI="http://www.popies.net/sonypi/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin spicctrl
+}