summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-11-18 20:39:56 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-11-18 20:39:56 +0000
commit9394e6915fedec8bbb208f9d7f0204cb31f66f5c (patch)
tree54350f373f363235c6ba036216e90ca742d5a9ac /app-laptop/hdapsd
parentFix Manifest. (diff)
downloadgentoo-2-9394e6915fedec8bbb208f9d7f0204cb31f66f5c.tar.gz
gentoo-2-9394e6915fedec8bbb208f9d7f0204cb31f66f5c.tar.bz2
gentoo-2-9394e6915fedec8bbb208f9d7f0204cb31f66f5c.zip
add auto-detecting of disks (bug #334435#c13)
(Portage version: 2.2.0_alpha142/cvs/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'app-laptop/hdapsd')
-rw-r--r--app-laptop/hdapsd/ChangeLog9
-rw-r--r--app-laptop/hdapsd/files/hdapsd.conf.3 (renamed from app-laptop/hdapsd/files/hdapsd.conf.2)3
-rw-r--r--app-laptop/hdapsd/files/hdapsd.init.3 (renamed from app-laptop/hdapsd/files/hdapsd.init.2)9
-rw-r--r--app-laptop/hdapsd/hdapsd-20090401-r2.ebuild (renamed from app-laptop/hdapsd/hdapsd-20090401-r1.ebuild)8
-rw-r--r--app-laptop/hdapsd/metadata.xml11
5 files changed, 27 insertions, 13 deletions
diff --git a/app-laptop/hdapsd/ChangeLog b/app-laptop/hdapsd/ChangeLog
index 7080dd1cc479..3e6f682125c5 100644
--- a/app-laptop/hdapsd/ChangeLog
+++ b/app-laptop/hdapsd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-laptop/hdapsd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/ChangeLog,v 1.20 2012/11/18 10:49:08 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/ChangeLog,v 1.21 2012/11/18 20:39:55 ottxor Exp $
+
+*hdapsd-20090401-r2 (18 Nov 2012)
+
+ 18 Nov 2012; Christoph Junghans <ottxor@gentoo.org> +files/hdapsd.conf.3,
+ +files/hdapsd.init.3, +hdapsd-20090401-r2.ebuild, -files/hdapsd.conf.2,
+ -files/hdapsd.init.2, -hdapsd-20090401-r1.ebuild, metadata.xml:
+ add auto-detecting of disks (bug #334435#c13)
18 Nov 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop mobile herd as talked in gentoo-dev ML
diff --git a/app-laptop/hdapsd/files/hdapsd.conf.2 b/app-laptop/hdapsd/files/hdapsd.conf.3
index 2f55a83bae87..509d3afa2013 100644
--- a/app-laptop/hdapsd/files/hdapsd.conf.2
+++ b/app-laptop/hdapsd/files/hdapsd.conf.3
@@ -1,6 +1,7 @@
# The list of the disk devices that hdapsd should monitor.
# Usually this is 'hda', 'sda' or 'hda sda'.
-DISKLIST="sda"
+# hdaps will auto-devices if empty
+#DISKLIST="sda"
# hdapsd sensitivity
# The lower the threshold is the earlier
diff --git a/app-laptop/hdapsd/files/hdapsd.init.2 b/app-laptop/hdapsd/files/hdapsd.init.3
index 80add2d32f9d..ef27368f7b5d 100644
--- a/app-laptop/hdapsd/files/hdapsd.init.2
+++ b/app-laptop/hdapsd/files/hdapsd.init.3
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2
depend() {
@@ -12,11 +12,12 @@ checkconfig() {
DISKLIST=${DISK}
fi
- if [[ -z ${DISKLIST} || -z ${THRESHOLD} ]] ; then
- eerror "You should setup DISKLIST and THRESHOLD in /etc/conf.d/hdapsd."
+ if [[ -z ${THRESHOLD} ]] ; then
+ eerror "You should setup THRESHOLD in /etc/conf.d/hdapsd."
return 1
fi
+ #empty DISKLIST is allowed as well
for DISK in ${DISKLIST}; do
if [ ! -b /dev/${DISK} ]; then
eerror "Could not find disk /dev/${DISK}!"
@@ -59,7 +60,7 @@ start() {
${DISKOPTS} --sensitivity "${THRESHOLD}" ${OPTIONS}
eend $?
}
-
+
stop() {
ebegin "Stopping Hard Drive Active Protection System daemon"
start-stop-daemon --stop --exec /usr/sbin/hdapsd \
diff --git a/app-laptop/hdapsd/hdapsd-20090401-r1.ebuild b/app-laptop/hdapsd/hdapsd-20090401-r2.ebuild
index d4774ceac80e..1416d3bf2154 100644
--- a/app-laptop/hdapsd/hdapsd-20090401-r1.ebuild
+++ b/app-laptop/hdapsd/hdapsd-20090401-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/hdapsd-20090401-r1.ebuild,v 1.1 2011/12/21 04:51:22 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/hdapsd-20090401-r2.ebuild,v 1.1 2012/11/18 20:39:55 ottxor Exp $
EAPI=4
inherit linux-info
@@ -28,8 +28,8 @@ src_install() {
emake DESTDIR="${ED}" install
rm -rf "${ED}"/usr/share/doc/hdapsd
dodoc ChangeLog README AUTHORS
- newconfd "${FILESDIR}"/hdapsd.conf.2 hdapsd
- newinitd "${FILESDIR}"/hdapsd.init.2 hdapsd
+ newconfd "${FILESDIR}"/hdapsd.conf.3 hdapsd
+ newinitd "${FILESDIR}"/hdapsd.init.3 hdapsd
}
pkg_postinst(){
diff --git a/app-laptop/hdapsd/metadata.xml b/app-laptop/hdapsd/metadata.xml
index acb91b4295a3..fe60e106f9c3 100644
--- a/app-laptop/hdapsd/metadata.xml
+++ b/app-laptop/hdapsd/metadata.xml
@@ -1,7 +1,12 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
-<longdescription>IBM ThinkPad Harddrive Active Protection disk head parking
- daemon</longdescription>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <longdescription>IBM ThinkPad Harddrive Active Protection disk head parking daemon</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">hdapsd</remote-id>
+ </upstream>
</pkgmetadata>