summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-09-05 23:47:14 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-09-05 23:47:14 +0000
commit7973d37008f9b7a07005b1a83a4326f9e770cf7b (patch)
tree0078f8cff5f67a11232df0a32955a7c3fd75a785 /app-i18n
parentAdd workaround for compatibility with epydoc-3. (diff)
downloadgentoo-2-7973d37008f9b7a07005b1a83a4326f9e770cf7b.tar.gz
gentoo-2-7973d37008f9b7a07005b1a83a4326f9e770cf7b.tar.bz2
gentoo-2-7973d37008f9b7a07005b1a83a4326f9e770cf7b.zip
Initial import. Submitted by Hong Hao, bug 236277.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus/ChangeLog10
-rw-r--r--app-i18n/ibus/Manifest4
-rw-r--r--app-i18n/ibus/ibus-0.1.1.20080901.ebuild89
-rw-r--r--app-i18n/ibus/metadata.xml11
4 files changed, 114 insertions, 0 deletions
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
new file mode 100644
index 000000000000..8846f924f2eb
--- /dev/null
+++ b/app-i18n/ibus/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-i18n/ibus
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.1 2008/09/05 23:47:14 matsuu Exp $
+
+*ibus-0.1.1.20080901 (05 Sep 2008)
+
+ 05 Sep 2008; MATSUU Takuto <matsuu@gentoo.org> +metadata.xml,
+ +ibus-0.1.1.20080901.ebuild:
+ Initial import. Submitted by Hong Hao, bug 236277.
+
diff --git a/app-i18n/ibus/Manifest b/app-i18n/ibus/Manifest
new file mode 100644
index 000000000000..af0596223f5b
--- /dev/null
+++ b/app-i18n/ibus/Manifest
@@ -0,0 +1,4 @@
+DIST ibus-0.1.1.20080901.tar.gz 630193 RMD160 e160730b7229aa7226dc915390dec7c3bd5c8b73 SHA1 536540bb57bd6c76790fa39796c93eb673f15207 SHA256 1775b67098050f5898176118db576de128d40dd6bb09731b0b6242022b3ea83d
+EBUILD ibus-0.1.1.20080901.ebuild 2148 RMD160 28f9e25a2aeda8c803a6db2097fa6d6e4306cf21 SHA1 1836cbc78040aa6f115595c05e235d5cd386903f SHA256 083bd2e3b19245d9fd44e3a218656d9a2be27bc69d4a422c7100e9cd7def9510
+MISC ChangeLog 299 RMD160 47f40b228f918ab9f36a33a753d51d0a6906684f SHA1 3ef9d5f7a8d072ab9c96d49db28525228af77bd9 SHA256 9045c3a37c2c35f8ace1cc0d1f3b63e56876893ac387d0c6fb67d0e3016de52a
+MISC metadata.xml 413 RMD160 78bf392cb0f922f9b1dbc39475d27dc90bd5c3e8 SHA1 8a2bcbd11ee50f43bd1211c6e484fe16126debe1 SHA256 fc7288848e696d0b27471658ee44467d2cdc7d7d40d38287cafa1299c20e00d4
diff --git a/app-i18n/ibus/ibus-0.1.1.20080901.ebuild b/app-i18n/ibus/ibus-0.1.1.20080901.ebuild
new file mode 100644
index 000000000000..2942a6f0921d
--- /dev/null
+++ b/app-i18n/ibus/ibus-0.1.1.20080901.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-0.1.1.20080901.ebuild,v 1.1 2008/09/05 23:47:14 matsuu Exp $
+
+EAPI="1"
+inherit multilib
+
+DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls qt4"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ dev-libs/dbus-glib
+ qt4? ( || (
+ (
+ >=x11-libs/qt-core-4.4:4
+ >=x11-libs/qt-dbus-4.4:4
+ )
+ >=x11-libs/qt-4.4:4
+ ) )
+ x11-libs/libX11
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ dev-python/pygtk
+ >=dev-python/dbus-python-0.83
+ dev-python/pyxdg
+ dev-python/gnome-python"
+
+pkg_setup() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable qt4 qt4-immodule) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bug to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "To use ibus, you should:"
+ elog "1. Get input engines from sunrise overlay."
+ elog " Run \"emerge -s ibus-\" in your favorite terminal"
+ elog " for a list of packages we already have."
+ elog "2. Set the following in your"
+ elog " user startup scripts such as .xinitrc or .bashrc"
+ elog
+ elog " export XMODIFIERS=\"@im=ibus\""
+ elog " export GTK_IM_MODULE=\"ibus\""
+ elog " export QT_IM_MODULE=\"ibus\""
+ elog " ibus &"
+ elog
+ if ! use qt4; then
+ ewarn "Missing qt4 use flag, ibus will not work in qt4 applications."
+ ebeep 3
+ fi
+ elog
+
+ if [ -x /usr/bin/gtk-query-immodules-2.0 ] ; then
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+ fi
+}
+
+pkg_postrm() {
+ if [ -x /usr/bin/gtk-query-immodules-2.0 ] ; then
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+ fi
+}
diff --git a/app-i18n/ibus/metadata.xml b/app-i18n/ibus/metadata.xml
new file mode 100644
index 000000000000..34b896cf3b73
--- /dev/null
+++ b/app-i18n/ibus/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+<longdescription lang="en">
+IBus is an Intelligent Input Bus. It is a new input framework for Linux OS.
+It provides full featured and user friendly input method user interface.
+It also may help developers to develop input method easily.
+</longdescription>
+</pkgmetadata>
+