summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-12 16:17:35 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-12 16:17:35 +0000
commit3d6368a61e2517d0e68e7a7f2ae72fd40cb0e35f (patch)
tree9b308f79755ef671e311c2211b555e72e6cbcf19 /app-i18n
parentVersion bumped. (diff)
downloadgentoo-2-3d6368a61e2517d0e68e7a7f2ae72fd40cb0e35f.tar.gz
gentoo-2-3d6368a61e2517d0e68e7a7f2ae72fd40cb0e35f.tar.bz2
gentoo-2-3d6368a61e2517d0e68e7a7f2ae72fd40cb0e35f.zip
Version bumped.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-qt/ChangeLog7
-rw-r--r--app-i18n/ibus-qt/ibus-qt-1.3.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-i18n/ibus-qt/ChangeLog b/app-i18n/ibus-qt/ChangeLog
index 28e5a55658c8..5a5220e856d2 100644
--- a/app-i18n/ibus-qt/ChangeLog
+++ b/app-i18n/ibus-qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-qt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ChangeLog,v 1.10 2011/01/10 15:56:01 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ChangeLog,v 1.11 2011/05/12 16:17:35 matsuu Exp $
+
+*ibus-qt-1.3.1 (12 May 2011)
+
+ 12 May 2011; MATSUU Takuto <matsuu@gentoo.org> +ibus-qt-1.3.1.ebuild:
+ Version bumped.
10 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> ibus-qt-1.3.0.ebuild:
x86 stable wrt bug #350624
diff --git a/app-i18n/ibus-qt/ibus-qt-1.3.1.ebuild b/app-i18n/ibus-qt/ibus-qt-1.3.1.ebuild
new file mode 100644
index 000000000000..27e4468b0799
--- /dev/null
+++ b/app-i18n/ibus-qt/ibus-qt-1.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ibus-qt-1.3.1.ebuild,v 1.1 2011/05/12 16:17:35 matsuu Exp $
+
+EAPI="2"
+inherit cmake-utils eutils multilib
+
+MY_P="${P}-Source"
+DESCRIPTION="Qt IBus library and Qt input method plugin"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=app-i18n/ibus-1.3.7
+ >=sys-apps/dbus-1.2
+ x11-libs/libX11
+ >=x11-libs/qt-core-4.5:4
+ >=x11-libs/qt-dbus-4.5:4"
+DEPEND="${RDEPEND}
+ >=dev-libs/icu-4
+ dev-util/cmake
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS README TODO"
+
+mycmakeargs="-DLIBDIR=$(get_libdir) -DDOCDIR=/usr/share/doc/${PF} all"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.0.20091217-doc.patch"
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ cd "${CMAKE_BUILD_DIR}"
+ emake docs || die
+ fi
+}
+
+src_install() {
+ if use doc ; then
+ HTML_DOCS="${CMAKE_BUILD_DIR}/docs/html/*"
+ fi
+
+ cmake-utils_src_install
+}