summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-07-05 04:33:11 +0000
committerMamoru Komachi <usata@gentoo.org>2004-07-05 04:33:11 +0000
commit71282c222304c82653e00a032f50bf1a43394202 (patch)
tree852b4e1d6f2f3ba32289b50f1cb1f88336e2c910 /app-i18n/uim-fep/uim-fep-0.3.7.ebuild
parentAdded ~sparc to KEYWORDS. (Manifest recommit) (diff)
downloadgentoo-2-71282c222304c82653e00a032f50bf1a43394202.tar.gz
gentoo-2-71282c222304c82653e00a032f50bf1a43394202.tar.bz2
gentoo-2-71282c222304c82653e00a032f50bf1a43394202.zip
Version bumped.
Diffstat (limited to 'app-i18n/uim-fep/uim-fep-0.3.7.ebuild')
-rw-r--r--app-i18n/uim-fep/uim-fep-0.3.7.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-i18n/uim-fep/uim-fep-0.3.7.ebuild b/app-i18n/uim-fep/uim-fep-0.3.7.ebuild
new file mode 100644
index 000000000000..e4ea66761e3e
--- /dev/null
+++ b/app-i18n/uim-fep/uim-fep-0.3.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim-fep/uim-fep-0.3.7.ebuild,v 1.1 2004/07/05 04:33:11 usata Exp $
+
+IUSE="unicode"
+
+DESCRIPTION="UIM multilingual input method frontend processor for console"
+HOMEPAGE="http://www.ice.nuie.nagoya-u.ac.jp/~h013177b/uim-fep/"
+SRC_URI="http://www.ice.nuie.nagoya-u.ac.jp/~h013177b/uim-fep/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha"
+
+DEPEND=">=app-i18n/uim-0.3.4.2
+ sys-libs/ncurses"
+
+src_compile() {
+
+ local myconf
+ if use unicode ; then
+ myconf="${myconf} --with-enc=utf-8"
+ else
+ myconf="${myconf} --with-enc=euc-jp"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc README COPYING INSTALL
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "uim-fep is configured for skk. If you want to change it, you can set"
+ einfo "UIM_FEP environment variable to one of skk, prime, anthy, canna,"
+ einfo "tcode and tutcode or run uim-fep with -u option with engines listed above."
+ einfo
+}