summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-12 16:08:38 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-12 16:08:38 +0000
commit0a004109d30ee1fe69c8318ec6a1f1fea02eb433 (patch)
tree376b30a29a35ced31968e5eeafc9f2351aec27f8 /app-i18n/opencc
parent[bump] dev-perl/DBD-Pg-2.18.1 (diff)
downloadgentoo-2-0a004109d30ee1fe69c8318ec6a1f1fea02eb433.tar.gz
gentoo-2-0a004109d30ee1fe69c8318ec6a1f1fea02eb433.tar.bz2
gentoo-2-0a004109d30ee1fe69c8318ec6a1f1fea02eb433.zip
Version bumped.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/opencc')
-rw-r--r--app-i18n/opencc/ChangeLog9
-rw-r--r--app-i18n/opencc/opencc-0.2.0.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/app-i18n/opencc/ChangeLog b/app-i18n/opencc/ChangeLog
index 377fda9624ac..a9964c0afb7d 100644
--- a/app-i18n/opencc/ChangeLog
+++ b/app-i18n/opencc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/opencc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/ChangeLog,v 1.1 2010/09/20 02:46:56 matsuu Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/ChangeLog,v 1.2 2011/05/12 16:08:38 matsuu Exp $
+
+*opencc-0.2.0 (12 May 2011)
+
+ 11 May 2011; MATSUU Takuto <matsuu@gentoo.org> +opencc-0.2.0.ebuild:
+ Version bumped. Added static-libs USE flag.
*opencc-0.1.2 (20 Sep 2010)
diff --git a/app-i18n/opencc/opencc-0.2.0.ebuild b/app-i18n/opencc/opencc-0.2.0.ebuild
new file mode 100644
index 000000000000..d7749d207669
--- /dev/null
+++ b/app-i18n/opencc/opencc-0.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/opencc-0.2.0.ebuild,v 1.1 2011/05/12 16:08:38 matsuu Exp $
+
+EAPI=3
+inherit cmake-utils multilib
+
+DESCRIPTION="Libraries for Simplified-Traditional Chinese Conversion"
+HOMEPAGE="http://code.google.com/p/open-chinese-convert/"
+SRC_URI="http://open-chinese-convert.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS="AUTHORS ChangeLog README"
+
+src_prepare() {
+ sed -i \
+ -e "s:\${CMAKE_\(SHARED\|STATIC\)_LIBRARY_PREFIX}:\"$(get_libdir)\":" \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ "$(cmake-utils_use_enable nls GETTEXT)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use static-libs || find "${ED}" -name '*.la' -o -name '*.a' -exec rm {} +
+}