summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-26 23:12:30 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-26 23:12:30 +0000
commit265d1845f317c8c28b26d157e63867f0b2fd9a08 (patch)
tree19267879f645bd92697e4d912d229a4fe4f0c773 /app-i18n/libtomoe-gtk
parentMark x86/amd64 stable (diff)
downloadgentoo-2-265d1845f317c8c28b26d157e63867f0b2fd9a08.tar.gz
gentoo-2-265d1845f317c8c28b26d157e63867f0b2fd9a08.tar.bz2
gentoo-2-265d1845f317c8c28b26d157e63867f0b2fd9a08.zip
Removed .la files, bug #299018. Added python and static-libs USE flags. Clean up.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/libtomoe-gtk')
-rw-r--r--app-i18n/libtomoe-gtk/ChangeLog10
-rw-r--r--app-i18n/libtomoe-gtk/libtomoe-gtk-0.6.0-r2.ebuild69
2 files changed, 77 insertions, 2 deletions
diff --git a/app-i18n/libtomoe-gtk/ChangeLog b/app-i18n/libtomoe-gtk/ChangeLog
index 8b299cd3e547..3507364e9683 100644
--- a/app-i18n/libtomoe-gtk/ChangeLog
+++ b/app-i18n/libtomoe-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/libtomoe-gtk
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtomoe-gtk/ChangeLog,v 1.12 2009/03/09 23:02:40 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtomoe-gtk/ChangeLog,v 1.13 2011/05/26 23:12:30 matsuu Exp $
+
+*libtomoe-gtk-0.6.0-r2 (26 May 2011)
+
+ 26 May 2011; MATSUU Takuto <matsuu@gentoo.org> +libtomoe-gtk-0.6.0-r2.ebuild:
+ Removed .la files, bug #299018. Added python and static-libs USE flags. Clean
+ up.
09 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
files/libtomoe-gtk-0.6.0-gucharmap2.patch:
diff --git a/app-i18n/libtomoe-gtk/libtomoe-gtk-0.6.0-r2.ebuild b/app-i18n/libtomoe-gtk/libtomoe-gtk-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..781268dd9f60
--- /dev/null
+++ b/app-i18n/libtomoe-gtk/libtomoe-gtk-0.6.0-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtomoe-gtk/libtomoe-gtk-0.6.0-r2.ebuild,v 1.1 2011/05/26 23:12:30 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+
+inherit autotools python
+
+MY_P="tomoe-gtk-${PV}"
+DESCRIPTION="Tomoe GTK+ interface widget library"
+HOMEPAGE="http://tomoe.sourceforge.jp/"
+SRC_URI="mirror://sourceforge/tomoe/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +gucharmap python static-libs"
+
+RDEPEND=">=app-i18n/tomoe-0.6.0[python?]
+ python? (
+ dev-python/pygtk:2
+ dev-python/pygobject:2
+ )
+ gucharmap? ( >=gnome-extra/gucharmap-1.4.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use python ; then
+ python_set_active_version 2
+ fi
+}
+
+src_prepare() {
+ # Fix compilation with gucharmap-2.24, bug #243160
+ epatch "${FILESDIR}/${P}-gucharmap2.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ #--with-python b0rked
+ use python || myconf="${myconf} --without-python"
+
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_with gucharmap) \
+ $(use_enable static-libs static) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if use python ; then
+ find "${ED}$(python_get_sitedir)" \( -name "*.la" -o -name "*.a" \) -type f -delete || die
+ fi
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}