summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-05-27 17:23:55 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-05-27 17:23:55 +0000
commitbd101e1e609afd8e3007423cfe00eb1f811e7980 (patch)
treec992dcba431e40d29f987d6fd5c31585a2c0090f /app-forensics
parentVersion bump. (diff)
downloadgentoo-2-bd101e1e609afd8e3007423cfe00eb1f811e7980.tar.gz
gentoo-2-bd101e1e609afd8e3007423cfe00eb1f811e7980.tar.bz2
gentoo-2-bd101e1e609afd8e3007423cfe00eb1f811e7980.zip
Version bumped, bug #319561.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/aide/ChangeLog8
-rw-r--r--app-forensics/aide/aide-0.14.ebuild132
-rw-r--r--app-forensics/aide/files/aide-0.14-as-needed.patch20
-rw-r--r--app-forensics/aide/files/aide-0.14-gentoo.patch26
4 files changed, 185 insertions, 1 deletions
diff --git a/app-forensics/aide/ChangeLog b/app-forensics/aide/ChangeLog
index c2108a128cd1..1c0010ce5a62 100644
--- a/app-forensics/aide/ChangeLog
+++ b/app-forensics/aide/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/aide
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/ChangeLog,v 1.46 2010/05/26 11:36:28 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/ChangeLog,v 1.47 2010/05/27 17:23:55 matsuu Exp $
+
+*aide-0.14 (27 May 2010)
+
+ 27 May 2010; MATSUU Takuto <matsuu@gentoo.org> +aide-0.14.ebuild,
+ +files/aide-0.14-as-needed.patch, +files/aide-0.14-gentoo.patch:
+ Version bumped, bug #319561.
*aide-0.13.1-r5 (26 May 2010)
diff --git a/app-forensics/aide/aide-0.14.ebuild b/app-forensics/aide/aide-0.14.ebuild
new file mode 100644
index 000000000000..fb3cfbfbda9d
--- /dev/null
+++ b/app-forensics/aide/aide-0.14.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.14.ebuild,v 1.1 2010/05/27 17:23:55 matsuu Exp $
+
+EAPI="3"
+
+inherit autotools confutils eutils
+
+DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a replacement for Tripwire"
+HOMEPAGE="http://aide.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aide/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="acl curl mhash nls postgres selinux static xattr zlib"
+#IUSE="acl audit curl mhash nls postgres prelink selinux static xattr zlib"
+
+# libsandbox: Can't dlopen libc: (null)
+#RESTRICT="test"
+
+DEPEND="acl? ( sys-apps/acl )
+ curl? ( net-misc/curl )
+ mhash? ( >=app-crypt/mhash-0.9.2 )
+ !mhash? ( dev-libs/libgcrypt )
+ nls? ( virtual/libintl )
+ postgres? ( virtual/postgresql-base )
+ selinux? ( sys-libs/libselinux )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )"
+# audit? ( sys-process/audit )
+# prelink? ( sys-devel/prelink )
+
+RDEPEND="!static? ( ${DEPEND} )"
+
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/bison
+ sys-devel/flex"
+
+pkg_config() {
+ confutils_use_conflict mhash postgres
+ confutils_use_conflict curl static
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ # fix libgcrypt issue, bug #266175
+ epatch "${FILESDIR}/${PN}-0.13.1-libgrypt_init.patch"
+
+ # fix as-need issue, bug #271326
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ # fix zlib issue, bug #316665
+ epatch "${FILESDIR}/${PN}-0.13.1-zlib.patch"
+
+ if ! use selinux ; then
+ sed -i -e 's/\+selinux//' doc/aide.conf.in || die
+ fi
+
+ if ! use xattr ; then
+ sed -i -e 's/\+xattrs//' doc/aide.conf.in || die
+ fi
+
+ if ! use acl ; then
+ sed -i -e 's/\+acl//' doc/aide.conf.in || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="
+ $(use_with acl posix-acl)
+ $(use_with curl)
+ $(use_with !mhash gcrypt)
+ $(use_with mhash mhash)
+ $(use_with nls locale)
+ $(use_with postgres psql)
+ $(use_with selinux)
+ $(use_enable static)
+ $(use_with xattr)
+ $(use_with zlib)
+ --sysconfdir=${EPREFIX}/etc/aide"
+# $(use_with audit)
+# $(use_with prelink)
+
+ econf ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man || die "emake install failed"
+
+ keepdir /var/lib/aide || die
+ fowners root:0 /var/lib/aide || die
+ fperms 0755 /var/lib/aide || die
+
+ keepdir /var/log/aide || die
+
+ insinto /etc/aide
+ doins "${FILESDIR}"/aide.conf || die
+
+ dosbin "${FILESDIR}"/aideinit || die
+
+ dodoc ChangeLog AUTHORS NEWS README "${FILESDIR}"/aide.cron || die
+ dohtml doc/manual.html || die
+}
+
+pkg_postinst() {
+ elog
+ elog "A sample configuration file has been installed as"
+ elog "/etc/aide/aide.conf. Please edit to meet your needs."
+ elog "Read the aide.conf(5) manual page for more information."
+ elog "A helper script, aideinit, has been installed and can"
+ elog "be used to make AIDE management easier. Please run"
+ elog "aideinit --help for more information"
+ elog
+
+ if use postgres; then
+ elog "Due to a bad assumption by aide, you must issue the following"
+ elog "command after the database initialization (aide --init ...):"
+ elog
+ elog 'psql -c "update pg_index set indisunique=false from pg_class \\ '
+ elog " where pg_class.relname='TABLE_pkey' and \ "
+ elog ' pg_class.oid=pg_index.indexrelid" -h HOSTNAME -p PORT DBASE USER'
+ elog
+ elog "where TABLE, HOSTNAME, PORT, DBASE, and USER are the same as"
+ elog "your aide.conf."
+ elog
+ fi
+}
diff --git a/app-forensics/aide/files/aide-0.14-as-needed.patch b/app-forensics/aide/files/aide-0.14-as-needed.patch
new file mode 100644
index 000000000000..7a90b4e25079
--- /dev/null
+++ b/app-forensics/aide/files/aide-0.14-as-needed.patch
@@ -0,0 +1,20 @@
+--- aide-0.14.orig/configure.in 2010-02-26 17:25:29.000000000 +0900
++++ aide-0.14/configure.in 2010-05-27 00:11:34.000000000 +0900
+@@ -42,7 +42,7 @@
+ AC_ARG_WITH(extra-libs,
+ AC_HELP_STRING([--with-extra-libs],
+ [Specify additional paths with -L to find libraries]),
+- [LDFLAGS="$LDFLAGS $withval"]
++ [LIBS="$LIBS $withval"]
+ )
+ AC_ARG_WITH(extra-link-libs,
+ AC_HELP_STRING([--with-extra-link-libs],
+@@ -671,7 +671,7 @@
+ AC_CHECK_HEADERS(curl/curl.h,,
+ [AC_MSG_ERROR([You don't have curl properly installed. Install it or try --without-curl.])])
+ CFLAGS="$CFLAGS $CURL_CFLAGS"
+- LDFLAGS="$LDFLAGS $CURL_LIBS"
++ LIBS="$LIBS $CURL_LIBS"
+ AC_CHECK_LIB(curl,curl_easy_init,havecurl=yes,
+ [AC_MSG_ERROR([You don't have curl properly installed. Install it or try --without-curl.])]
+ )
diff --git a/app-forensics/aide/files/aide-0.14-gentoo.patch b/app-forensics/aide/files/aide-0.14-gentoo.patch
new file mode 100644
index 000000000000..f2c8156ed161
--- /dev/null
+++ b/app-forensics/aide/files/aide-0.14-gentoo.patch
@@ -0,0 +1,26 @@
+diff -Naur aide-0.14.orig//src/Makefile.am aide-0.14//src/Makefile.am
+--- aide-0.14.orig//src/Makefile.am 2010-02-20 04:23:08.000000000 +0900
++++ aide-0.14//src/Makefile.am 2010-05-26 23:56:47.000000000 +0900
+@@ -26,7 +26,7 @@
+ LEX_OUTPUT_ROOT = lex.yy
+
+ LDADD = -lm @CRYPTLIB@ @ACLLIB@ @SELINUXLIB@ @AUDITLIB@ @ATTRLIB@ @ELFLIB@
+-AM_CFLAGS = @AIDE_DEFS@ -W -Wall -g
++AM_CFLAGS = -DLOCALEDIR=\"$(localedir)\" @AIDE_DEFS@ -W -Wall -g
+
+ CLEANFILES = conf_yacc.h conf_yacc.c conf_lex.c db_lex.c *~
+
+diff -Naur aide-0.14.orig//src/db.c aide-0.14//src/db.c
+--- aide-0.14.orig//src/db.c 2010-02-18 05:06:57.000000000 +0900
++++ aide-0.14//src/db.c 2010-05-27 00:16:07.000000000 +0900
+@@ -26,6 +26,10 @@
+ #include "db_file.h"
+ #include "db_disk.h"
+
++#ifdef WITH_CURL
++#include "fopen.h"
++#endif
++
+ #ifdef WITH_PSQL
+ #include "db_sql.h"
+ #endif