summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-05 17:26:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-05 17:26:49 +0000
commit1a40ae327c81d1d6c0b4dfe93183141f7215211f (patch)
treeabded3c7d6f8829c2d2f01f84bfe25a949affc1c /app-forensics/rkhunter
parentFIX for new gtk-sharp-module eclass (diff)
downloadgentoo-2-1a40ae327c81d1d6c0b4dfe93183141f7215211f.tar.gz
gentoo-2-1a40ae327c81d1d6c0b4dfe93183141f7215211f.tar.bz2
gentoo-2-1a40ae327c81d1d6c0b4dfe93183141f7215211f.zip
Bump to 1.3.4. Might need some more love.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-forensics/rkhunter')
-rw-r--r--app-forensics/rkhunter/ChangeLog9
-rw-r--r--app-forensics/rkhunter/rkhunter-1.3.4.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/app-forensics/rkhunter/ChangeLog b/app-forensics/rkhunter/ChangeLog
index 2b69a43ae527..730c5bacfe77 100644
--- a/app-forensics/rkhunter/ChangeLog
+++ b/app-forensics/rkhunter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/rkhunter
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.63 2007/07/28 17:07:05 kumba Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.64 2009/01/05 17:26:49 patrick Exp $
+
+*rkhunter-1.3.4 (05 Jan 2009)
+
+ 05 Jan 2009; Patrick Lauer <patrick@gentoo.org> +rkhunter-1.3.4.ebuild:
+ Bump to 1.3.4. Might need some more love.
28 Jul 2007; Joshua Kinard <kumba@gentoo.org> ChangeLog:
Stable on mips, per #161943.
diff --git a/app-forensics/rkhunter/rkhunter-1.3.4.ebuild b/app-forensics/rkhunter/rkhunter-1.3.4.ebuild
new file mode 100644
index 000000000000..b5ffba694cab
--- /dev/null
+++ b/app-forensics/rkhunter/rkhunter-1.3.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/rkhunter-1.3.4.ebuild,v 1.1 2009/01/05 17:26:49 patrick Exp $
+
+inherit eutils bash-completion
+
+DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers."
+HOMEPAGE="http://rkhunter.sf.net/"
+SRC_URI="mirror://sourceforge/rkhunter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/mta
+ app-shells/bash
+ dev-lang/perl
+ sys-process/lsof"
+
+S="${WORKDIR}/${P}/files"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/${PN}-1.2.1-create-tmpdir.diff
+ #epatch "${FILESDIR}"/${PN}-1.2.9-ppc64.patch
+}
+
+src_install() {
+ insinto /usr/lib/rkhunter/db
+ doins *.dat || die "failed to install dat files"
+
+ exeinto /usr/lib/rkhunter/scripts
+ doexe *.pl check_update.sh || die "failed to install scripts"
+
+ dobin rkhunter || die "failed to install rkhunter script"
+
+ insinto /etc
+ doins rkhunter.conf || die "failed to install rkhunter.conf"
+ dosed 's:^#\(DBDIR=.*\)local\(.*\)$:\1lib\2\nINSTALLDIR=/usr:' \
+ /etc/rkhunter.conf || die "sed rkhunter.conf failed"
+
+ #doman development/rkhunter.8 || die "doman failed"
+ dodoc CHANGELOG LICENSE README WISHLIST || die "dodoc failed"
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/rkhunter.cron rkhunter || \
+ die "failed to install cron script"
+ dobashcompletion ${FILESDIR}/${PN}.bash-completion
+}
+
+pkg_postinst() {
+ echo
+ elog "A cron script has been installed to /etc/cron.daily/rkhunter."
+ elog "To enable it, edit /etc/cron.daily/rkhunter and follow the"
+ elog "directions."
+ echo
+ bash-completion_pkg_postinst
+}
+
+pkg_prerm() {
+ rm -rf /usr/lib/rkhunter/tmp
+}