summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2013-04-02 19:19:41 +0000
committerRaúl Porcel <armin76@gentoo.org>2013-04-02 19:19:41 +0000
commita3bcc7f17172ba1a0d8cbe0992f3b70c5b5f969a (patch)
tree8cd84680a53b5507c78f829572d000bb8b795e92 /app-emulation
parentAdd net-libs/libkolabxml to the previous mask (diff)
downloadgentoo-2-a3bcc7f17172ba1a0d8cbe0992f3b70c5b5f969a.tar.gz
gentoo-2-a3bcc7f17172ba1a0d8cbe0992f3b70c5b5f969a.tar.bz2
gentoo-2-a3bcc7f17172ba1a0d8cbe0992f3b70c5b5f969a.zip
Version bump, add more USE-flags
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0xF6AD3240)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/aranym/ChangeLog8
-rw-r--r--app-emulation/aranym/aranym-0.9.14.ebuild58
-rw-r--r--app-emulation/aranym/metadata.xml5
3 files changed, 70 insertions, 1 deletions
diff --git a/app-emulation/aranym/ChangeLog b/app-emulation/aranym/ChangeLog
index 3903b864f063..5b236a5ffec7 100644
--- a/app-emulation/aranym/ChangeLog
+++ b/app-emulation/aranym/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/aranym
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.20 2013/01/30 05:39:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.21 2013/04/02 19:19:41 armin76 Exp $
+
+*aranym-0.9.14 (02 Apr 2013)
+
+ 02 Apr 2013; Raúl Porcel <armin76@gentoo.org> +aranym-0.9.14.ebuild,
+ metadata.xml:
+ Version bump, add more USE-flags
*aranym-0.9.11 (30 Jan 2013)
diff --git a/app-emulation/aranym/aranym-0.9.14.ebuild b/app-emulation/aranym/aranym-0.9.14.ebuild
new file mode 100644
index 000000000000..0bace57aa216
--- /dev/null
+++ b/app-emulation/aranym/aranym-0.9.14.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.14.ebuild,v 1.1 2013/04/02 19:19:41 armin76 Exp $
+
+EAPI=5
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Atari Running on Any Machine, a VM running Atari ST/TT/Falcon OS and TOS/GEM applications"
+HOMEPAGE="http://aranym.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aranym/${P/-/_}.orig.tar.gz
+ mirror://sourceforge/aranym/afros812.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+fullmmu +lilo opengl usbhost X"
+
+RDEPEND="games-emulation/emutos
+ opengl? ( virtual/opengl )
+ X? ( media-libs/libsdl[X] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_configure() {
+ filter-flags -mpowerpc-gfxopt
+
+ local myconf=""
+ if [[ ${ARCH} == x86 ]]; then
+ myconf="${myconf} --enable-jit-compiler"
+ fi
+
+ if ! use X; then
+ myconf="${myconf} --disable-nfjpeg --disable-nfclipbrd"
+ fi
+
+ econf \
+ $(use_enable X gui) \
+ $(use_enable opengl) \
+ $(use_enable fullmmu) \
+ $(use_enable lilo) \
+ $(use_enable usbhost) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_PROGRAM="install" install || die "installation failed"
+
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/afros || die
+
+ dodoc "${D}"/usr/share/doc/${PN}/* || die
+ rm -r "${D}"/usr/share/doc/${PN} || die
+}
+
+pkg_postinst() {
+ elog "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
+}
diff --git a/app-emulation/aranym/metadata.xml b/app-emulation/aranym/metadata.xml
index 4c10298a0781..f2bea56f35c4 100644
--- a/app-emulation/aranym/metadata.xml
+++ b/app-emulation/aranym/metadata.xml
@@ -13,4 +13,9 @@
That's a break-through for all Atari users - now you can turn almost
any hardware into your familiar TOS/GEM system.
</longdescription>
+ <use>
+ <flag name="fullmmu">Enable full 68040 MMU emulation</flag>
+ <flag name="lilo">Enable Linux-m68k loader</flag>
+ <flag name="usbhost">Enable NatFeat USB</flag>
+ </use>
</pkgmetadata>