summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-30 04:25:33 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-30 04:25:33 +0000
commit9fc1b6fef5a21682cbca945f22e146a4e6ae20a9 (patch)
tree6a42a2b2b35915f1b143d2199c8703da68cbef3f /app-emulation
parentMark s390 stable #298571. (diff)
downloadgentoo-2-9fc1b6fef5a21682cbca945f22e146a4e6ae20a9.tar.gz
gentoo-2-9fc1b6fef5a21682cbca945f22e146a4e6ae20a9.tar.bz2
gentoo-2-9fc1b6fef5a21682cbca945f22e146a4e6ae20a9.zip
Version bump #308823 by Jay Maynard.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/hercules/ChangeLog9
-rw-r--r--app-emulation/hercules/hercules-3.07.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/app-emulation/hercules/ChangeLog b/app-emulation/hercules/ChangeLog
index f5794467fe96..d6eb23ebdac1 100644
--- a/app-emulation/hercules/ChangeLog
+++ b/app-emulation/hercules/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/hercules
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.27 2009/08/10 12:00:17 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.28 2010/08/30 04:25:33 vapier Exp $
+
+*hercules-3.07 (30 Aug 2010)
+
+ 30 Aug 2010; Mike Frysinger <vapier@gentoo.org> +hercules-3.07.ebuild:
+ Version bump #308823 by Jay Maynard.
10 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> hercules-3.06.ebuild,
+files/hercules-3.06-gcc44.patch:
diff --git a/app-emulation/hercules/hercules-3.07.ebuild b/app-emulation/hercules/hercules-3.07.ebuild
new file mode 100644
index 000000000000..19ea8773c67c
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.07.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.07.ebuild,v 1.1 2010/08/30 04:25:33 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+HOMEPAGE="http://www.hercules-390.org/"
+SRC_URI="http://www.hercules-390.org/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="custom-cflags"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:@modexecdir@:$(libdir)/$(PACKAGE):' \
+ -e '/^AM_CPPFLAGS/s:=:= -DMODULESDIR=\\"$(modexecdir)\\" :' \
+ -e 's:ltdl.lo::' \
+ -e '/^libherc_la_LIBADD/s:=:= -lltdl :' \
+ $(find -name Makefile.in)
+ sed -i '/MODULESDIR/d' config.h.in
+}
+
+src_compile() {
+ use custom-cflags || strip-flags
+ econf \
+ --enable-cckd-bzip2 \
+ --enable-het-bzip2 \
+ --enable-setuid-hercifc \
+ --enable-custom="Gentoo ${PF}.ebuild" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.* RELEASE.NOTES CHANGES
+ dohtml -r html
+}