summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-06-20 14:42:09 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-06-20 14:42:09 +0000
commit6db571725794a2637deb381b52d79035bcb5e7fc (patch)
tree193e903b3883df5b46e53a734666c774657c19bb /app-emulation
parentRe-fix bug #228005 (diff)
downloadgentoo-2-6db571725794a2637deb381b52d79035bcb5e7fc.tar.gz
gentoo-2-6db571725794a2637deb381b52d79035bcb5e7fc.tar.bz2
gentoo-2-6db571725794a2637deb381b52d79035bcb5e7fc.zip
autoconf fix thanks to master Diego - bug #226705. removed old version 1.1.10-r1
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libdsk/ChangeLog8
-rw-r--r--app-emulation/libdsk/files/libdsk-1.2.1-java-make-fix.patch15
-rw-r--r--app-emulation/libdsk/libdsk-1.1.10-r1.ebuild54
-rw-r--r--app-emulation/libdsk/libdsk-1.2.1.ebuild7
4 files changed, 11 insertions, 73 deletions
diff --git a/app-emulation/libdsk/ChangeLog b/app-emulation/libdsk/ChangeLog
index 52d0ef8b7218..91fb54ac16d5 100644
--- a/app-emulation/libdsk/ChangeLog
+++ b/app-emulation/libdsk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/libdsk
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libdsk/ChangeLog,v 1.20 2008/04/02 07:41:42 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libdsk/ChangeLog,v 1.21 2008/06/20 14:42:08 dragonheart Exp $
+
+ 20 Jun 2008; Daniel Black <dragonheart@gentoo.org>
+ files/libdsk-1.2.1-java-make-fix.patch, -libdsk-1.1.10-r1.ebuild,
+ libdsk-1.2.1.ebuild:
+ autoconf fix thanks to master Diego - bug #226705. removed old version
+ 1.1.10-r1
*libdsk-1.2.1 (02 Apr 2008)
diff --git a/app-emulation/libdsk/files/libdsk-1.2.1-java-make-fix.patch b/app-emulation/libdsk/files/libdsk-1.2.1-java-make-fix.patch
index 07aa58c9a93e..21e7ff999224 100644
--- a/app-emulation/libdsk/files/libdsk-1.2.1-java-make-fix.patch
+++ b/app-emulation/libdsk/files/libdsk-1.2.1-java-make-fix.patch
@@ -21,21 +21,6 @@
$(HEADERPRE)_%.h: $(CLASSDPRE)/%.class
---- libdsk-1.2.1.orig/lib/Makefile.in 2008-01-24 06:29:49.000000000 +1100
-+++ libdsk-1.2.1/lib/Makefile.in 2008-04-02 14:04:42.000000000 +1100
-@@ -492,10 +492,10 @@
- $(JAVADOC) -d $(top_srcdir)/doc/jni $(CLASSCPRE)
-
- $(CLASSDPRE)/%.class: $(srcdir)/$(CLASSDPRE)/%.java
-- here=`pwd` && cd $(srcdir) && $(JAVAC) -d $$here $<
-+ here=`pwd` && cd $(srcdir) && $(JAVAC) $(JAVACFLAGS) -d $$here $<
-
- %.class: $(srcdir)/%.java
-- here=`pwd` && cd $(srcdir) && $(JAVAC) -d $$here $<
-+ here=`pwd` && cd $(srcdir) && $(JAVAC) $(JAVACFLAGS) -d $$here $<
-
- $(HEADERPRE)_%.h: $(CLASSDPRE)/%.class
- $(JAVAH) -jni $(CLASSCPRE).`basename $< .class`
--- libdsk-1.2.1.orig/tools/Makefile.am 2006-04-12 08:05:09.000000000 +1000
+++ libdsk-1.2.1/tools/Makefile.am 2008-04-02 14:06:06.000000000 +1100
@@ -32,5 +32,5 @@
diff --git a/app-emulation/libdsk/libdsk-1.1.10-r1.ebuild b/app-emulation/libdsk/libdsk-1.1.10-r1.ebuild
deleted file mode 100644
index a00a5fc53809..000000000000
--- a/app-emulation/libdsk/libdsk-1.1.10-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libdsk/libdsk-1.1.10-r1.ebuild,v 1.2 2008/04/02 07:41:42 dragonheart Exp $
-
-inherit java-pkg-opt-2 flag-o-matic
-
-DESCRIPTION="Disk emulation library"
-HOMEPAGE="http://www.seasip.demon.co.uk/Unix/LibDsk/"
-SRC_URI="http://www.seasip.demon.co.uk/Unix/LibDsk/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="java"
-KEYWORDS="~x86 ~ppc ~amd64"
-
-CDEPEND="sys-libs/zlib
- app-arch/bzip2"
-DEPEND="${CDEPEND}
- java? ( >=virtual/jdk-1.5 )"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jdk-1.4 )"
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}/java-make-fix.patch"
-}
-
-src_compile() {
- use java && sed -i -e "s!_JINC=\"\$_JTOPDIR/i!_JINC=\"${JAVA_HOME}/i!" configure
-
- local java_options=""
- if use java; then
- java_options="--with-javac-flags=$(java-pkg_javac-args)"
- fi
-
- econf \
- --with-zlib \
- --with-bzlib \
- --enable-floppy \
- $(use_with java jni) \
- --with-java-prefix=${JAVA_HOME} \
- "${java_options}" \
- || die
- emake || die "libdsk make failed!"
-}
-
-src_install() {
- emake install transform="s,^,," DESTDIR="${D}" || die
- if use java; then
- java-pkg_dojar "lib/${PN}.jar"
- fi
-
- dodoc ChangeLog README TODO doc/libdsk.*
-}
diff --git a/app-emulation/libdsk/libdsk-1.2.1.ebuild b/app-emulation/libdsk/libdsk-1.2.1.ebuild
index 215f440d1fae..9e739461e447 100644
--- a/app-emulation/libdsk/libdsk-1.2.1.ebuild
+++ b/app-emulation/libdsk/libdsk-1.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libdsk/libdsk-1.2.1.ebuild,v 1.1 2008/04/02 07:41:42 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libdsk/libdsk-1.2.1.ebuild,v 1.2 2008/06/20 14:42:08 dragonheart Exp $
-inherit java-pkg-opt-2 flag-o-matic
+inherit java-pkg-opt-2 flag-o-matic autotools
DESCRIPTION="Disk emulation library"
HOMEPAGE="http://www.seasip.demon.co.uk/Unix/LibDsk/"
@@ -11,7 +11,7 @@ SRC_URI="http://www.seasip.demon.co.uk/Unix/LibDsk/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
IUSE="java"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
CDEPEND="sys-libs/zlib
app-arch/bzip2"
@@ -23,6 +23,7 @@ RDEPEND="${CDEPEND}
src_unpack() {
unpack ${A}
epatch "${FILESDIR}"/${P}-java-make-fix.patch
+ eautoconf
}
src_compile() {