summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-27 23:04:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-27 23:04:50 +0000
commit524693934163c0286d2885619a1513a6b96eecdd (patch)
treebc921253af57d081ba5a28fe00955cd1d560e889 /app-emulation
parentver bump (Manifest recommit) (diff)
downloadgentoo-2-524693934163c0286d2885619a1513a6b96eecdd.tar.gz
gentoo-2-524693934163c0286d2885619a1513a6b96eecdd.tar.bz2
gentoo-2-524693934163c0286d2885619a1513a6b96eecdd.zip
touch the libc
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/aranym/aranym-0.8.6_beta.ebuild17
-rw-r--r--app-emulation/basiliskII/basiliskII-0.9.0.ebuild15
-rw-r--r--app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild16
-rw-r--r--app-emulation/bochs/bochs-1.4.1.ebuild36
-rw-r--r--app-emulation/bochs/bochs-1.4.ebuild34
-rw-r--r--app-emulation/bochs/bochs-2.0.2.ebuild10
-rw-r--r--app-emulation/bochs/bochs-2.0.ebuild32
-rw-r--r--app-emulation/bochs/bochs-2.1.1.ebuild8
-rw-r--r--app-emulation/bochs/bochs-2.1.ebuild8
-rw-r--r--app-emulation/cedega/cedega-4.0.ebuild4
-rw-r--r--app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.0.ebuild23
-rw-r--r--app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.1-r2.ebuild11
-rw-r--r--app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-1.0.ebuild13
-rw-r--r--app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-1.1.ebuild11
-rw-r--r--app-emulation/frodo/frodo-4.1.ebuild6
-rw-r--r--app-emulation/glukalka/glukalka-0.90.1.ebuild16
-rw-r--r--app-emulation/hercules/hercules-2.17.1-r1.ebuild6
-rw-r--r--app-emulation/hercules/hercules-3.00.ebuild6
-rw-r--r--app-emulation/hercules/hercules-3.01.ebuild8
-rw-r--r--app-emulation/i8086emu/i8086emu-0.9.1.ebuild17
20 files changed, 134 insertions, 163 deletions
diff --git a/app-emulation/aranym/aranym-0.8.6_beta.ebuild b/app-emulation/aranym/aranym-0.8.6_beta.ebuild
index cf9dc756708e..b47a74136617 100644
--- a/app-emulation/aranym/aranym-0.8.6_beta.ebuild
+++ b/app-emulation/aranym/aranym-0.8.6_beta.ebuild
@@ -1,25 +1,25 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.8.6_beta.ebuild,v 1.4 2004/06/24 22:29:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.8.6_beta.ebuild,v 1.5 2004/06/27 23:00:49 vapier Exp $
inherit flag-o-matic
AFROS="afros-20040206.zip"
S="${WORKDIR}/${PN}-0.8.6beta"
-DESCRIPTION="ARAnyM, Atari Running on Any Machine, is a virtual machine software for running Atari ST/TT/Falcon operating systems and TOS/GEM applications."
+DESCRIPTION="Atari Running on Any Machine, is a virtual machine software for running Atari ST/TT/Falcon operating systems and TOS/GEM applications"
+HOMEPAGE="http://aranym.sourceforge.net/"
SRC_URI="mirror://sourceforge/aranym/${PN}-0.8.6beta.tar.gz
mirror://sourceforge/aranym/${AFROS}"
-HOMEPAGE="http://aranym.sourceforge.net/"
-LICENSE="GPL-2"
-KEYWORDS="~ppc ~x86"
+LICENSE="GPL-2"
SLOT="0"
-
+KEYWORDS="~ppc ~x86"
IUSE="sdl"
+
DEPEND="media-libs/libsdl
games-emulation/emutos
app-arch/unzip
- opengl? virtual/opengl"
+ opengl? ( virtual/opengl )"
src_unpack() {
unpack "${PN}-0.8.6beta.tar.gz"
@@ -40,7 +40,7 @@ src_compile() {
emake || die "failed during compilation"
}
-src_install () {
+src_install() {
cd ${S}/src/Unix
emake DESTDIR=${D} install || die "installation failed"
@@ -54,4 +54,3 @@ src_install () {
pkg_postinst() {
einfo "To run ARAnyM with AFROS type: aranym -c /usr/share/aranym/afros/config"
}
-
diff --git a/app-emulation/basiliskII/basiliskII-0.9.0.ebuild b/app-emulation/basiliskII/basiliskII-0.9.0.ebuild
index 2ab07ea9920c..7a42a687ad30 100644
--- a/app-emulation/basiliskII/basiliskII-0.9.0.ebuild
+++ b/app-emulation/basiliskII/basiliskII-0.9.0.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/basiliskII-0.9.0.ebuild,v 1.14 2004/06/24 22:29:52 agriffis Exp $
-
-IUSE="X gtk xv esd dga"
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/basiliskII-0.9.0.ebuild,v 1.15 2004/06/27 23:01:16 vapier Exp $
inherit flag-o-matic
@@ -12,9 +10,12 @@ inherit flag-o-matic
DESCRIPTION="BasiliskII-0.9.0 Macintosh Emulator (Stable Release)"
HOMEPAGE="http://www.uni-mainz.de/~bauec002/B2Main.html"
+SRC_URI="http://iphcip1.physik.uni-mainz.de/~cbauer/BasiliskII_src_31052001.tar.gz"
+
LICENSE="GPL-2 | LGPL-2.1"
-KEYWORDS="x86 -ppc"
SLOT="0"
+KEYWORDS="x86 -ppc"
+IUSE="X gtk xv esd dga"
### We'll set $S Manually, it's version dependant, and nested strangely.
S=${WORKDIR}/BasiliskII-0.9/src/Unix
@@ -26,11 +27,7 @@ S=${WORKDIR}/BasiliskII-0.9/src/Unix
DEPEND="gtk? ( x11-libs/gtk+ )
esd? ( media-sound/esound )"
-
-SRC_URI="http://iphcip1.physik.uni-mainz.de/~cbauer/BasiliskII_src_31052001.tar.gz"
-
src_compile() {
-
#fpu_x86 doesnt compile properly if -O3 or greater :(
replace-flags -O[3-9] -O2
@@ -60,7 +57,7 @@ src_compile() {
emake || die "BasiliskII Make Failed"
}
-src_install () {
+src_install() {
make \
prefix=${D}/usr \
mandir=${D}/usr/share/man \
diff --git a/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild b/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild
index 8297f69c444a..ae8b7556a81a 100644
--- a/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild
+++ b/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild,v 1.4 2004/06/24 22:29:52 agriffis Exp $
-
-IUSE="X gtk xv esd dga"
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild,v 1.5 2004/06/27 23:01:16 vapier Exp $
inherit flag-o-matic
@@ -12,9 +10,12 @@ inherit flag-o-matic
DESCRIPTION="Basilisk II Macintosh Emulator"
HOMEPAGE="http://www.uni-mainz.de/~bauec002/B2Main.html"
+SRC_URI="http://iphcip1.physik.uni-mainz.de/~cbauer/BasiliskII_src_15012002.tar.gz"
+
LICENSE="GPL-2 | LGPL-2.1"
-KEYWORDS="x86 ~ppc"
SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE="X gtk xv esd dga"
### We'll set $S Manually, it's version dependant, and nested strangely.
S=${WORKDIR}/BasiliskII-1.0/src/Unix
@@ -26,11 +27,7 @@ S=${WORKDIR}/BasiliskII-1.0/src/Unix
DEPEND="gtk? ( x11-libs/gtk+ )
esd? ( media-sound/esound )"
-
-SRC_URI="http://iphcip1.physik.uni-mainz.de/~cbauer/BasiliskII_src_15012002.tar.gz"
-
src_compile() {
-
#fpu_x86 doesnt compile properly if -O3 or greater :(
replace-flags -O[3-9] -O2
@@ -62,7 +59,7 @@ src_compile() {
emake || die "BasiliskII Make Failed"
}
-src_install () {
+src_install() {
make \
prefix=${D}/usr \
mandir=${D}/usr/share/man \
@@ -78,5 +75,4 @@ src_install () {
### provides (effectivly) an ethernet bridge between basliskII and the kernel
# make modules
-
}
diff --git a/app-emulation/bochs/bochs-1.4.1.ebuild b/app-emulation/bochs/bochs-1.4.1.ebuild
index f8ddd8d673bf..58b416422071 100644
--- a/app-emulation/bochs/bochs-1.4.1.ebuild
+++ b/app-emulation/bochs/bochs-1.4.1.ebuild
@@ -1,37 +1,34 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.1.ebuild,v 1.11 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.1.ebuild,v 1.12 2004/06/27 23:01:44 vapier Exp $
-DESCRIPTION="Bochs is a pc emulator.
-This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
-CDROM drive. It also comes with a disk image using dlxlinux."
+DESCRIPTION="a pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
-HOMEPAGE="http://bochs.sourceforge.net"
+
LICENSE="LGPL-2.1"
SLOT="0"
+KEYWORDS="x86 ppc ~alpha"
IUSE=""
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11"
-KEYWORDS="x86 ppc ~alpha"
-
src_unpack() {
unpack ${P}.tar.gz
- cd $S
- cp Makefile.in Makefile.in.orig
- sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
- -e 's: $(prefix): $(DESTDIR)$(prefix):g' \
- -e 's: $(bindir): $(DESTDIR)$(bindir):g' \
- -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
-
+ cd ${S}
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e 's: $(prefix): $(DESTDIR)$(prefix):g' \
+ -e 's: $(bindir): $(DESTDIR)$(bindir):g' \
+ -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' \
+ Makefile.in
}
src_compile() {
-
[ "$ARCH" == "x86" ] && myconf="--enable-idle-hack"
./configure --enable-fpu --enable-cdrom --enable-control-panel \
@@ -44,8 +41,7 @@ src_compile() {
emake || die
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
- dodoc CHANGES COPYING CVS README TESTFORM.txt
+ dodoc CHANGES CVS README TESTFORM.txt
}
diff --git a/app-emulation/bochs/bochs-1.4.ebuild b/app-emulation/bochs/bochs-1.4.ebuild
index de7f58424410..c88fbbef7c1c 100644
--- a/app-emulation/bochs/bochs-1.4.ebuild
+++ b/app-emulation/bochs/bochs-1.4.ebuild
@@ -1,36 +1,32 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.ebuild,v 1.17 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.ebuild,v 1.18 2004/06/27 23:01:44 vapier Exp $
MY_P=${P/_/.}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="Bochs is a pc emulator.
-This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
-CDROM drive.
-It also comes with a disk image using dlxlinux."
+DESCRIPTION="a pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net"
SRC_URI="mirror://sourceforge/bochs/${MY_P}.tar.gz
http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
-HOMEPAGE="http://bochs.sourceforge.net"
+
LICENSE="LGPL-2.1"
SLOT="0"
+KEYWORDS="x86 ppc"
IUSE=""
-#build-time dependencies
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11"
-KEYWORDS="x86 ppc"
-
src_unpack() {
unpack ${MY_P}.tar.gz
- cd $S
- cp Makefile.in Makefile.in.orig
- sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
- -e 's: $(prefix): $(DESTDIR)$(prefix):g' \
- -e 's: $(bindir): $(DESTDIR)$(bindir):g' \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
-
+ cd ${S}
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e 's: $(prefix): $(DESTDIR)$(prefix):g' \
+ -e 's: $(bindir): $(DESTDIR)$(bindir):g' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' \
+ Makefile.in
}
src_compile() {
@@ -44,7 +40,7 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- dodoc CHANGES COPYING CVS README TESTFORM.txt
+ dodoc CHANGES CVS README TESTFORM.txt
}
diff --git a/app-emulation/bochs/bochs-2.0.2.ebuild b/app-emulation/bochs/bochs-2.0.2.ebuild
index bb44aab27b11..7535999a176b 100644
--- a/app-emulation/bochs/bochs-2.0.2.ebuild
+++ b/app-emulation/bochs/bochs-2.0.2.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.14 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.15 2004/06/27 23:01:44 vapier Exp $
inherit eutils
DESCRIPTION="a LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
- http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
+ http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 ~ppc alpha sparc"
IUSE="sdl gtk"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
- sdl? media-libs/libsdl
- gtk? x11-libs/wxGTK"
+ sdl? ( media-libs/libsdl )
+ gtk? ( x11-libs/wxGTK )"
src_unpack() {
unpack ${A}
diff --git a/app-emulation/bochs/bochs-2.0.ebuild b/app-emulation/bochs/bochs-2.0.ebuild
index d01cfd3c22ea..ec33b0c318e7 100644
--- a/app-emulation/bochs/bochs-2.0.ebuild
+++ b/app-emulation/bochs/bochs-2.0.ebuild
@@ -1,30 +1,30 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.ebuild,v 1.8 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.ebuild,v 1.9 2004/06/27 23:01:44 vapier Exp $
-DESCRIPTION="Bochs is a pc emulator.
-This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
-CDROM drive. It also comes with a disk image using dlxlinux."
+DESCRIPTION="a pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
-HOMEPAGE="http://bochs.sourceforge.net"
+
LICENSE="LGPL-2.1"
SLOT="0"
+KEYWORDS="x86 ~ppc ~alpha"
IUSE="sdl"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11
- sdl? media-libs/libsdl"
-KEYWORDS="x86 ~ppc ~alpha"
+ sdl? ( media-libs/libsdl )"
src_unpack() {
unpack ${P}.tar.gz
- cd $S
- cp Makefile.in Makefile.in.orig
- sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
- -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
+ cd ${S}
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' \
+ Makefile.in
}
src_compile() {
@@ -38,9 +38,7 @@ src_compile() {
emake || die
}
-
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- dodoc CHANGES COPYING CVS README TESTFORM.txt
+ dodoc CHANGES CVS README TESTFORM.txt
}
-
diff --git a/app-emulation/bochs/bochs-2.1.1.ebuild b/app-emulation/bochs/bochs-2.1.1.ebuild
index b670c59bb523..b06ccd8f1f13 100644
--- a/app-emulation/bochs/bochs-2.1.1.ebuild
+++ b/app-emulation/bochs/bochs-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.6 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.7 2004/06/27 23:01:44 vapier Exp $
inherit eutils
@@ -14,11 +14,11 @@ SLOT="0"
KEYWORDS="~x86 ~ppc alpha ~sparc ~amd64"
IUSE="sdl gtk readline"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
- sdl? media-libs/libsdl
- gtk? x11-libs/wxGTK
+ sdl? ( media-libs/libsdl )
+ gtk? ( x11-libs/wxGTK )
readline? sys-libs/readline"
src_unpack() {
diff --git a/app-emulation/bochs/bochs-2.1.ebuild b/app-emulation/bochs/bochs-2.1.ebuild
index 446834bb504b..34ec72a6bbd3 100644
--- a/app-emulation/bochs/bochs-2.1.ebuild
+++ b/app-emulation/bochs/bochs-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.ebuild,v 1.3 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.ebuild,v 1.4 2004/06/27 23:01:44 vapier Exp $
inherit eutils
@@ -14,11 +14,11 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha ~sparc"
IUSE="sdl gtk readline"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
- sdl? media-libs/libsdl
- gtk? x11-libs/wxGTK
+ sdl? ( media-libs/libsdl )
+ gtk? ( x11-libs/wxGTK )
readline? sys-libs/readline"
src_unpack() {
diff --git a/app-emulation/cedega/cedega-4.0.ebuild b/app-emulation/cedega/cedega-4.0.ebuild
index 141bcbc661b3..7d9a892db582 100644
--- a/app-emulation/cedega/cedega-4.0.ebuild
+++ b/app-emulation/cedega/cedega-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-4.0.ebuild,v 1.3 2004/06/24 22:30:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-4.0.ebuild,v 1.4 2004/06/27 23:02:04 vapier Exp $
MY_P="cedega_${PV}-1.i386"
DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
@@ -28,7 +28,7 @@ pkg_nofetch() {
einfo "Then put the file in ${DISTDIR}"
}
-src_install () {
+src_install() {
mv ${WORKDIR}/usr ${D}
}
diff --git a/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.0.ebuild b/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.0.ebuild
index 415291276a8c..e57802f8820d 100644
--- a/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.0.ebuild
+++ b/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.0.ebuild
@@ -1,27 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.0.ebuild,v 1.8 2004/06/24 22:31:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.0.ebuild,v 1.9 2004/06/27 23:02:44 vapier Exp $
DESCRIPTION="Base libraries for emulation of 32bit x86 on amd64/ia64"
-SRC_URI="mirror://gentoo/distfiles/emul-linux-x86-baselibs-1.0.tar.bz2"
-HOMEPAGE=""
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/distfiles/emul-linux-x86-baselibs-${PV}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
+
+S=${WORKDIR}
src_install() {
- cd ${WORKDIR}
- mkdir -p ${D}/emul/linux/x86
- mkdir -p ${D}/emul/linux/x86/lib
- mkdir -p ${D}/emul/linux/x86/usr/lib
- mkdir -p ${D}/lib
- mkdir -p ${D}/usr
- mkdir -p ${D}/etc/env.d
- cp -Rpvf ${WORKDIR}/* ${D}/emul/linux/x86
+ dodir /emul/linux/x86/lib /emul/linux/x86/usr/lib
+ dodir /lib /usr /etc/env.d
+ cp -Rpvf ${WORKDIR}/* ${D}/emul/linux/x86/
ln -sf /emul/linux/x86/lib/ld-linux.so.2 ${D}/lib/ld-linux.so.2
ln -sf /emul/linux/x86/lib ${D}/lib32
ln -sf /emul/linux/x86/usr/lib ${D}/usr/lib32
diff --git a/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.1-r2.ebuild b/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.1-r2.ebuild
index 3d932f833668..df5f40e381d4 100644
--- a/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.1-r2.ebuild
+++ b/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.1-r2.ebuild
@@ -1,20 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.1-r2.ebuild,v 1.5 2004/06/24 22:31:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-1.1-r2.ebuild,v 1.6 2004/06/27 23:02:44 vapier Exp $
DESCRIPTION="Base libraries for emulation of 32bit x86 on amd64"
+HOMEPAGE="http://www.gentoo.org/"
SRC_URI="mirror://gentoo/distfiles/emul-linux-x86-baselibs-1.1.tar.bz2"
-HOMEPAGE=""
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
+
+S=${WORKDIR}
src_install() {
- cd ${WORKDIR}
mkdir -p ${D}/emul/linux/x86
mkdir -p ${D}/emul/linux/x86/lib/dev-state
mkdir -p ${D}/emul/linux/x86/lib/security/pam_filter
diff --git a/app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-1.0.ebuild b/app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-1.0.ebuild
index c78efb6de605..1fb2ab45a8ae 100644
--- a/app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-1.0.ebuild
+++ b/app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-1.0.ebuild
@@ -1,25 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-1.0.ebuild,v 1.3 2004/06/24 22:31:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-1.0.ebuild,v 1.4 2004/06/27 23:03:10 vapier Exp $
DESCRIPTION="QT 2/3 libraries for emulation of 32bit x86 on amd64"
+HOMEPAGE="http://www.gentoo.org/"
SRC_URI="mirror://gentoo/distfiles/emul-linux-x86-qtlibs-1.0.tar.bz2"
-HOMEPAGE=""
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
=app-emulation/emul-linux-x86-xlibs-1.1"
-src_unpack () {
- unpack ${A}
-}
+S=${WORKDIR}
src_install() {
- cd ${WORKDIR}
mkdir -p ${D}/emul/linux/x86
mkdir -p ${D}/emul/linux/x86/usr/qt/2/lib
mkdir -p ${D}/emul/linux/x86/usr/qt/3/lib
diff --git a/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-1.1.ebuild b/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-1.1.ebuild
index be1ee523e774..04ab3c9053ec 100644
--- a/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-1.1.ebuild
+++ b/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-1.1.ebuild
@@ -1,20 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-1.1.ebuild,v 1.7 2004/06/24 22:31:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-1.1.ebuild,v 1.8 2004/06/27 23:03:28 vapier Exp $
DESCRIPTION="X11R6 libraries for emulation of 32bit x86 on amd64"
+HOMEPAGE="http://www.gentoo.org/"
SRC_URI="mirror://gentoo/distfiles/emul-linux-x86-xlibs-1.1.tar.bz2"
-HOMEPAGE=""
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
+
+S=${WORKDIR}
src_install() {
- cd ${WORKDIR}
mkdir -p ${D}/emul/linux/x86
mkdir -p ${D}/emul/linux/x86/usr/lib/opengl
mkdir -p ${D}/emul/linux/x86/usr/X11R6/lib/X11/locale
diff --git a/app-emulation/frodo/frodo-4.1.ebuild b/app-emulation/frodo/frodo-4.1.ebuild
index 516e9547c3fe..de2925adeb44 100644
--- a/app-emulation/frodo/frodo-4.1.ebuild
+++ b/app-emulation/frodo/frodo-4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/frodo/frodo-4.1.ebuild,v 1.6 2004/06/24 22:31:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/frodo/frodo-4.1.ebuild,v 1.7 2004/06/27 23:03:46 vapier Exp $
inherit eutils
@@ -32,7 +32,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
cd ${S}/Src
dobin Frodo FrodoPC FrodoSC TkGui.tcl
cd ${S}
@@ -62,7 +62,7 @@ src_install () {
dohtml -r ${S}/Docs/*.html
}
-pkg_postinst () {
+pkg_postinst() {
einfo " "
einfo " READ THE DOCS! The documentation can be found at: "
einfo " /usr/share/doc/${PN}-${PV}/html/ "
diff --git a/app-emulation/glukalka/glukalka-0.90.1.ebuild b/app-emulation/glukalka/glukalka-0.90.1.ebuild
index 3d79b002329e..0f5ed487baed 100644
--- a/app-emulation/glukalka/glukalka-0.90.1.ebuild
+++ b/app-emulation/glukalka/glukalka-0.90.1.ebuild
@@ -1,24 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/glukalka/glukalka-0.90.1.ebuild,v 1.2 2004/06/24 22:32:18 agriffis Exp $
-
-DESCRIPTION="Emulator of ZX Spectrum 48K/128K and clones"
-HOMEPAGE="http://glukalka.sourceforge.net"
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/glukalka/glukalka-0.90.1.ebuild,v 1.3 2004/06/27 23:04:11 vapier Exp $
# set MY_P to glukalka-0.90-1 instead of original glukalka-0.90.1
MY_P=${PN}-${PV%.*}-${PV##*.}
+DESCRIPTION="Emulator of ZX Spectrum 48K/128K and clones"
+HOMEPAGE="http://glukalka.sourceforge.net"
SRC_URI="mirror://sourceforge/glukalka/${MY_P}.tar.bz2"
-RESTRICT="nomirror"
+
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc"
SLOT="0"
+KEYWORDS="~x86 ~ppc"
IUSE=""
RDEPEND="x11-libs/openmotif
virtual/x11
- virtual/glibc"
-
+ virtual/libc"
DEPEND="${RDEPEND}
>=sys-apps/sed-4
sys-devel/gcc"
@@ -41,7 +39,7 @@ src_unpack() {
}
src_install() {
- dobin glukalka
+ dobin glukalka || die
dodir /usr/share/glukalka
cp -R resources ${D}/usr/share/glukalka
cp -R icons ${D}/usr/share/glukalka
diff --git a/app-emulation/hercules/hercules-2.17.1-r1.ebuild b/app-emulation/hercules/hercules-2.17.1-r1.ebuild
index b81f4a73b5a5..805e8e7107ca 100644
--- a/app-emulation/hercules/hercules-2.17.1-r1.ebuild
+++ b/app-emulation/hercules/hercules-2.17.1-r1.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-2.17.1-r1.ebuild,v 1.8 2004/06/24 22:32:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-2.17.1-r1.ebuild,v 1.9 2004/06/27 23:04:29 vapier Exp $
DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
-SRC_URI="http://www.conmicro.cx/hercules/${P}.tar.gz"
HOMEPAGE="http://www.conmicro.cx/hercules/"
+SRC_URI="http://www.conmicro.cx/hercules/${P}.tar.gz"
LICENSE="QPL-1.0"
SLOT="0"
KEYWORDS="x86 ~ppc alpha ~sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
app-arch/bzip2"
src_compile() {
diff --git a/app-emulation/hercules/hercules-3.00.ebuild b/app-emulation/hercules/hercules-3.00.ebuild
index a3154c7eba63..dcd67937c4ca 100644
--- a/app-emulation/hercules/hercules-3.00.ebuild
+++ b/app-emulation/hercules/hercules-3.00.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.00.ebuild,v 1.5 2004/06/24 22:32:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.00.ebuild,v 1.6 2004/06/27 23:04:29 vapier Exp $
DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
-SRC_URI="http://www.conmicro.cx/hercules/${P}.tar.gz"
HOMEPAGE="http://www.conmicro.cx/hercules/"
+SRC_URI="http://www.conmicro.cx/hercules/${P}.tar.gz"
LICENSE="QPL-1.0"
SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha ~sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
app-arch/bzip2"
src_compile() {
diff --git a/app-emulation/hercules/hercules-3.01.ebuild b/app-emulation/hercules/hercules-3.01.ebuild
index f4edf735ec7f..88eacd78d33c 100644
--- a/app-emulation/hercules/hercules-3.01.ebuild
+++ b/app-emulation/hercules/hercules-3.01.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.01.ebuild,v 1.5 2004/06/24 22:32:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.01.ebuild,v 1.6 2004/06/27 23:04:29 vapier Exp $
inherit flag-o-matic
DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
-SRC_URI="http://www.conmicro.cx/hercules/${P}.tar.gz"
HOMEPAGE="http://www.conmicro.cx/hercules/"
+SRC_URI="http://www.conmicro.cx/hercules/${P}.tar.gz"
LICENSE="QPL-1.0"
SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha ~sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
app-arch/bzip2"
-replace-flags -march=pentium3 -mcpu=pentium3
src_compile() {
+ replace-flags -march=pentium3 -mcpu=pentium3
local mycflags
mycflags="${CFLAGS}"
unset CFLAGS ; unset CXXFLAGS
diff --git a/app-emulation/i8086emu/i8086emu-0.9.1.ebuild b/app-emulation/i8086emu/i8086emu-0.9.1.ebuild
index 20135143df8d..db811a4f6a43 100644
--- a/app-emulation/i8086emu/i8086emu-0.9.1.ebuild
+++ b/app-emulation/i8086emu/i8086emu-0.9.1.ebuild
@@ -1,23 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/i8086emu/i8086emu-0.9.1.ebuild,v 1.4 2004/06/24 22:32:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/i8086emu/i8086emu-0.9.1.ebuild,v 1.5 2004/06/27 23:04:50 vapier Exp $
inherit eutils
DESCRIPTION="Emulator for the Intel 8086 microprocessor"
-HOMEPAGE="http://i8086emu.sourceforge.net"
+HOMEPAGE="http://i8086emu.sourceforge.net/"
SRC_URI="mirror://sourceforge/i8086emu/i8086emu-src-${PV}.tar.bz2"
-RESTRICT="nomirror"
-S=${WORKDIR}/i8086emu-src-${PV}
LICENSE="GPL-2"
SLOT="0"
-#KEYWORDS="x86 ~alpha ~amd64"
KEYWORDS="x86 ~ppc"
IUSE="X"
RDEPEND="sys-libs/ncurses
- virtual/glibc
+ virtual/libc
X? ( dev-libs/glib
dev-libs/atk
media-libs/fontconfig
@@ -27,19 +24,19 @@ RDEPEND="sys-libs/ncurses
sys-libs/zlib
dev-libs/expat
>=x11-libs/gtk+-2.0.0 )"
-
DEPEND="${RDEPEND}
sys-devel/gcc
sys-devel/autoconf
dev-util/pkgconfig"
+S=${WORKDIR}/i8086emu-src-${PV}
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}.patch
}
src_compile() {
-
local myconf
use X || myconf="usegtk=0"
@@ -48,7 +45,5 @@ src_compile() {
}
src_install() {
-
- emake DESTDIR=${D} infodir=/usr/share/doc/${P} examplesdir=/usr/share/doc/${P}/examples install
-
+ make DESTDIR=${D} infodir=/usr/share/doc/${P} examplesdir=/usr/share/doc/${P}/examples install || die
}